Mint v19.3 audio popping

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
User avatar
MrEen
Level 20
Level 20
Posts: 10741
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint v19.3 audio popping

Post by MrEen »

Okay, I think this is my last hope (although I often say that then come up with other things to try) but let's just see what happens with this:

Code: Select all

sudo tee /etc/modprobe.d/blacklist-ac97.conf <<<'blacklist ac97_bus'
Reboot after that and if the boom happens on startup, you can undo it with this:

Code: Select all

sudo rm /etc/modprobe.d/blacklist-ac97.conf

jalin
Level 1
Level 1
Posts: 40
Joined: Thu Mar 05, 2020 8:57 pm

Re: Mint v19.3 audio popping

Post by jalin »

no dice -- startup and shutdown booms remain. thanks for your continued support!

jalin
Level 1
Level 1
Posts: 40
Joined: Thu Mar 05, 2020 8:57 pm

Re: Mint v19.3 audio popping

Post by jalin »

MrEen, something new for ya... now I am seemingly randomly getting spontaneous, sustained boom/buzz drones coming from my audio out

I was listening to some music. Turned it off, got up from computer went to other room and then suddenly BUZZZZZBZBZBZBZBZBZB... had to run in and shut down the speakers

(my sound system has no independent volume level control, other than on the sub)

Horrendous. Was gonna watch a movie tonight but now I'm honestly scared, lol

jalin
Level 1
Level 1
Posts: 40
Joined: Thu Mar 05, 2020 8:57 pm

Re: Mint v19.3 audio popping

Post by jalin »

by the way I don't get these sounds coming out of my onboard laptop speakers --- so the problem is only be emitted from the audio out

User avatar
MrEen
Level 20
Level 20
Posts: 10741
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint v19.3 audio popping

Post by MrEen »

jalin wrote:
Sat Jul 04, 2020 2:42 pm
by the way I don't get these sounds coming out of my onboard laptop speakers --- so the problem is only be emitted from the audio out
I'm starting to wonder if this is a hardware issue. Could be an issue with the port. I'd certainly try cleaning out the port for starters.

jalin
Level 1
Level 1
Posts: 40
Joined: Thu Mar 05, 2020 8:57 pm

Re: Mint v19.3 audio popping

Post by jalin »

if it was a hardware as opposed to software problem, unlikely would be getting the repeatable startup and shutdown boom patterns

User avatar
MrEen
Level 20
Level 20
Posts: 10741
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint v19.3 audio popping

Post by MrEen »

Well, there could be an issue with the port, when the amp turns on/off, is what I was thinking. Do you have something else you could plug into the same port to test with? Just want to rule out the wires of what you're presently using.

jalin
Level 1
Level 1
Posts: 40
Joined: Thu Mar 05, 2020 8:57 pm

Re: Mint v19.3 audio popping

Post by jalin »

headphones pop as well (startup), plugged into same port. shutdown I don't hear it but it's mainly a low frequency tone so that may be why. definitely popping on startup though with different gear plugged into same port (1/8" line out)

User avatar
MrEen
Level 20
Level 20
Posts: 10741
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint v19.3 audio popping

Post by MrEen »

So, the issue seems to be when the amp turns on or off, you get these noises, but not from your built-in speakers. I'm afraid that kind of thing is a little over my head. I think we've tried everything we can to eliminate what we can in the OS.

The only thing I can think of to try to prevent this is to redirect the output before you shut down. You could create a script to run at shutdown that redirects the output, then shuts down the computer all in one. Then after the computer boots up and you've logged in, you redirect the output back to where it should be. To help with this idea, I'd need to see the output of pacmd list-cards with your setup working as it should be.

jalin
Level 1
Level 1
Posts: 40
Joined: Thu Mar 05, 2020 8:57 pm

Re: Mint v19.3 audio popping

Post by jalin »

Code: Select all

1 card(s) available.
    index: 0
	name: <alsa_card.pci-0000_00_1f.3>
	driver: <module-alsa-card.c>
	owner module: 7
	properties:
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0x604b118000 irq 178"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1f.3"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "02c8"
		device.form_factor = "internal"
		device.string = "0"
		device.description = "Built-in Audio"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	profiles:
		input:analog-stereo: Analog Stereo Input (priority 60, available: unknown)
		output:analog-stereo: Analog Stereo Output (priority 6000, available: unknown)
		output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (priority 6060, available: unknown)
		output:hdmi-stereo: Digital Stereo (HDMI) Output (priority 5400, available: unknown)
		output:hdmi-stereo+input:analog-stereo: Digital Stereo (HDMI) Output + Analog Stereo Input (priority 5460, available: unknown)
		output:hdmi-stereo-extra1: Digital Stereo (HDMI 2) Output (priority 5200, available: no)
		output:hdmi-stereo-extra1+input:analog-stereo: Digital Stereo (HDMI 2) Output + Analog Stereo Input (priority 5260, available: unknown)
		output:hdmi-surround-extra1: Digital Surround 5.1 (HDMI 2) Output (priority 100, available: no)
		output:hdmi-surround-extra1+input:analog-stereo: Digital Surround 5.1 (HDMI 2) Output + Analog Stereo Input (priority 160, available: unknown)
		output:hdmi-surround71-extra1: Digital Surround 7.1 (HDMI 2) Output (priority 100, available: no)
		output:hdmi-surround71-extra1+input:analog-stereo: Digital Surround 7.1 (HDMI 2) Output + Analog Stereo Input (priority 160, available: unknown)
		output:hdmi-stereo-extra2: Digital Stereo (HDMI 3) Output (priority 5200, available: no)
		output:hdmi-stereo-extra2+input:analog-stereo: Digital Stereo (HDMI 3) Output + Analog Stereo Input (priority 5260, available: unknown)
		output:hdmi-surround-extra2: Digital Surround 5.1 (HDMI 3) Output (priority 100, available: no)
		output:hdmi-surround-extra2+input:analog-stereo: Digital Surround 5.1 (HDMI 3) Output + Analog Stereo Input (priority 160, available: unknown)
		output:hdmi-surround71-extra2: Digital Surround 7.1 (HDMI 3) Output (priority 100, available: no)
		output:hdmi-surround71-extra2+input:analog-stereo: Digital Surround 7.1 (HDMI 3) Output + Analog Stereo Input (priority 160, available: unknown)
		output:hdmi-stereo-extra3: Digital Stereo (HDMI 4) Output (priority 5200, available: no)
		output:hdmi-stereo-extra3+input:analog-stereo: Digital Stereo (HDMI 4) Output + Analog Stereo Input (priority 5260, available: unknown)
		output:hdmi-surround-extra3: Digital Surround 5.1 (HDMI 4) Output (priority 100, available: no)
		output:hdmi-surround-extra3+input:analog-stereo: Digital Surround 5.1 (HDMI 4) Output + Analog Stereo Input (priority 160, available: unknown)
		output:hdmi-surround71-extra3: Digital Surround 7.1 (HDMI 4) Output (priority 100, available: no)
		output:hdmi-surround71-extra3+input:analog-stereo: Digital Surround 7.1 (HDMI 4) Output + Analog Stereo Input (priority 160, available: unknown)
		output:hdmi-stereo-extra4: Digital Stereo (HDMI 5) Output (priority 5200, available: no)
		output:hdmi-stereo-extra4+input:analog-stereo: Digital Stereo (HDMI 5) Output + Analog Stereo Input (priority 5260, available: unknown)
		output:hdmi-surround-extra4: Digital Surround 5.1 (HDMI 5) Output (priority 100, available: no)
		output:hdmi-surround-extra4+input:analog-stereo: Digital Surround 5.1 (HDMI 5) Output + Analog Stereo Input (priority 160, available: unknown)
		output:hdmi-surround71-extra4: Digital Surround 7.1 (HDMI 5) Output (priority 100, available: no)
		output:hdmi-surround71-extra4+input:analog-stereo: Digital Surround 7.1 (HDMI 5) Output + Analog Stereo Input (priority 160, available: unknown)
		off: Off (priority 0, available: unknown)
	active profile: <output:analog-stereo+input:analog-stereo>
	sinks:
		alsa_output.pci-0000_00_1f.3.analog-stereo/#0: Built-in Audio Analog Stereo
	sources:
		alsa_output.pci-0000_00_1f.3.analog-stereo.monitor/#0: Monitor of Built-in Audio Analog Stereo
		alsa_input.pci-0000_00_1f.3.analog-stereo/#1: Built-in Audio Analog Stereo
	ports:
		analog-input-internal-mic: Internal Microphone (priority 8900, latency offset 0 usec, available: unknown)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-input-headphone-mic: Microphone (priority 8700, latency offset 0 usec, available: unknown)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-input-headset-mic: Headset Microphone (priority 8800, latency offset 0 usec, available: unknown)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
			properties:
				device.icon_name = "audio-speakers"
		analog-output-headphones: Headphones (priority 9000, latency offset 0 usec, available: yes)
			properties:
				device.icon_name = "audio-headphones"
		hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: yes)
			properties:
				device.icon_name = "video-display"
				device.product.name = "LG Ultra HD"
		hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-2: HDMI / DisplayPort 3 (priority 5700, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-3: HDMI / DisplayPort 4 (priority 5600, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-4: HDMI / DisplayPort 5 (priority 5500, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"

User avatar
MrEen
Level 20
Level 20
Posts: 10741
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint v19.3 audio popping

Post by MrEen »

Okay, let's first test if my idea holds water. Run pacmd set-sink-port 0 analog-output-speaker then reboot. Tell me if either sound occurs.

jalin
Level 1
Level 1
Posts: 40
Joined: Thu Mar 05, 2020 8:57 pm

Re: Mint v19.3 audio popping

Post by jalin »

Yup, both startup and shutdown booms occur. When runnnig the command, audio switches to laptop builtlin speakers as expected

Perhaps the port can be shutdown altogether? Or is that what you've effectively done...

jalin
Level 1
Level 1
Posts: 40
Joined: Thu Mar 05, 2020 8:57 pm

Re: Mint v19.3 audio popping

Post by jalin »

Btw, when I dual boot into windows there is no startup or shutdown boom

There is only a single boom (much quieter) when the machine is already powered down and I power it up (before bios or anything loads)

User avatar
MrEen
Level 20
Level 20
Posts: 10741
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint v19.3 audio popping

Post by MrEen »

Well, I'm lost at this point. At least you've confirmed it's not really a port issue with the difference in Windows.

Maybe this one will stop it:

Code: Select all

pacmd set-card-profile alsa_card.pci-0000_00_1f.3 output:hdmi-stereo
Reboot and tell me what happens.

jalin
Level 1
Level 1
Posts: 40
Joined: Thu Mar 05, 2020 8:57 pm

Re: Mint v19.3 audio popping

Post by jalin »

startup and shutdown booms remain.

I guess we're certain it's a linux issue though, yes?

I'm also having another problem you may be able to assist me with, (lol, thanks)
viewtopic.php?f=49&t=323846&p=1840114#p1840114

User avatar
MrEen
Level 20
Level 20
Posts: 10741
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint v19.3 audio popping

Post by MrEen »

Yeah, it's an issue in Linux I'd say. The coding underbelly has ramps that aren't sufficient is my guess. I.e. sound ramps up from zero at boot, then ramps down to zero on shutdown. That's way above my pay grade though. There's a new audio driver that might fix this issue, but I'm not sure how to force it into use in your case. Try this then reboot and see if the sound works:

Code: Select all

sudo tee /etc/modprobe.d/alsa-fix.conf <<<'options snd-intel-dspcfg dsp_driver=0'
Last edited by MrEen on Sun Jul 05, 2020 4:35 pm, edited 1 time in total.

jalin
Level 1
Level 1
Posts: 40
Joined: Thu Mar 05, 2020 8:57 pm

Re: Mint v19.3 audio popping

Post by jalin »

thanks for your endless attempts! no change

I was thinking that ... no ramp up/down , or the ramp is too short

Although not sure that would explain the sustained shutdown boom (probably 3 seconds)... or that the startup booms are over a period of about 2 seconds

I'd love to try a different driver altogether

User avatar
MrEen
Level 20
Level 20
Posts: 10741
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint v19.3 audio popping

Post by MrEen »

Try the above with number other than 0 or 1. 1 = the old driver that you're running. So try 2 through 5 rebooting in between each. You can check inxi -A after each reboot to see if the driver has changed.

Also note I fixed my url in place of code in the previous reply.

jalin
Level 1
Level 1
Posts: 40
Joined: Thu Mar 05, 2020 8:57 pm

Re: Mint v19.3 audio popping

Post by jalin »

thanks yea I quoted the link earlier to extract the code

I tried 2, 3, 4, 5

3-5 all no good

'2', no booms, startup or shutdown! however, no sound either. When I go to sound menu, the only option available is 'dummy output'. Tried restarting pulseaudio but still just dummy output avaiable

when in 2, inxi -A gives

Code: Select all

Audio:
  Device-1: Intel driver: N/A 
  Sound Server: ALSA v: k5.3.0-59-generic 

User avatar
MrEen
Level 20
Level 20
Posts: 10741
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint v19.3 audio popping

Post by MrEen »

Ohhhhhh. Upgrade the kernel to the latest 5.4 kernel. I'm not certain, but that might be necessary for the previous tries.

Post Reply

Return to “Sound, Multimedia, & Codecs”