Page 1 of 2

Mint v19.3 audio popping

Posted: Thu Dec 19, 2019 1:39 pm
by heavilyredacted
I installed mint v19.3 Tricia yesterday. It's working fine except that a sometimes startlingly loud popping noise is produced whenever an audio/video file begins. Is there a way to resolve this without downgrading to v19.2?

Re: Mint v19.3 audio popping

Posted: Thu Dec 19, 2019 1:46 pm
by Flemur
heavilyredacted wrote:
Thu Dec 19, 2019 1:39 pm
I installed mint v19.3 Tricia yesterday. It's working fine except that a sometimes startlingly loud popping noise is produced whenever an audio/video file begins. Is there a way to resolve this without downgrading to v19.2?
FWIW, I get the same thing with 19.3, not otherwise.

Re: Mint v19.3 audio popping

Posted: Thu Dec 19, 2019 2:27 pm
by JoeBingo
Yep, noticed it too when I installed 19.3 last night. Even pops when visiting a site that has audio features even if they aren't currently playing. Hoping things will settle down. 19.2 sound would sometimes pop when doing a system reboot / restart but not otherwise on my desktop.

Re: Mint v19.3 audio popping

Posted: Thu Dec 19, 2019 4:22 pm
by MrEen
There was an update to pulseaudio a few days ago. I wonder if something in the update is causing this.

Sounds as though the amp isn't ramping up to full volume gradually and is jumping from off to fully on.

Re: Mint v19.3 audio popping

Posted: Thu Dec 19, 2019 4:56 pm
by JoeBingo
Think it's a power issue. Seems power to audio is disabled after 10 seconds if not being actively used ... or something like that ... and apparently the pop is when sound is re-enabled for a site or audio file.

I guess it depends on hardware, but the solution at this link fixed my popping problem and there is also a link in the solution to a youtube video for further explanation and is worth a watch ... https://superuser.com/questions/1493096 ... ew-seconds

I THINK basically the fix keeps the sound from "going to sleep". This fix may not be ideal for a laptop on battery power.

Re: Mint v19.3 audio popping

Posted: Thu Dec 19, 2019 5:07 pm
by MrEen
JoeBingo wrote:
Thu Dec 19, 2019 4:56 pm
Think it's a power issue. Seems power to audio is disabled after 10 seconds if not being actively used ... or something like that ... and apparently the pop is when sound is re-enabled for a site or audio file.

I guess it depends on hardware, but the solution at this link fixed my popping problem and there is also a link in the solution to a youtube video for further explanation and is worth a watch ... https://superuser.com/questions/1493096 ... ew-seconds

I THINK basically the fix keeps the sound from "going to sleep". This fix may not be ideal for a laptop on battery power.
Yeah, some hardware has always needed the power_save/power_save_controller settings change. But this sounds like a change has been made that needs to be fixed.

Re: Mint v19.3 audio popping

Posted: Thu Dec 19, 2019 6:20 pm
by gm10
MrEen wrote:
Thu Dec 19, 2019 5:07 pm
But this sounds like a change has been made that needs to be fixed.
Maybe the 4.15 kernel had Intel HDA power saving disabled? Frankly I don't recall, it's been making that sound for years when entering power save mode. Which brings substantial battery savings btw.

Re: Mint v19.3 audio popping

Posted: Thu Dec 19, 2019 6:26 pm
by MrEen
gm10 wrote:
Thu Dec 19, 2019 6:20 pm
MrEen wrote:
Thu Dec 19, 2019 5:07 pm
But this sounds like a change has been made that needs to be fixed.
Defaulting to power saving on isn't exactly what I would call something needing to be fixed. My laptop gains substantial amounts of battery life with the audio subsystem in power saving mode, many people work on those things rather than listen to music/videos. :)
What I meant was something has changed were people that didn't need to disable power saving previously are now getting the nasty pops. I haven't had a 19.3 system up for a few days, but has there been an update to ALSA? I can't really see a pulseaudio change causing this.

Re: Mint v19.3 audio popping

Posted: Thu Dec 19, 2019 6:43 pm
by gm10
MrEen wrote:
Thu Dec 19, 2019 6:26 pm
What I meant was something has changed were people that didn't need to disable power saving previously are now getting the nasty pops.
Yes, I realized that and had edited that post long before you posted. But those pops have always been around with power saving enabled, they have been happening for years.

Re: Mint v19.3 audio popping

Posted: Thu Dec 19, 2019 6:54 pm
by MrEen
Gotcha. Looks like you were correct about 4.15:

Code: Select all

scott@scott-HP ~ $ cat /sys/module/snd_hda_intel/parameters/power_save_controller
Y
scott@scott-HP ~ $ cat /sys/module/snd_hda_intel/parameters/power_save
0
My 19.3 install is in a VM and doesn't use snd-hda-intel, so no equivalent parameters there.

Re: Mint v19.3 audio popping

Posted: Thu Dec 19, 2019 11:28 pm
by JoeBingo
MrEen wrote:
Thu Dec 19, 2019 6:54 pm
Gotcha. Looks like you were correct about 4.15:

Code: Select all

scott@scott-HP ~ $ cat /sys/module/snd_hda_intel/parameters/power_save_controller
Y
scott@scott-HP ~ $ cat /sys/module/snd_hda_intel/parameters/power_save
0
My 19.3 install is in a VM and doesn't use snd-hda-intel, so no equivalent parameters there.
Curious ... wonder why the controller was left in the enabled (Y) state when the power save feature was disabled (0) in the 4.15 kernel?

Re: Mint v19.3 audio popping

Posted: Fri Dec 20, 2019 4:58 am
by gm10
You are misunderstanding the flag:

Code: Select all

parm:           power_save_controller:Reset controller in power save mode. (bool)

Re: Mint v19.3 audio popping

Posted: Fri Dec 20, 2019 8:35 am
by dev0
I have the same issue after upgrade to 19.3.
Any solution found?

Re: Mint v19.3 audio popping

Posted: Fri Dec 20, 2019 8:49 am
by gm10
dev0 wrote:
Fri Dec 20, 2019 8:35 am
I have the same issue after upgrade to 19.3.
Any solution found?
Your options are to go back to the 4.15 kernel series or to disable power management for Intel's HDA driver:

Code: Select all

sudo tee /etc/modprobe.d/snd-hda-intel.conf <<<'options snd-hda-intel power_save=0'
(takes effect on reboot)

Re: Mint v19.3 audio popping

Posted: Fri Dec 20, 2019 10:42 am
by JoeBingo
gm10 wrote:
Fri Dec 20, 2019 4:58 am
You are misunderstanding the flag:

Code: Select all

parm:           power_save_controller:Reset controller in power save mode. (bool)
Okay, so the controller (Y) is more like a persistence than an enable (feels like I'm not finding the right word), regarding the state of power save, I guess. The link I posted earlier suggested power save (0) and power save controller (N). Just trying to wrap my head around why 4.15 would do it one way and not the other.

EDIT: After the 4.15 reveal, I change the controller back to (Y) while leaving power save (0) ... no popping. Since battery power isn't an issue with my desktop, I'm a happy camper.

EDIT 2: While the audio power save feature may enable "substantial" battery savings, I don't recall any thread complaints concerning battery power duration due to no/disabled audio power save when everyone was using 4.15. Just an observation.

Re: Mint v19.3 audio popping

Posted: Fri Dec 20, 2019 3:27 pm
by RamBurner
This worked on my desktop, thank you

Your only options are to either deal with it or to disable power management for Intel's HDA driver:

Code: Select all

sudo tee /etc/modprobe.d/snd-hda-intel.conf <<<'options snd-hda-intel power_save=0'
(takes effect on reboot)

Re: Mint v19.3 audio popping

Posted: Fri Dec 20, 2019 3:29 pm
by gm10
You're welcome. :)

Re: Mint v19.3 audio popping

Posted: Mon Dec 23, 2019 4:28 am
by dev0
gm10 wrote:
Fri Dec 20, 2019 8:49 am
dev0 wrote:
Fri Dec 20, 2019 8:35 am
I have the same issue after upgrade to 19.3.
Any solution found?
Your only options are to either deal with it or to disable power management for Intel's HDA driver:

Code: Select all

sudo tee /etc/modprobe.d/snd-hda-intel.conf <<<'options snd-hda-intel power_save=0'
(takes effect on reboot)
Thanks, popping sound is gone

Re: Mint v19.3 audio popping

Posted: Tue Dec 24, 2019 8:21 am
by Tater
Thank you so very much!

I upgraded from 19.2 a few days ago and the "pop-pop" when I started an audio file or video was really annoying me. It has always there in the boot sequence, but that is only when booting when it is supposed to be doing things. When you are actually using the computer it is just "wrong". :lol:
gm10 wrote:
Fri Dec 20, 2019 8:49 am
dev0 wrote:
Fri Dec 20, 2019 8:35 am
I have the same issue after upgrade to 19.3.
Any solution found?
Your only options are to either deal with it or to disable power management for Intel's HDA driver:

Code: Select all

sudo tee /etc/modprobe.d/snd-hda-intel.conf <<<'options snd-hda-intel power_save=0'
(takes effect on reboot)

Re: Mint v19.3 audio popping

Posted: Wed Dec 25, 2019 10:17 pm
by Flexan
wonder if something in the update is causing this.