[solved] Sound fades in

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
Infidelus
Level 1
Level 1
Posts: 49
Joined: Mon Feb 25, 2019 3:14 pm

[solved] Sound fades in

Post by Infidelus »

Hi,

I just built myself a new PC and reinstalled Mint, but with every application now the sound fades in over a couple of seconds when it starts. I can't see any obvious settings that would cause this or work out why this would happen with a new motherboard so I'm hoping someone can point me in the right direction.

System info:

Code: Select all

System:    Host: linux-pc Kernel: 5.3.0-28-generic x86_64 bits: 64 compiler: gcc v: 7.4.0 
           Desktop: Cinnamon 4.4.8 wm: muffin dm: LightDM Distro: Linux Mint 19.3 Tricia 
           base: Ubuntu 18.04 bionic 
Machine:   Type: Desktop System: Micro-Star product: MS-7C02 v: 1.0 serial: <filter> 
           Mobo: Micro-Star model: B450 TOMAHAWK MAX (MS-7C02) v: 1.0 serial: <filter> 
           UEFI: American Megatrends v: 3.50 date: 11/07/2019 
Battery:   Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard K270 serial: <filter> 
           charge: 55% status: Discharging 
CPU:       Topology: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 
           L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 86400 
           Speed: 2200 MHz min/max: 2200/3600 MHz Core speeds (MHz): 1: 2200 2: 2199 3: 2075 
           4: 2069 5: 2199 6: 4146 7: 2075 8: 2072 9: 2199 10: 2199 11: 2200 12: 4150 
Graphics:  Device-1: NVIDIA vendor: Gigabyte driver: nvidia v: 440.59 bus ID: 26:00.0 
           chip ID: 10de:1f02 
           Display: x11 server: X.Org 1.20.5 driver: nvidia 
           unloaded: fbdev,modesetting,nouveau,vesa resolution: 2560x1440~144Hz 
           OpenGL: renderer: GeForce RTX 2070/PCIe/SSE2 v: 4.6.0 NVIDIA 440.59 direct render: Yes 
Audio:     Device-1: NVIDIA vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 26:00.1 
           chip ID: 10de:10f9 
           Device-2: AMD vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 28:00.4 
           chip ID: 1022:1487 
           Sound Server: ALSA v: k5.3.0-28-generic 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI 
           driver: r8169 v: kernel port: f000 bus ID: 22:00.0 chip ID: 10ec:8168 
           IF: enp34s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Microsoft Xbox 360 Wireless Adapter type: USB driver: xpad bus ID: 5-2:3 
           chip ID: 045e:0719 
Last edited by Infidelus on Fri Feb 14, 2020 7:51 am, edited 1 time in total.
User avatar
MrEen
Level 22
Level 22
Posts: 15169
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound fades in

Post by MrEen »

Hi Infidelus.

This is worth a shot:
gm10 wrote:
Fri Dec 20, 2019 8:49 am

Your only options are to either deal with it or to disable power management for Intel's HDA driver:

Code: Select all

sudo tee /etc/modprobe.d/snd-hda-intel.conf <<<'options snd-hda-intel power_save=0'
(takes effect on reboot)
It might be the audio power management is slow to react, and with a desktop, you don't really need the power management anyway.
Infidelus
Level 1
Level 1
Posts: 49
Joined: Mon Feb 25, 2019 3:14 pm

Re: Sound fades in

Post by Infidelus »

Thanks, I'll give it a go. As you say there's no real need for power management on a desktop, especially as I usually either have music, video or games running :)
Infidelus
Level 1
Level 1
Posts: 49
Joined: Mon Feb 25, 2019 3:14 pm

Re: [solved] Sound fades in

Post by Infidelus »

Just to confirm, after changing the setting and rebooting the fade-in problem seems to have gone away. Thanks again :)
User avatar
MrEen
Level 22
Level 22
Posts: 15169
Joined: Mon Jun 12, 2017 8:39 pm

Re: [solved] Sound fades in

Post by MrEen »

That's great!

Happy to help. :D
Sobieski
Level 1
Level 1
Posts: 17
Joined: Fri Aug 17, 2012 2:48 am
Location: Undisclosed Location, Australia

Re: [solved] Sound fades in

Post by Sobieski »

Hi:

I've been having issues with annoying short (ca. 1 sec.) fade-ins after a few seconds of silence in audio files (I'm using language teaching materials) and so the spoken material in those files isn't fully uttered for the students to hear - most annoying!!!

I followed the tips in this thread and I even removed power management from the startup apps, but to no avail. I'm STILL having the same annoying fad-ins after a short silence in the audio.

At the moment, I'm using Mint 19.3 Mate on an ASUS VivoBook Flip 14 laptop (Intel i7 8th gen) NVidia Geforce 930MX.

Anything I'm missing??
Sobieski
Level 1
Level 1
Posts: 17
Joined: Fri Aug 17, 2012 2:48 am
Location: Undisclosed Location, Australia

Re: [solved] Sound fades in

Post by Sobieski »

It seems that after a couple of re-boots, the problem has resolved itself. :D
User avatar
MrEen
Level 22
Level 22
Posts: 15169
Joined: Mon Jun 12, 2017 8:39 pm

Re: [solved] Sound fades in

Post by MrEen »

Hi Sobieski,

That command certainly requires a reboot to become active. It's a bit odd that it required more for you.

Just in case this issue returns, also changing this might help:

In the terminal run xed admin:///etc/pulse/default.pa and find this section:

Code: Select all

### Automatically suspend sinks/sources that become idle for too long
load-module module-suspend-on-idle
Change it to this:

Code: Select all

### Automatically suspend sinks/sources that become idle for too long
# load-module module-suspend-on-idle
Again, reboot to make the change active. This one was necessary just this past weekend for one user.
Sobieski
Level 1
Level 1
Posts: 17
Joined: Fri Aug 17, 2012 2:48 am
Location: Undisclosed Location, Australia

Re: [solved] Sound fades in

Post by Sobieski »

Hi MrEen:

Thanks for your reply. I'll keep these things in mind should I encounter any misbehaviour from the beast.

There's quite a few things about the more recent iterations of Mint that leave me scratching my head and wondering about what the hell is going on. I guess the mint 17.3 benchmark has yet to be reached again.
User avatar
MrEen
Level 22
Level 22
Posts: 15169
Joined: Mon Jun 12, 2017 8:39 pm

Re: [solved] Sound fades in

Post by MrEen »

Sobieski wrote:
Mon Oct 05, 2020 1:46 pm
There's quite a few things about the more recent iterations of Mint that leave me scratching my head and wondering about what the hell is going on. I guess the mint 17.3 benchmark has yet to be reached again.
I've read many posts from users that think the same. There's just so much that has changed since then, I couldn't even tell you how much might be Mint's fault. Things like the newer Python and newer GTK+ deprecated a lot of things that users enjoyed. Not to mention many apps from back then becoming abandonware.

But it's the same everywhere. When I was on Windows, I taught myself to program in Visual Basic 6. Just when I got really comfortable using it, it was replaced with VB.NET. I briefly checked the differences and then gave up on programming at that time. Still smacking myself for that decision!
Sobieski
Level 1
Level 1
Posts: 17
Joined: Fri Aug 17, 2012 2:48 am
Location: Undisclosed Location, Australia

Re: [solved] Sound fades in

Post by Sobieski »

Indeed. I'm a bit miffed (putting it lightly) that many of the themes I had used up till 17.3 are now impossible to use with Compiz. I miss those Mac Aqua themes with the pearly blue buttons (with wobbly windows)!!

Is there any indication that the Mint boys are getting their act together any time soon in a timely manner???
User avatar
MrEen
Level 22
Level 22
Posts: 15169
Joined: Mon Jun 12, 2017 8:39 pm

Re: [solved] Sound fades in

Post by MrEen »

Well, they've got their act together as far as I'm concerned.

I found this and this for your Aqua wish, but as usual, it GTK2 only. Someone would need to port it to GTK3 for it to work on any modern Linux OS. I'm still using Mint 18.3 where that would work. I'm not certain about the 19 versions. It certainly won't work on 20. And the second link is for KDE, which Mint doesn't ship with anymore. It's possible it would work on other desktop environments, although that's beyond my knowledge.
Sobieski
Level 1
Level 1
Posts: 17
Joined: Fri Aug 17, 2012 2:48 am
Location: Undisclosed Location, Australia

Re: [solved] Sound fades in

Post by Sobieski »

How does one port to GTK 3?? Is it overly technical that requires years of study or can one teach oneself in a relatively short time?
User avatar
MrEen
Level 22
Level 22
Posts: 15169
Joined: Mon Jun 12, 2017 8:39 pm

Re: [solved] Sound fades in

Post by MrEen »

Sobieski wrote:
Fri Oct 16, 2020 10:14 am
How does one port to GTK 3?? Is it overly technical that requires years of study or can one teach oneself in a relatively short time?
As far as I know, by rewriting all the old code. For example, I use the Cinnamox-Rhino theme. Because my system is still mostly GTK2, the main theme file starts with this:

Code: Select all

gtk-color-scheme =
"base_color:#3b444c\nbg_color:#434e5a\ntooltip_bg_color:#434e5a\nselected_bg_color:#3d80cc\ntext_color:#d8e5f2\nfg_color:#d8e5f2\ntooltip_fg_color:#d8e5f2\nselected_fg_color:#000000\nmenubar_bg_color:#1c2126\nmenubar_fg_color:#d8e5f2\ntoolbar_bg_color:#434e5a\ntoolbar_fg_color:#d8e5f2\nmenu_bg_color:#1c2126\nmenu_fg_color:#d8e5f2\npanel_bg_color:#434e5a\npanel_fg_color:#d8e5f2\nlink_color:#a9cdf2\nbtn_bg_color:#3b444c\nbtn_fg_color:#d8e5f2\ntitlebar_bg_color:#1c2126\ntitlebar_fg_color:#d8e5f2\nprimary_caret_color:#d8e5f2\nsecondary_caret_color:#d8e5f2\naccent_bg_color:#3d80cc\n"
# Default Style
gtk-primary-button-warps-slider = 1
style "murrine-default" {
	GtkArrow::arrow-scaling= 0.6

	GtkWidget::cursor_color = @primary_caret_color
	GtkWidget::secondary_cursor_color = @secondary_caret_color
	GtkWidget::cursor_aspect_ratio = 0.05

	GtkButton::child-displacement-x = 0
	GtkButton::child-displacement-y = 0

	GtkButton::default-border = { 0, 0, 0, 0 }
	#GtkButton::inner-border        = { 2, 2, 1, 1 }
	GtkButton::focus-line-width    = 1
	GtkButton::focus-padding       = 0
	GtkButton::interior-focus      = 0

	GtkButtonBox::child-min-height = 26

	GtkCheckButton::indicator-size = 15
This theme also has a GTK3 variant where it's mostly css now. The above section is somewhat covered with this in a different file:

Code: Select all

* {
  -GtkArrow-arrow-scaling: .5;
  -GtkExpander-expander-size: 8;
  -GtkStatusbar-shadow-type: none;
  -GtkToolItemGroup-expander-size: 8;
  -GtkWindow-resize-grip-height: 0;
  -GtkWindow-resize-grip-width: 0;
  -WnckTasklist-fade-overlay-rect: 0;
  -GtkWidget-cursor-color: #d8e5f2;
  -GtkWidget-secondary-cursor-color: #d8e5f2;
  -GtkWidget-cursor-aspect-ratio: 0.05;
  outline-color: rgba(61, 128, 204, 0.5);
  outline-style: dashed;
  outline-width: 1px;
  outline-offset: -1px;
  outline-radius: 10px; }
Not a job I would envy.
Sobieski
Level 1
Level 1
Posts: 17
Joined: Fri Aug 17, 2012 2:48 am
Location: Undisclosed Location, Australia

Re: [solved] Sound fades in

Post by Sobieski »

Nope. No envy from me, either! :lol:
User avatar
MrEen
Level 22
Level 22
Posts: 15169
Joined: Mon Jun 12, 2017 8:39 pm

Re: [solved] Sound fades in

Post by MrEen »

For myself, I found it best to just to learn to live with an existing theme , which also includes finding one I like enough, than to try to do multiple alterations to one. There are so many out there. The forum user smurphos has made many, some (most?) of which are here: https://github.com/smurphos/cinnamox_themes

Scroll down on that page for plenty of screenshots. Most, if not all of those are available via the cinnamon-spices doohicky if you're using Cinnamon. I use Xfce myself, and had no issues using the Cinnamox-Rhino theme. I just had to manually install it.
Post Reply

Return to “Sound, Multimedia, & Codecs”