The microphone is not working

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Tobari
Level 1
Level 1
Posts: 37
Joined: Tue Jun 02, 2020 5:24 am

The microphone is not working

Post by Tobari »

Hi,

I've recently installed Linux Mint 19.3 (Cinnamon, 64-bit) on a laptop (HP EliteBook 840 G3).

I'm a complete newbie.

The microphone is not working. In the sound settings, the input level is such:
Image


In the "input devices" tag of pavucontrol, "microphone" was selected by default and it says it is plugged in. In the combobox, it shows "internal microphone" and "line in" alongside microphone, but both are unplugged.
Image

Thanks.
User avatar
MrEen
Level 21
Level 21
Posts: 13086
Joined: Mon Jun 12, 2017 8:39 pm

Re: The microphone is not working

Post by MrEen »

Hi Tobari, and welcome to the forum.

Are you asking about the internal microphone, or a plugged in microphone? I understand what is showing as available, but which one are you hoping to use?

Let's also see the output of pacmd list-cards please.
Tobari
Level 1
Level 1
Posts: 37
Joined: Tue Jun 02, 2020 5:24 am

Re: The microphone is not working

Post by Tobari »

MrEen wrote:
Fri Jun 05, 2020 7:51 pm
Hi Tobari, and welcome to the forum.

Are you asking about the internal microphone, or a plugged in microphone? I understand what is showing as available, but which one are you hoping to use?

Let's also see the output of pacmd list-cards please.
Hi, thanks for your reply and your welcome.

I'm asking about the internal microphone.

When I enter pacmd list-cards, it says: No PulseAudio daemon running, or not running as session daemon.

Now, I got new development. I blindly try out pretty much everything I can find the forum. On the following thread, I found the following lines to enter:

Code: Select all

sudo tee /etc/modprobe.d/blacklist-snd-hdmi-lpe-audio.conf <<<'blacklist snd_hdmi_lpe_audio'
cd ~
apt install git
git clone https://github.com/plbossart/UCM.git
sudo cp -rf ~/UCM/chtnau8824 /usr/share/alsa/ucm
sudo alsa force-reload
Now, the microphone is working on Skype, Messenger and onlinemictest.com but not on Zoom.

However, there are new issues:
- I cannot change the output volume with the keyboard anymore. (but I do hear on YouTube, etc)
- Under system settings / sound, there appear no device in the output tab, and a "no inputs sources are currently available" message in the input tab.
- pulseaudio (pavu control) just displays "Connection to pulseaudio failed, and so rorth". (it worked ok before)

Sorry to bother.
User avatar
MrEen
Level 21
Level 21
Posts: 13086
Joined: Mon Jun 12, 2017 8:39 pm

Re: The microphone is not working

Post by MrEen »

Okay, I'm not quite sure why things are the way they are, but let's see a few outputs please: aplay -l, dmesg | grep snd and sudo fuser -v /dev/snd/*

And one thing you can try to see if it fixes everything is pulseaudio --start
Tobari
Level 1
Level 1
Posts: 37
Joined: Tue Jun 02, 2020 5:24 am

Re: The microphone is not working

Post by Tobari »

To aplay -l, it says:

Code: Select all

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: CX20724 Analog [CX20724 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
To $ dmesg | grep snd, it says:

Code: Select all

[    7.635522] snd_hda_intel 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040380
[    7.635544] snd_hda_intel 0000:00:1f.3: enabling device (0000 -> 0002)
[    7.635878] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    7.664519] snd_hda_codec_conexant hdaudioC0D0: CX20724: BIOS auto-probing.
[    7.665071] snd_hda_codec_conexant hdaudioC0D0: autoconfig for CX20724: line_outs=1 (0x16/0x0/0x0/0x0/0x0) type:line
[    7.665073] snd_hda_codec_conexant hdaudioC0D0:    speaker_outs=1 (0x17/0x0/0x0/0x0/0x0)
[    7.665074] snd_hda_codec_conexant hdaudioC0D0:    hp_outs=1 (0x1d/0x0/0x0/0x0/0x0)
[    7.665075] snd_hda_codec_conexant hdaudioC0D0:    mono: mono_out=0x0
[    7.665077] snd_hda_codec_conexant hdaudioC0D0:    inputs:
[    7.665078] snd_hda_codec_conexant hdaudioC0D0:      Mic=0x19
[    7.665079] snd_hda_codec_conexant hdaudioC0D0:      Internal Mic=0x1a
[    7.665080] snd_hda_codec_conexant hdaudioC0D0:      Line=0x18
After running fuser -v /dev/snd/*, and inserting the root password, it says:

Code: Select all

                     USER        PID ACCESS COMMAND
/dev/snd/controlC0:  dorje      2591 F.... chromium-browse
                     dorje     10142 F.... rhythmbox
/dev/snd/pcmC0D0p:   dorje      2591 F...m chromium-browse
                     dorje     10142 F...m rhythmbox
/dev/snd/timer:      dorje      2591 f.... chromium-browse
                     dorje     10142 f.... rhythmbox
And pulseaudio --start said:

Code: Select all

E: [pulseaudio] main.c: Daemon startup failed.
User avatar
MrEen
Level 21
Level 21
Posts: 13086
Joined: Mon Jun 12, 2017 8:39 pm

Re: The microphone is not working

Post by MrEen »

Okay, I'm hoping this one might help point to the source of the issue:

Code: Select all

curl https://gitlab.freedesktop.org/pulseaudio/pulseaudio/raw/master/src/utils/pa-info?inline=false | bash | nc termbin.com 9999
The last line will contain a URL pointing to your sound setup. Right now, any working sound is playing directly through ALSA and bypassing PulseAudio. On the plus side, at least we know it works. We just need to determine why PulseAudio won't start, then it should be a breeze to get things working properly.
Tobari
Level 1
Level 1
Posts: 37
Joined: Tue Jun 02, 2020 5:24 am

Re: The microphone is not working

Post by Tobari »

The result is:

Code: Select all

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  2039  100  2039    0     0   1760      0  0:00:01  0:00:01 --:--:--  1760
Connection failure: Connection refused
pa_context_connect() failed: Connection refused
Connection failure: Connection refused
pa_context_connect() failed: Connection refused
lsof: WARNING: can't stat() fuse file system /home/dorje/.cache/doc
      Output information may be incomplete.
lsof: WARNING: can't stat() fuse.gvfsd-fuse file system /home/dorje/.gvfs
      Output information may be incomplete.
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse: /etc/modprobe.d/alsa-base.conf line 45: ignoring bad line starting with 'options'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse: /etc/modprobe.d/alsa-base.conf line 45: ignoring bad line starting with 'options'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse: /etc/modprobe.d/alsa-base.conf line 45: ignoring bad line starting with 'options'
https://termbin.com/6ied
PulseAudio still fails to connect.

(I believe I messed PulseAudio up myself when I tried to have the microphone work, with the command lines I introduced in my second message.)
User avatar
MrEen
Level 21
Level 21
Posts: 13086
Joined: Mon Jun 12, 2017 8:39 pm

Re: The microphone is not working

Post by MrEen »

Yeah, that's sort of what I'm looking for. Give me a few minutes to look through the output.
User avatar
MrEen
Level 21
Level 21
Posts: 13086
Joined: Mon Jun 12, 2017 8:39 pm

Re: The microphone is not working

Post by MrEen »

I don't think those command should have messed up pulseaudio. While they didn't apply for your hardware, they should have just been ignored. We can undo it anyway, just to be safe.

Code: Select all

sudo rm /etc/modprobe.d/blacklist-snd-hdmi-lpe-audio.conf
sudo rm /usr/share/alsa/ucm/chtnau8824
Finish with a reboot, then see if pulseaudio starts up again.

Is Windows still on this machine?
Tobari
Level 1
Level 1
Posts: 37
Joined: Tue Jun 02, 2020 5:24 am

Re: The microphone is not working

Post by Tobari »

As you guessed, pulseaudio still doesn't work.

There's only Linux Mint on this machine.
User avatar
MrEen
Level 21
Level 21
Posts: 13086
Joined: Mon Jun 12, 2017 8:39 pm

Re: The microphone is not working

Post by MrEen »

Okay, we're going to need to see what's stopping PA from starting up. Run this command:

Code: Select all

pulseaudio -vvv > pulse.txt
Then wait about 20 seconds and run this command:

Code: Select all

cat pulse.txt | nc termbin.com 9999
Then paste the URL that will give.
Tobari
Level 1
Level 1
Posts: 37
Joined: Tue Jun 02, 2020 5:24 am

Re: The microphone is not working

Post by Tobari »

Pulse.txt is 0 bytes and is empty after the 1st and the 2nd line.

pulseaudio -vvv > pulse.txt resulted in this:
I: [pulseaudio] main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: [pulseaudio] main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
D: [pulseaudio] core-rtclock.c: Timer slack is set to 50 us.
D: [pulseaudio] core-util.c: RealtimeKit worked.
I: [pulseaudio] core-util.c: Successfully gained nice level -11.
I: [pulseaudio] main.c: This is PulseAudio 11.1
D: [pulseaudio] main.c: Compilation host: x86_64-pc-linux-gnu
D: [pulseaudio] main.c: Compilation CFLAGS: -g -O2 -fdebug-prefix-map=/build/pulseaudio-Ytpi3P/pulseaudio-11.1=. -fstack-protector-strong -Wformat -Werror=format-security -Wall -W -Wextra -pipe -Wno-long-long -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing -Wwrite-strings -Wno-unused-parameter -ffast-math -fno-common -fdiagnostics-show-option -fdiagnostics-color=auto
D: [pulseaudio] main.c: Running on host: Linux x86_64 5.3.0-53-generic #47~18.04.1-Ubuntu SMP Thu May 7 13:10:50 UTC 2020
D: [pulseaudio] main.c: Found 4 CPUs.
I: [pulseaudio] main.c: Page size is 4096 bytes
D: [pulseaudio] main.c: Compiled with Valgrind support: no
D: [pulseaudio] main.c: Running in valgrind mode: no
D: [pulseaudio] main.c: Running in VM: no
D: [pulseaudio] main.c: Optimized build: yes
D: [pulseaudio] main.c: FASTPATH defined, only fast path asserts disabled.
I: [pulseaudio] main.c: Machine ID is aaa642a1efb049fba8d6ca0c8d22ff0a.
I: [pulseaudio] main.c: Session ID is c2.
I: [pulseaudio] main.c: Using runtime directory /run/user/1000/pulse.
I: [pulseaudio] main.c: Using state directory /home/dorje/.config/pulse.
I: [pulseaudio] main.c: Using modules directory /usr/lib/pulse-11.1/modules.
I: [pulseaudio] main.c: Running in system mode: no
I: [pulseaudio] main.c: System supports high resolution timers
D: [pulseaudio] memblock.c: Using shared memfd memory pool with 1024 slots of size 64,0 KiB each, total size is 64,0 MiB, maximum usable slot size is 65472
I: [pulseaudio] cpu-x86.c: CPU flags: CMOV MMX SSE SSE2 SSE3 SSSE3 SSE4_1 SSE4_2
I: [pulseaudio] svolume_mmx.c: Initialising MMX optimized volume functions.
I: [pulseaudio] remap_mmx.c: Initialising MMX optimized remappers.
I: [pulseaudio] svolume_sse.c: Initialising SSE2 optimized volume functions.
I: [pulseaudio] remap_sse.c: Initialising SSE2 optimized remappers.
I: [pulseaudio] sconv_sse.c: Initialising SSE2 optimized conversions.
I: [pulseaudio] svolume_orc.c: Initialising ORC optimized volume functions.
E: [pulseaudio] main.c: Daemon startup without any loaded modules, refusing to work.
I: [pulseaudio] main.c: Daemon terminated.
cat pulse.txt | nc termbin.com 9999 takes a few seconds but doesn't seem to write in pulse.txt. Is it supposed to?
User avatar
MrEen
Level 21
Level 21
Posts: 13086
Joined: Mon Jun 12, 2017 8:39 pm

Re: The microphone is not working

Post by MrEen »

It should have, but you gave me what was needed anyway:
E: [pulseaudio] main.c: Daemon startup without any loaded modules, refusing to work.
I haven't seen that error before. Let's start by making sure you own what you're supposed to own with this command:

Code: Select all

sudo chown -Rc $USER:$USER $HOME
Then see if pulseaudio --start does anything.
User avatar
MrEen
Level 21
Level 21
Posts: 13086
Joined: Mon Jun 12, 2017 8:39 pm

Re: The microphone is not working

Post by MrEen »

Also, let's see the output of ls -la ~/.config/pulse. If there are any .conf files in there, we need to delete them.
User avatar
MrEen
Level 21
Level 21
Posts: 13086
Joined: Mon Jun 12, 2017 8:39 pm

Re: The microphone is not working

Post by MrEen »

I have to do some yard work now. I'll check back in a little while.
Tobari
Level 1
Level 1
Posts: 37
Joined: Tue Jun 02, 2020 5:24 am

Re: The microphone is not working

Post by Tobari »

I still get a E: [pulseaudio] main.c: Daemon startup failed.

The output for ~$ ls -la ~/.config/pulse is:

Code: Select all

total 92
drwx------  2 dorje dorje  4096 Jun  6 09:56 .
drwxr-xr-x 31 dorje dorje  4096 Jun  6 19:01 ..
-rw-r--r--  1 dorje dorje 49152 Jun  5 17:56 aaa642a1efb049fba8d6ca0c8d22ff0a-card-database.tdb
-rw-r--r--  1 dorje dorje     1 Jun  6 09:49 aaa642a1efb049fba8d6ca0c8d22ff0a-default-sink
-rw-r--r--  1 dorje dorje     1 Jun  6 09:49 aaa642a1efb049fba8d6ca0c8d22ff0a-default-source
-rw-r--r--  1 dorje dorje 12288 Jun  6 09:49 aaa642a1efb049fba8d6ca0c8d22ff0a-device-volumes.tdb
-rw-r--r--  1 dorje dorje 12288 Jun  5 16:55 aaa642a1efb049fba8d6ca0c8d22ff0a-stream-volumes.tdb
-rw-------  1 dorje dorje   256 Jun  4 23:40 cookie
-rw-r--r--  1 dorje dorje     0 Jun  6 09:56 default.pa
I renamed pulse.conf (in /usr/share/alsa/alsa.conf.d) as well as client.conf, daemon.conf, system.pa, and default.pa in etc/pulse to no avail.
MrEen wrote:
Sat Jun 06, 2020 1:53 pm
I have to do some yard work now. I'll check back in a little while.
Of course, take your time! Thank you so much for your help :)
User avatar
MrEen
Level 21
Level 21
Posts: 13086
Joined: Mon Jun 12, 2017 8:39 pm

Re: The microphone is not working

Post by MrEen »

Okay, that explains it. Rename everything back in /etc/pulse as well as pulse.conf, then delete the file ~/.config/pulse/default.pa (I forgot that one doesn't have .conf) and PulseAudio should be able to start again.
Tobari
Level 1
Level 1
Posts: 37
Joined: Tue Jun 02, 2020 5:24 am

Re: The microphone is not working

Post by Tobari »

Unfortunately, it still doesn't work.
User avatar
MrEen
Level 21
Level 21
Posts: 13086
Joined: Mon Jun 12, 2017 8:39 pm

Re: The microphone is not working

Post by MrEen »

Tobari wrote:
Sat Jun 06, 2020 3:47 pm
Unfortunately, it still doesn't work.
Okay, let's make sure everything is correct: ls -la ~/.config/pulse, ls -la /etc/pulse, ls -la /usr/share/alsa/alsa.conf.d
Tobari
Level 1
Level 1
Posts: 37
Joined: Tue Jun 02, 2020 5:24 am

Re: The microphone is not working

Post by Tobari »

ls -la ~/.config/pulse

Code: Select all

total 92
drwx------  2 dorje dorje  4096 Jun  6 09:56 .
drwxr-xr-x 31 dorje dorje  4096 Jun  6 20:47 ..
-rw-r--r--  1 dorje dorje 49152 Jun  5 17:56 aaa642a1efb049fba8d6ca0c8d22ff0a-card-database.tdb
-rw-r--r--  1 dorje dorje     1 Jun  6 09:49 aaa642a1efb049fba8d6ca0c8d22ff0a-default-sink
-rw-r--r--  1 dorje dorje     1 Jun  6 09:49 aaa642a1efb049fba8d6ca0c8d22ff0a-default-source
-rw-r--r--  1 dorje dorje 12288 Jun  6 09:49 aaa642a1efb049fba8d6ca0c8d22ff0a-device-volumes.tdb
-rw-r--r--  1 dorje dorje 12288 Jun  5 16:55 aaa642a1efb049fba8d6ca0c8d22ff0a-stream-volumes.tdb
-rw-------  1 dorje dorje   256 Jun  4 23:40 cookie
-rw-r--r--  1 dorje dorje     0 Jun  6 09:56 default.pa
ls -la /etc/pulse

Code: Select all

total 36
drwxr-xr-x   2 root  root   4096 Jun  6 20:45 .
drwxr-xr-x 152 root  root  12288 Jun  6 14:48 ..
-rw-rw-r--   1 dorje dorje  1408 Jun  6 20:44 client.conf
-rw-r--r--   1 root  root   2366 Jan 23  2019 daemon.conf
-rw-rw-r--   1 dorje dorje  5668 Jun  6 19:55 default.pa.back
-rw-r--r--   1 root  root   2046 Jan 23  2019 system.pa
ls -la /usr/share/alsa/alsa.conf.d

Code: Select all

total 24
drwxr-xr-x 2 root root 4096 Jun  6 20:38 .
drwxr-xr-x 9 root root 4096 Jun  3 12:56 ..
-rw-r--r-- 1 root root  216 Jun 27  2016 50-pulseaudio.conf
-rw-r--r-- 1 root root  201 Jun 27  2016 99-pulseaudio-default.conf.example
-rw-r--r-- 1 root root  376 May 14 06:26 pulse.conf
-rw-r--r-- 1 root root  103 Mar 27 02:26 README

P.S.: By mistake, I deleted client.conf instead of renaming it. To have it back, I found a client.conf I found on the web. I hope it's not problematic.
Post Reply

Return to “Sound, Multimedia, & Codecs”