Linux Mint Cinnamon 20 does not detect Logitech H110 headset

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Wayne
Level 1
Level 1
Posts: 13
Joined: Wed Jul 08, 2020 11:38 pm

Linux Mint Cinnamon 20 does not detect Logitech H110 headset

Post by Wayne »

Hello, I am a new Linux Mint user. I have been using Linux Mint for past 2-3 months. Recently I have upgraded from Linux Mint 19.3 to Linux mint 20 (Cinnamon 4.6.6). I have done a fresh install. My problem is that I have a Logitech H110 Stereo Headset which I have recently bought. Linux MInt do not detect the headset from front jacks. Neither mic nor headphone is detected. In PulseAudio Volume Control, there is nothing under input devices. Also, the headphone is shown unplugged. Analog Stereo Duplex profile is unavailable when I plug headphone and mic in front jacks. Though it shows headphones unplugged, when I change port from Line Out (plugged in) to headphones (unplugged) in PulseAudio I can hear sound from headphone. Mic is detected and working fine in rear port.

My system information:

Code: Select all

System:
  Host: Mint-Desktop Kernel: 5.4.0-40-generic x86_64 bits: 64 
  Desktop: Cinnamon 4.6.6 Distro: Linux Mint 20 Ulyana 
Machine:
  Type: Desktop Mobo: ASUSTeK model: H110M-CS v: Rev X.0x 
  serial: <superuser/root required> UEFI: American Megatrends v: 3402 
  date: 07/05/2017 
CPU:
  Topology: Dual Core model: Intel Pentium G4560 bits: 64 type: MT MCP 
  L2 cache: 3072 KiB 
  Speed: 800 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 
Graphics:
  Device-1: Intel HD Graphics 610 driver: i915 v: kernel 
  Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1440x900~60Hz 
  OpenGL: renderer: Mesa Intel HD Graphics 610 (KBL GT1) v: 4.6 Mesa 20.0.8 
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio 
  driver: snd_hda_intel 
  Sound Server: ALSA v: k5.4.0-40-generic 
Output of pacmd list-cards is:

Code: Select all

1 card(s) available.
    index: 0
	name: <alsa_card.pci-0000_00_1f.3>
	driver: <module-alsa-card.c>
	owner module: 7
	properties:
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xf7120000 irq 128"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1f.3"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "a170"
		device.product.name = "100 Series/C230 Series Chipset Family HD Audio Controller"
		device.form_factor = "internal"
		device.string = "0"
		device.description = "Built-in Audio"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	profiles:
		input:analog-stereo: Analog Stereo Input (priority 65, available: no)
		output:analog-stereo: Analog Stereo Output (priority 6500, available: unknown)
		output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (priority 6565, available: no)
		off: Off (priority 0, available: unknown)
	active profile: <output:analog-stereo>
	sinks:
		alsa_output.pci-0000_00_1f.3.analog-stereo/#0: Built-in Audio Analog Stereo
	sources:
		alsa_output.pci-0000_00_1f.3.analog-stereo.monitor/#0: Monitor of Built-in Audio Analog Stereo
	ports:
		analog-input-front-mic: Front Microphone (priority 8500, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-input-rear-mic: Rear Microphone (priority 8200, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-input-linein: Line In (priority 8100, latency offset 0 usec, available: no)
			properties:
				
		analog-output-lineout: Line Out (priority 9000, latency offset 0 usec, available: yes)
			properties:
				
		analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-headphones"
Output of dmesg | grep snd is:

Code: Select all

[   11.661109] snd_hda_intel 0000:00:1f.3: enabling device (0000 -> 0002)
[   11.661337] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[   11.825661] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC887-VD: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:line
[   11.825663] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   11.825664] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[   11.825664] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[   11.825665] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[   11.825666] snd_hda_codec_realtek hdaudioC0D0:      Front Mic=0x19
[   11.825666] snd_hda_codec_realtek hdaudioC0D0:      Rear Mic=0x18
[   11.825667] snd_hda_codec_realtek hdaudioC0D0:      Line=0x1a
[13052.582740] snd_hda_intel 0000:00:1f.3: Unstable LPIB (65536 >= 32768); disabling LPIB delay counting
I have dual booted Windows with Mint. the headset (both headphone and mic) is working fine in front port in Windows.
User avatar
MrEen
Level 22
Level 22
Posts: 15236
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint Cinnamon 20 does not detect Logitech H110 headset

Post by MrEen »

Hi Wayne, and welcome to the forum.

Here's most of your issue:

Code: Select all

	active profile: <output:analog-stereo>
Run this to change the profile to allow input:

Code: Select all

pacmd set-card-profile alsa_card.pci-0000_00_1f.3 output:analog-stereo+input:analog-stereo
That profile shows as not available, so there might be some other issue as well. Are there any changes you've made yourself to the sound system?

You should also boot Windows (assuming 10 here) and ensure Fast Startup is turned off, then shut down, don't reboot. Wait 2 minutes, then power up into Mint and test everything sound wise.
User avatar
MrEen
Level 22
Level 22
Posts: 15236
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint Cinnamon 20 does not detect Logitech H110 headset

Post by MrEen »

If the above doesn't help, it's quite possible the newest pulseaudio version is conflicting with your system. You can run this to revert to the previous version:

Code: Select all

apt update && apt install libpulse-mainloop-glib0=1:13.99.1-1ubuntu3.2 libpulse0=1:13.99.1-1ubuntu3.2 libpulsedsp=1:13.99.1-1ubuntu3.2 pulseaudio=1:13.99.1-1ubuntu3.2 pulseaudio-module-bluetooth=1:13.99.1-1ubuntu3.2 pulseaudio-utils=1:13.99.1-1ubuntu3.2
Reboot after running that and test the sound.
Wayne
Level 1
Level 1
Posts: 13
Joined: Wed Jul 08, 2020 11:38 pm

Re: Linux Mint Cinnamon 20 does not detect Logitech H110 headset

Post by Wayne »

Hello MrEen, Thank you.
Fast boot has already been disabled in Windows 10. Running the code pacmd set-card-profile alsa_card.pci-0000_00_1f.3 output:analog-stereo+input:analog-stereo changes profile from Analogue Stereo Output to Analogue Stero Duplex (unavailable). As I said earlier, in this profile, PulseAudio shows Port: front microphone (unplugged). So mic is not working. However, after running the code, I went to https://www.onlinemictest.com/. When I talk into the mic, the line does not move. But when I play a video, the line moves. If I pause or mute video, the line stops moving. (Note: when I plugged my headset in front headphone and mic port, firefox show it as Monitor of Built-in Audio Analogue Stereo. When I plugged my headset in rear port, it works correctly and firefox show it as Built-in Audio Analogue Stereo.
I do not change anything in sound system. Before asking in forum, I have done a fresh install. Then I have installed pavucontrol and other softwares. Before writing this reply, I deleted files in /.config/pulse in my home folder and used pulseaudio -k command.
Also, Linux mint do not detect headphone in front port. But if I select Headphones (unplugged) in PulseAudio, I can hear sound in headphone. I have run pacmd list-sinks command while listening a song using headphone. It gives following output:

Code: Select all

1 sink(s) available.
  * index: 0
	name: <alsa_output.pci-0000_00_1f.3.analog-stereo>
	driver: <module-alsa-card.c>
	flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: RUNNING
	suspend cause: (none)
	priority: 9039
	volume: front-left: 57454 /  88% / -3.43 dB,   front-right: 57454 /  88% / -3.43 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 9.62 ms
	max request: 1 KiB
	max rewind: 1 KiB
	monitor source: 0
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 2
	linked by: 5
	configured latency: 10.00 ms; range is 1.00 .. 371.52 ms
	card: 0 <alsa_card.pci-0000_00_1f.3>
	module: 7
	properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "ALC887-VD Analog"
		alsa.id = "ALC887-VD Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xf7120000 irq 128"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1f.3"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "a170"
		device.product.name = "100 Series/C230 Series Chipset Family HD Audio Controller"
		device.form_factor = "internal"
		device.string = "front:0"
		device.buffering.buffer_size = "65536"
		device.buffering.fragment_size = "32768"
		device.access_mode = "mmap+timer"
		device.profile.name = "analog-stereo"
		device.profile.description = "Analogue Stereo"
		device.description = "Built-in Audio Analogue Stereo"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	ports:
		analog-output-lineout: Line Out (priority 9000, latency offset 0 usec, available: yes)
			properties:
				
		analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-headphones"
	active port: <analog-output-headphones>
It shows that <analog-output-headphones> is not available but it is also active.

I have reverted to previous version of Pulse. But Mint still does not detect mic and headphone from front ports.
User avatar
MrEen
Level 22
Level 22
Posts: 15236
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint Cinnamon 20 does not detect Logitech H110 headset

Post by MrEen »

I was really hoping the reverting of pulseaudio was going to fix this.

Your test showing the VU meter changing while playing sound means your input was set to Monitor of Built-in Audio. You can change that on pavucontrol's Input Devices tab by clicking on the check mark next to Microphone (unplugged) to make it the default device. Does that get the mic working?

We should probably get a look at your whole setup with this command:

Code: Select all

curl https://gitlab.freedesktop.org/pulseaudio/pulseaudio/raw/master/src/utils/pa-info?inline=false | bash | nc termbin.com 9999
The last line will have a URL pointing to the info.
Wayne
Level 1
Level 1
Posts: 13
Joined: Wed Jul 08, 2020 11:38 pm

Re: Linux Mint Cinnamon 20 does not detect Logitech H110 headset

Post by Wayne »

Making Front Microphone (unplugged) default does not work. Here is my information: https://termbin.com/ec6uc.
User avatar
MrEen
Level 22
Level 22
Posts: 15236
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint Cinnamon 20 does not detect Logitech H110 headset

Post by MrEen »

Heading to bed, but should have some ideas tomorrow. Looks like there definitely a jack detection issue. Is there anything plugged into the Line Out port in the back?
Wayne
Level 1
Level 1
Posts: 13
Joined: Wed Jul 08, 2020 11:38 pm

Re: Linux Mint Cinnamon 20 does not detect Logitech H110 headset

Post by Wayne »

A speaker is plugged into the line out port. Nothing into line in or mic port.
User avatar
MrEen
Level 22
Level 22
Posts: 15236
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint Cinnamon 20 does not detect Logitech H110 headset

Post by MrEen »

See if running sudo alsa force-reload makes any difference. The downgrade of pulseaudio has fixed this issue for some that you're still having:

Code: Select all

	Profiles:
		input:analog-stereo: Analog Stereo Input (sinks: 0, sources: 1, priority: 65, available: no)
		output:analog-stereo: Analog Stereo Output (sinks: 1, sources: 0, priority: 6500, available: yes)
		output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (sinks: 1, sources: 1, priority: 6565, available: no)
The one other possible cause I've seen recently is rebooting from Windows to Mint. Did you definitely shut down from within Windows before powering up into Mint the last time? On some hardware, this does make a difference.
Wayne
Level 1
Level 1
Posts: 13
Joined: Wed Jul 08, 2020 11:38 pm

Re: Linux Mint Cinnamon 20 does not detect Logitech H110 headset

Post by Wayne »

See if running sudo alsa force-reload makes any difference.
I have already tried this, but ALSA does not recognise front jacks.
The downgrade of pulseaudio has fixed this issue for some that you're still having:
I do not understand which issue you are talking about. Output of pacmd list-cards shows that input:analog-stereo: Analog Stereo Input (sinks: 0, sources: 1, priority: 65, available: no) shows that input is not available.When I plug the headset in rear mic port it shows input:analog-stereo: Analogue Stereo Input (priority 65, available: unknown). But the mic is working.
PulseAudio is now latest version.
The one other possible cause I've seen recently is rebooting from Windows to Mint. Did you definitely shut down from within Windows before powering up into Mint the last time? On some hardware, this does make a difference.
Well, I have installed Windows 10 for gaming, but nowadays I rarely play games. I use it when I need to use headphone and mic at same time (e.g. video calling), so I do not use windows often. I think it is not the issue here. But after booting into windows, sometimes I shut down the pc and sometimes restart to boot into Linux Mint.
Edit: Here is the output of pacmd list-cards when headset (only mic) is plugged into rear jack.

Code: Select all

1 card(s) available.
    index: 0
	name: <alsa_card.pci-0000_00_1f.3>
	driver: <module-alsa-card.c>
	owner module: 7
	properties:
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xf7120000 irq 128"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1f.3"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "a170"
		device.product.name = "100 Series/C230 Series Chipset Family HD Audio Controller"
		device.form_factor = "internal"
		device.string = "0"
		device.description = "Built-in Audio"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	profiles:
		input:analog-stereo: Analogue Stereo Input (priority 65, available: unknown)
		output:analog-stereo: Analogue Stereo Output (priority 6500, available: unknown)
		output:analog-stereo+input:analog-stereo: Analogue Stereo Duplex (priority 6565, available: unknown)
		off: Off (priority 0, available: unknown)
	active profile: <output:analog-stereo+input:analog-stereo>
	sinks:
		alsa_output.pci-0000_00_1f.3.analog-stereo/#0: Built-in Audio Analogue Stereo
	sources:
		alsa_output.pci-0000_00_1f.3.analog-stereo.monitor/#0: Monitor of Built-in Audio Analogue Stereo
		alsa_input.pci-0000_00_1f.3.analog-stereo/#1: Built-in Audio Analogue Stereo
	ports:
		analog-input-front-mic: Front Microphone (priority 8500, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-input-rear-mic: Rear Microphone (priority 8200, latency offset 0 usec, available: yes)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-input-linein: Line In (priority 8100, latency offset 0 usec, available: no)
			properties:
				
		analog-output-lineout: Line Out (priority 9000, latency offset 0 usec, available: yes)
			properties:
				
		analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-headphones"
User avatar
MrEen
Level 22
Level 22
Posts: 15236
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint Cinnamon 20 does not detect Logitech H110 headset

Post by MrEen »

Okay, you're getting a better output this time:

Code: Select all

	profiles:
		input:analog-stereo: Analogue Stereo Input (priority 65, available: unknown)
		output:analog-stereo: Analogue Stereo Output (priority 6500, available: unknown)
		output:analog-stereo+input:analog-stereo: Analogue Stereo Duplex (priority 6565, available: unknown)
At least unknown is better than no. And the list-cards output often uses unknown. If you'd been using pacmd list-sources, or pacmd list-sinks, then unknown is more troublesome.

Let's do a confirmation of your jack detection. Install alsa-tools, then keep running sudo hdajacksensetest -a as you plug into the various ports on the computer. Hopefully you'll see no changing to yes where appropriate.

Based on your last output, I do have a feeling your system might be working properly right now, but that's a bit of a guess. When recording with the mic, running pacmd list-sources will show you which device the system is recording from with the asterisk by the index number. If the name just below the index that has the asterisk end with .monitor, then you're recording from the wrong device.
Wayne
Level 1
Level 1
Posts: 13
Joined: Wed Jul 08, 2020 11:38 pm

Re: Linux Mint Cinnamon 20 does not detect Logitech H110 headset

Post by Wayne »

Outlput of sudo hdajacksensetest -a when headset mic is connected in rear port:

Code: Select all

Pin 0x11 (Not connected): present = No
Pin 0x12 (Not connected): present = No
Pin 0x14 (Green Line Out, Rear side): present = Yes
Pin 0x15 (Not connected): present = No
Pin 0x16 (Not connected): present = No
Pin 0x17 (Not connected): present = No
Pin 0x18 (Pink Mic, Rear side): present = Yes
Pin 0x19 (Pink Mic, Front side): present = No
Pin 0x1a (Blue Line In, Rear side): present = No
Pin 0x1b (Green Headphone, Front side): present = No
Pin 0x1c (Not connected): present = No
Pin 0x1d (Not connected): present = No
Pin 0x1e (Not connected): present = No
Pin 0x1f (Not connected): present = No
A speaker is plugged into Pin 0x14 and headset's mic is into Pin 0x18. headphone is unplugged. Now Pulse recognises mic as Rear Microphone (plugged in). output of pacmd list-sources:

Code: Select all

2 source(s) available.
    index: 0
	name: <alsa_output.pci-0000_00_1f.3.analog-stereo.monitor>
	driver: <module-alsa-card.c>
	flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: RUNNING
	suspend cause: (none)
	priority: 1030
	volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 0.00 ms
	max rewind: 6 KiB
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 3
	linked by: 3
	configured latency: 40.00 ms; range is 0.50 .. 371.52 ms
	monitor_of: 0
	card: 0 <alsa_card.pci-0000_00_1f.3>
	module: 7
	properties:
		device.description = "Monitor of Built-in Audio Analogue Stereo"
		device.class = "monitor"
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xf7120000 irq 128"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1f.3"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "a170"
		device.product.name = "100 Series/C230 Series Chipset Family HD Audio Controller"
		device.form_factor = "internal"
		device.string = "0"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
  * index: 3
	name: <alsa_input.pci-0000_00_1f.3.analog-stereo>
	driver: <module-alsa-card.c>
	flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: RUNNING
	suspend cause: (none)
	priority: 9039
	volume: front-left: 22616 /  35% / -27.72 dB,   front-right: 22616 /  35% / -27.72 dB
	        balance 0.00
	base volume: 6554 /  10% / -60.00 dB
	volume steps: 65537
	muted: no
	current latency: 0.27 ms
	max rewind: 0 KiB
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 3
	linked by: 3
	configured latency: 10.00 ms; range is 0.50 .. 371.52 ms
	card: 0 <alsa_card.pci-0000_00_1f.3>
	module: 7
	properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "ALC887-VD Analog"
		alsa.id = "ALC887-VD Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xf7120000 irq 128"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1f.3"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "a170"
		device.product.name = "100 Series/C230 Series Chipset Family HD Audio Controller"
		device.form_factor = "internal"
		device.string = "front:0"
		device.buffering.buffer_size = "65536"
		device.buffering.fragment_size = "32768"
		device.access_mode = "mmap+timer"
		device.profile.name = "analog-stereo"
		device.profile.description = "Analogue Stereo"
		device.description = "Built-in Audio Analogue Stereo"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	ports:
		analog-input-front-mic: Front Microphone (priority 8500, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-input-rear-mic: Rear Microphone (priority 8200, latency offset 0 usec, available: yes)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-input-linein: Line In (priority 8100, latency offset 0 usec, available: no)
			properties:
				
	active port: <analog-input-rear-mic>
Mic is working and I have recorded a clip successfully.
Then I plugged the headset (mic and headphone) into front jacks. Output of pacmd list-sources is:

Code: Select all

1 source(s) available.
  * index: 0
	name: <alsa_output.pci-0000_00_1f.3.analog-stereo.monitor>
	driver: <module-alsa-card.c>
	flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: RUNNING
	suspend cause: (none)
	priority: 1030
	volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 0.00 ms
	max rewind: 1 KiB
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 6
	linked by: 6
	configured latency: 10.00 ms; range is 0.50 .. 371.52 ms
	monitor_of: 0
	card: 0 <alsa_card.pci-0000_00_1f.3>
	module: 7
	properties:
		device.description = "Monitor of Built-in Audio Analogue Stereo"
		device.class = "monitor"
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xf7120000 irq 128"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1f.3"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "a170"
		device.product.name = "100 Series/C230 Series Chipset Family HD Audio Controller"
		device.form_factor = "internal"
		device.string = "0"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
And sudo hdajacksensetest -a shows that nothing is connected into Pin 0x19 and Pin 0x1b.

Code: Select all

Pin 0x11 (Not connected): present = No
Pin 0x12 (Not connected): present = No
Pin 0x14 (Green Line Out, Rear side): present = Yes
Pin 0x15 (Not connected): present = No
Pin 0x16 (Not connected): present = No
Pin 0x17 (Not connected): present = No
Pin 0x18 (Pink Mic, Rear side): present = No
Pin 0x19 (Pink Mic, Front side): present = No
Pin 0x1a (Blue Line In, Rear side): present = No
Pin 0x1b (Green Headphone, Front side): present = No
Pin 0x1c (Not connected): present = No
Pin 0x1d (Not connected): present = No
Pin 0x1e (Not connected): present = No
Pin 0x1f (Not connected): present = No
No detection of mic and headphone. I have recorded a clip with gnome sound recorder, but no sound in the clip. Also the asterisk ends with a monitor. Another thing is gnome recoreder recorded sound from a video, not from mic.
Then I changed output from Line Out (plugged in) to Headphones (unplugged). Output of pacmd list-sources is:

Code: Select all

1 source(s) available.
  * index: 0
	name: <alsa_output.pci-0000_00_1f.3.analog-stereo.monitor>
	driver: <module-alsa-card.c>
	flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: RUNNING
	suspend cause: (none)
	priority: 1030
	volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 0.00 ms
	max rewind: 6 KiB
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 3
	linked by: 3
	configured latency: 40.00 ms; range is 0.50 .. 371.52 ms
	monitor_of: 0
	card: 0 <alsa_card.pci-0000_00_1f.3>
	module: 7
	properties:
		device.description = "Monitor of Built-in Audio Analogue Stereo"
		device.class = "monitor"
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xf7120000 irq 128"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1f.3"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "a170"
		device.product.name = "100 Series/C230 Series Chipset Family HD Audio Controller"
		device.form_factor = "internal"
		device.string = "0"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci" 
There is nothing related to front headphone jack but somehow headphone is working. As usual, the mic is not working, even if I selected it from PulseAudio. I cannot use my headset from front jack- that is my problem. I think ALSA does not have proper support for Realtek ALC887-VD chip.
Wayne
Level 1
Level 1
Posts: 13
Joined: Wed Jul 08, 2020 11:38 pm

Re: Linux Mint Cinnamon 20 does not detect Logitech H110 headset

Post by Wayne »

Immedietly after the previous reply, I have run sudo hdajacksensetest -a. Here is the output:

Code: Select all

Pin 0x11 (Not connected): present = No
Pin 0x12 (Not connected): present = No
Pin 0x14 (Green Line Out, Rear side): present = Yes
Pin 0x15 (Not connected): present = No
Pin 0x16 (Not connected): present = No
Pin 0x17 (Not connected): present = No
Pin 0x18 (Pink Mic, Rear side): present = No
Pin 0x19 (Pink Mic, Front side): present = No
Pin 0x1a (Blue Line In, Rear side): present = No
Pin 0x1b (Green Headphone, Front side): present = No
Pin 0x1c (Not connected): present = No
Pin 0x1d (Not connected): present = No
Pin 0x1e (Not connected): present = No
Pin 0x1f (Not connected): present = No
And output of pacmd list-sources:

Code: Select all

2 source(s) available.
  * index: 0
	name: <alsa_output.pci-0000_00_1f.3.analog-stereo.monitor>
	driver: <module-alsa-card.c>
	flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: RUNNING
	suspend cause: (none)
	priority: 1030
	volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 0.00 ms
	max rewind: 6 KiB
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 3
	linked by: 3
	configured latency: 40.00 ms; range is 0.50 .. 371.52 ms
	monitor_of: 0
	card: 0 <alsa_card.pci-0000_00_1f.3>
	module: 7
	properties:
		device.description = "Monitor of Built-in Audio Analogue Stereo"
		device.class = "monitor"
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xf7120000 irq 128"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1f.3"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "a170"
		device.product.name = "100 Series/C230 Series Chipset Family HD Audio Controller"
		device.form_factor = "internal"
		device.string = "0"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
    index: 4
	name: <alsa_input.pci-0000_00_1f.3.analog-stereo>
	driver: <module-alsa-card.c>
	flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: RUNNING
	suspend cause: (none)
	priority: 9039
	volume: front-left: 34182 /  52% / -16.96 dB,   front-right: 34182 /  52% / -16.96 dB
	        balance 0.00
	base volume: 6554 /  10% / -60.00 dB
	volume steps: 65537
	muted: no
	current latency: 0.53 ms
	max rewind: 0 KiB
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 2
	linked by: 2
	configured latency: 10.00 ms; range is 0.50 .. 371.52 ms
	card: 0 <alsa_card.pci-0000_00_1f.3>
	module: 7
	properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "ALC887-VD Analog"
		alsa.id = "ALC887-VD Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xf7120000 irq 128"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1f.3"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "a170"
		device.product.name = "100 Series/C230 Series Chipset Family HD Audio Controller"
		device.form_factor = "internal"
		device.string = "front:0"
		device.buffering.buffer_size = "65536"
		device.buffering.fragment_size = "32768"
		device.access_mode = "mmap+timer"
		device.profile.name = "analog-stereo"
		device.profile.description = "Analogue Stereo"
		device.description = "Built-in Audio Analogue Stereo"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	ports:
		analog-input-front-mic: Front Microphone (priority 8500, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-input-rear-mic: Rear Microphone (priority 8200, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-input-linein: Line In (priority 8100, latency offset 0 usec, available: no)
			properties:
				
	active port: <analog-input-front-mic> 
As you see, it shows <analogur-input-front-mic> as active. Then I went to Pulse and surprisingly, able to select Built-in Audio Analogue Stereo under recording tab. I have recorded a clip and heard my voice. So it's working for now. Note that:
1.Pin 0x19 (Pink Mic, Front side): present = No
2.Pin 0x1b (Green Headphone, Front side): present = No
3. * index: 0
name: <alsa_output.pci-0000_00_1f.3.analog-stereo.monitor>

4. ports:
analog-input-front-mic: Front Microphone (priority 8500, latency offset 0 usec, available: no)

5. active port: <analog-input-front-mic>
What is the index 4 for? Whatever, it is working. As long as it works, I am fine with that. I'll check if it works in zoom or discord.
User avatar
MrEen
Level 22
Level 22
Posts: 15236
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint Cinnamon 20 does not detect Logitech H110 headset

Post by MrEen »

The index 4 is unimportant, as you unplug in one place and plug in another, there's a change, so the index number increases.

You're definitely having some strangeness in the jack detection area, and you're "working" recordings shouldn't have worked based on the list-sources outputs showing negligible volumes.

Two outputs I'd like to see are apt policy pulseaudio and this one:

Code: Select all

curl https://gitlab.freedesktop.org/pulseaudio/pulseaudio/raw/master/src/utils/pa-info?inline=false | bash | nc termbin.com 9999
That second one will have a URL on the last line of output that points to your sound setup. That should give an indication of what's happening and how to solve it properly.
Wayne
Level 1
Level 1
Posts: 13
Joined: Wed Jul 08, 2020 11:38 pm

Re: Linux Mint Cinnamon 20 does not detect Logitech H110 headset

Post by Wayne »

Output of apt policy pulseaudion:

Code: Select all

pulseaudio:
  Installed: 1:13.99.1-1ubuntu3.3
  Candidate: 1:13.99.1-1ubuntu3.3
  Version table:
 *** 1:13.99.1-1ubuntu3.3 500
        500 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1:13.99.1-1ubuntu3.2 500
        500 http://security.ubuntu.com/ubuntu focal-security/main amd64 Packages
     1:13.99.1-1ubuntu3 500
        500 http://archive.ubuntu.com/ubuntu focal/main amd64 Packages 
Here is the url: https://termbin.com/u0gi
I have tried using my headset's mic with discord and gnome sound recorder.To enable mic, I have to follow this steps:
1. Open PulseAudio and select Profile: Analogue Stereo Duplex (unavailable) in Configuration tab.
2. Select Port: Front Microphone (unplugged) in Input Devices.
3. Change Monitor of Built-in Analogue Audio Stereo to Built-in Analogue Audio Stereo.
after following this steps, both discord and gnome sound recorder was able to use mic. However, when I opened firefox and tried to use discord.com and onlinemictest.com, I could not enable Built-in Audio Analogue Stereo in recording tab. The option is present, but it cannot be selected. Here is the screenshots (WebRTC VoiceEngine is discord):
I have also tried to use discord.com and onlinemictest.com in Brave an Google Chrome. But they cannot even detect Monitor of Built-in Audio Analogue Stereo. So my problem is partially solved. Now I need to solve the issue with firefox. In 2nd screenshot, mic is not working in firefox. ALSA (or PulseAudio) has some issues with browsers.
Attachments
Analogue Stereo Output profile selected in configuration -- mic not working
Analogue Stereo Output profile selected in configuration -- mic not working
Analogue Stereo Duplex (unavailable) profile selected in configuration --mic working
Analogue Stereo Duplex (unavailable) profile selected in configuration --mic working
User avatar
MrEen
Level 22
Level 22
Posts: 15236
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint Cinnamon 20 does not detect Logitech H110 headset

Post by MrEen »

Okay, you're back on the newest version of PulseAudio that has been an issue for quite a few users. Do this again:

Code: Select all

apt update && apt install libpulse-mainloop-glib0=1:13.99.1-1ubuntu3.2 libpulse0=1:13.99.1-1ubuntu3.2 libpulsedsp=1:13.99.1-1ubuntu3.2 pulseaudio=1:13.99.1-1ubuntu3.2 pulseaudio-module-bluetooth=1:13.99.1-1ubuntu3.2 pulseaudio-utils=1:13.99.1-1ubuntu3.2
Finish with a reboot, then run pacmd list-cards right after rebooting. I'm hoping this changes the no's to yes's in this section:

Code: Select all

	Profiles:
		input:analog-stereo: Analogue Stereo Input (sinks: 0, sources: 1, priority: 65, available: no)
		output:analog-stereo: Analogue Stereo Output (sinks: 1, sources: 0, priority: 6500, available: yes)
		output:analog-stereo+input:analog-stereo: Analogue Stereo Duplex (sinks: 1, sources: 1, priority: 6565, available: no)
I'm sure the above is at the heart of your issue. It's somewhat lucky you're getting any input to work at all.
Wayne
Level 1
Level 1
Posts: 13
Joined: Wed Jul 08, 2020 11:38 pm

Re: Linux Mint Cinnamon 20 does not detect Logitech H110 headset

Post by Wayne »

Output of pacmd list-sources:

Code: Select all

1 card(s) available.
    index: 0
	name: <alsa_card.pci-0000_00_1f.3>
	driver: <module-alsa-card.c>
	owner module: 7
	properties:
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xf7120000 irq 128"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1f.3"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "a170"
		device.product.name = "100 Series/C230 Series Chipset Family HD Audio Controller"
		device.form_factor = "internal"
		device.string = "0"
		device.description = "Built-in Audio"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	profiles:
		input:analog-stereo: Analogue Stereo Input (priority 65, available: no)
		output:analog-stereo: Analogue Stereo Output (priority 6500, available: unknown)
		output:analog-stereo+input:analog-stereo: Analogue Stereo Duplex (priority 6565, available: no)
		off: Off (priority 0, available: unknown)
	active profile: <output:analog-stereo>
	sinks:
		alsa_output.pci-0000_00_1f.3.analog-stereo/#0: Built-in Audio Analogue Stereo
	sources:
		alsa_output.pci-0000_00_1f.3.analog-stereo.monitor/#0: Monitor of Built-in Audio Analogue Stereo
	ports:
		analog-input-front-mic: Front Microphone (priority 8500, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-input-rear-mic: Rear Microphone (priority 8200, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-input-linein: Line In (priority 8100, latency offset 0 usec, available: no)
			properties:
				
		analog-output-lineout: Line Out (priority 9000, latency offset 0 usec, available: yes)
			properties:
				
		analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-headphones" 
Still I cannot enable Built-in Audio Analogue Stereo option for firefox.
User avatar
MrEen
Level 22
Level 22
Posts: 15236
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint Cinnamon 20 does not detect Logitech H110 headset

Post by MrEen »

Those profiles are still messed up. See if booting to the previous kernel makes a difference.
Wayne
Level 1
Level 1
Posts: 13
Joined: Wed Jul 08, 2020 11:38 pm

Re: Linux Mint Cinnamon 20 does not detect Logitech H110 headset

Post by Wayne »

I have used some Live CDs to test mic and headphone. I have followed the steps below:
1. Open PulseAudio and select profile Analogue stero Duplex (unavailable) in configuration.
2. Select Front Microphone (unplugged) in Input Devices and Headphone (unplugged) in Output Devices.
3. Give Firefox permission to use mic.
4. Change Monitor of Built-in Audio Analogue to built-in Audion Analogue in recordings.
PCLinuxOS (Kernel: 5.6.10-pclos1 x86_64): discord.com and onlinemictest.com received input from mic.
MX Linux (Patito Feo- kernel 4.19): PulseAudio did not show unavailable after Analogue Stereo Duplex profile. But Headphones and mic was showed unplugged. I was able to select Built-in Audio Analogue Stereo option for firefox. discord.com and onlinemictest.com received input from mic.
Ubuntu 20: Worked.
Manjaro Xfce (kernel 5.6): It did not work. I could not select Built-in Audion Analogue option for Firefox.
Solus $.1 budgie (Kernel 5.4.12): worked.
In Ubuntu and Solus, the line in onlinemictest.com was moving though I was not talking into mic. But it worked. In Manjaro and Linux Mint, Built-in Audio Analogue cannot be selected. So Firefox did not receive any input from mic.
User avatar
MrEen
Level 22
Level 22
Posts: 15236
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint Cinnamon 20 does not detect Logitech H110 headset

Post by MrEen »

Wayne wrote:
Mon Jul 20, 2020 1:23 am
Ubuntu 20: Worked.
Mint 20 uses the same sound base as Ubuntu 20 (all the relevant bits come from the same place.)

Run the Ubuntu 20 Live USB with working sound then in the terminal run sudo alsactl store followed by cat /var/lib/alsa/asound.state and paste that output here.

Then boot up your installed Mint, and run sudo touch /var/lib/alsa/asound.state followed by xed admin:///var/lib/alsa/asound.state and overwrite anything in the file with the copy you made from Ubuntu. After saving the file, run sudo alsactl restore and you may need to run pulseaudio -k to restart the sound daemon after that. That should work.
Post Reply

Return to “Sound, Multimedia, & Codecs”