Sound stops working after a few hours on Mint 20 Cinnamon

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
nkoropoff
Level 2
Level 2
Posts: 66
Joined: Fri Mar 21, 2014 12:32 pm

Sound stops working after a few hours on Mint 20 Cinnamon

Post by nkoropoff »

I upgraded my system from Mint 19.3 to Mint 20 yesterday per the instructions posted. Everything worked just fine on the 5.4.0-40 kernel at least for about 3 hours. It was then I noticed my sound system was no longer working (external speakers connected to headphone jack). I could neither shutdown nor reboot either, it appeared to be that pulseaudio was not responding. All I could do was power off my machine. Upon powering back on, sound again worked just fine for about 3 hours. I had encountered this exact same issue on Mint 19.3 with the 5.4.0-x kernels so I had reverted back to a 5.3.0.x kernel and all was good.
I installed the 5.3.0.61 on my Mint 20 install and my sound issues went away however; this kernel is unsupported on Mint 20 so I'd like to be able to be on a supported kernel.
I googled this issue and found that others had encountered similar issues with the 5.4 kernels except they had pulseaudio hanging from boot up. Mine works fine for a while and then eventually hangs. I tried some of the procedures that worked for the others situations but had no effect on my install. Can someone assist me in finding a solution? Thanks in advance.
User avatar
MrEen
Level 22
Level 22
Posts: 15169
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound stops working after a few hours on Mint 20 Cinnamon

Post by MrEen »

Hi nkoropoff,

Please post the output of apt policy pulseaudio. The newest version has been troublesome for some users, and maybe that's the issue you're experiencing as well.
nkoropoff
Level 2
Level 2
Posts: 66
Joined: Fri Mar 21, 2014 12:32 pm

Re: Sound stops working after a few hours on Mint 20 Cinnamon

Post by nkoropoff »

Here is the output of apt policy pulseaudio:
pulseaudio:
Installed: 1:13.99.1-1ubuntu3.3
Candidate: 1:13.99.1-1ubuntu3.3
Version table:
*** 1:13.99.1-1ubuntu3.3 500
500 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages
100 /var/lib/dpkg/status
1:13.99.1-1ubuntu3.2 500
500 http://security.ubuntu.com/ubuntu focal-security/main amd64 Packages
1:13.99.1-1ubuntu3 500
500 http://archive.ubuntu.com/ubuntu focal/main amd64 Packages

Thank you.
Neil
User avatar
MrEen
Level 22
Level 22
Posts: 15169
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound stops working after a few hours on Mint 20 Cinnamon

Post by MrEen »

Okay, I've already asked one person to try this but I haven't heard back yet to see if it was successful. If you want to be a guinea pig, you can try this, or wait until I get confirmation that it works. I don't have 20 installed myself, so I cannot test this. To downgrade your version of pulseaudio, I'm hoping this is the correct command to accomplish this:

Code: Select all

apt update && apt install libpulse-mainloop-glib0=1:13.99.1-1ubuntu3.2 libpulse0=1:13.99.1-1ubuntu3.2 libpulsedsp=1:13.99.1-1ubuntu3.2 pulseaudio=1:13.99.1-1ubuntu3.2 pulseaudio-module-bluetooth=1:13.99.1-1ubuntu3.2 pulseaudio-utils=1:13.99.1-1ubuntu3.2
I'm not 100% positive this is the correct command for Mint 20 as it was for earlier versions, as posted by xenopeek here.

If you would prefer to wait for confirmation about this, that is fine. I will let you know as soon as I hear back if it worked.
nkoropoff
Level 2
Level 2
Posts: 66
Joined: Fri Mar 21, 2014 12:32 pm

Re: Sound stops working after a few hours on Mint 20 Cinnamon

Post by nkoropoff »

Thank you. Ill wait until confirmation. I mentioned above that I had the exact same issue with Mint 19.3 and any of the 5.4.0.x kernels, unless you mean 19.3 and 20 use the same version of pulseaudio. Pulseaudio did not hang at all with the 5.3.0.x kernels. Not sure why but pulseaudio process(es) cannot be killed be either name or PID.
User avatar
MrEen
Level 22
Level 22
Posts: 15169
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound stops working after a few hours on Mint 20 Cinnamon

Post by MrEen »

19 had pulseaudio version 11.x, while 20 uses 13.99.x. It could be that the new pulseaudio has a conflict with the 5.4 kernel, but I'm starting to think it's likely not pulseaudio that's the issue for you.

Now, regarding this:
Not sure why but pulseaudio process(es) cannot be killed be either name or PID.
Can you explain? PulseAudio does automatically respawn when killed. Could that be what you're experiencing or is it something else?

I think the best bet to finding the issue might be to set thing up so the sound will quit again, and when it does, run this command:

Code: Select all

curl https://gitlab.freedesktop.org/pulseaudio/pulseaudio/raw/master/src/utils/pa-info?inline=false | bash | nc termbin.com 9999
Then also get a copy of the script with working sound. The last line will have a URL pointing to your sound setup. Hopefully the differences in the outputs between sound working and not will point us to the proper solution.

For completeness, can I also see the output of inxi -Fxz please.
nkoropoff
Level 2
Level 2
Posts: 66
Joined: Fri Mar 21, 2014 12:32 pm

Re: Sound stops working after a few hours on Mint 20 Cinnamon

Post by nkoropoff »

When the sound goes out, I cannot shutdown or reboot the system. If I select shutdown or reboot from the menu then I get a black screen with the Linux Mint icon in the middle and it will sit there indefinitely without shutting down or rebooting. I have let it sit there for 45 minutes with no change. If I instead open a terminal and issue sudo shutdown (or reboot) I get a popup that says it is waiting for pulseaudio to end and I have the option to wait or terminate now. If I select terminate now then I get the black screen with the Mint icon and it sits there indefinitely.

I am now waiting for sound to quit and I will gather the information you requested.
User avatar
MrEen
Level 22
Level 22
Posts: 15169
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound stops working after a few hours on Mint 20 Cinnamon

Post by MrEen »

Ahh, thanks for that explanation. So once again we might be back to pulseaudio being the culprit.
nkoropoff
Level 2
Level 2
Posts: 66
Joined: Fri Mar 21, 2014 12:32 pm

Re: Sound stops working after a few hours on Mint 20 Cinnamon

Post by nkoropoff »

Sorry the delay in the data. I'm running some experiments because I may have found a link between pulseaudio hanging, the 5.4 kernel, and the power management settings on my system.
User avatar
MrEen
Level 22
Level 22
Posts: 15169
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound stops working after a few hours on Mint 20 Cinnamon

Post by MrEen »

Very good! Anything you can find out will be more help it getting it resolved. And don't worry how long it takes. I'm here every day.
User avatar
MrEen
Level 22
Level 22
Posts: 15169
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound stops working after a few hours on Mint 20 Cinnamon

Post by MrEen »

If it turns out to be a pulseaudio issue, this command will revert your version to the previous:

Code: Select all

apt update && apt install libpulse-mainloop-glib0=1:13.99.1-1ubuntu3.2 libpulse0=1:13.99.1-1ubuntu3.2 libpulsedsp=1:13.99.1-1ubuntu3.2 pulseaudio=1:13.99.1-1ubuntu3.2 pulseaudio-module-bluetooth=1:13.99.1-1ubuntu3.2 pulseaudio-utils=1:13.99.1-1ubuntu3.2
The new version will then be available in the Update Manager again, so there's no harm in trying it. This has now been confirmed to fix at least one users audio issues. (More than one really, but some of the others didn't downgrade theirs this way.)
nkoropoff
Level 2
Level 2
Posts: 66
Joined: Fri Mar 21, 2014 12:32 pm

Re: Sound stops working after a few hours on Mint 20 Cinnamon

Post by nkoropoff »

OK. I seem to have found the trigger for my sound problem. My system is a desktop Lenovo M710q, not a laptop. My usual power management setting is to have "Turn off the screen when inactive for" set to 10 minutes. This is under Power Options on the Power tab. Suspend is always set to Never

If I then leave the system alone for about 2 hours at least then my sound stops working and I cannot reboot or shutdown. I can only power off.

What I discovered today is that if I set "Turn off the screen when inactive for" to Never then the sound never fails and I can then do normal reboots or shutdowns.

This situation ONLY happens when I am running any of the 5.4.0-x kernels (I tried -26, -37, and -40). If I am running a 5..3.0-x kernel than it doesn't produce the sound failure even if "Turn off the screen when inactive for" is set to something other than Never.

So for the time being I have a workaround in that I can leave the power setting to Never and just turn off the display from its on/off switch.
Do you still want me to collect the data you initially requested or do you require something different? Let me know since I can recreate the failure on demand.
User avatar
MrEen
Level 22
Level 22
Posts: 15169
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound stops working after a few hours on Mint 20 Cinnamon

Post by MrEen »

As it's easy for you to reproduce the issue, I would suggest trying to downgrade pulseaudio as in my last post, then reboot and see if the issue still persists. The newer pulseaudio version should reappear in the Update Manager after the next refresh, so that's also easy to undo. If the issue disappears with that change, we know your present version of pulseaudio has an issue with your setup. I know for a fact that there are issues with this version, and a few users have had success with the downgrade. Each has had slightly different issues with their sound, but were all solved the same way, so it could be the same for you.

And I must say, very nice work on that troubleshooting! Don't feel it's necessary to try what I've posted. I just like to eliminate everything possible from the issue chain.

The newest pulseaudio version's changelog is devoid of any useful information and implies it's only a revert of a previous bug fix that caused new issues. I know it can't simply be a revert as the previous versions didn't have the issues this new one has created.
nkoropoff
Level 2
Level 2
Posts: 66
Joined: Fri Mar 21, 2014 12:32 pm

Re: Sound stops working after a few hours on Mint 20 Cinnamon

Post by nkoropoff »

I will perform the downgrade and report back later today.
nkoropoff
Level 2
Level 2
Posts: 66
Joined: Fri Mar 21, 2014 12:32 pm

Re: Sound stops working after a few hours on Mint 20 Cinnamon

Post by nkoropoff »

So the same sound failure occurs on the downgraded version of Pulseaudio. I will upgrade back to the current version of pulseaudio. Let me know if you want me to run this:

curl https://gitlab.freedesktop.org/pulseaud ... line=false | bash | nc termbin.com 9999

After the failure and before failure. And the output of inxi -Fxz as well.
User avatar
MrEen
Level 22
Level 22
Posts: 15169
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound stops working after a few hours on Mint 20 Cinnamon

Post by MrEen »

That won't be necessary. You've found a workaround that is beyond my knowledge to solve any other way. I believe we've eliminated something in the sound stack being the culprit. Most likely something in the kernel is the issue with your hardware/settings, though it might be in the power manager.

If you want to try getting it properly resolved, you should probably start a new thread, in another category. Maybe focus on power manager in the title and mention the lock ups that occur that prevent shutting down and downplay the sound aspect of it.

I rather doubt this thread will get the eyes it needs to dig any deeper into this.
nkoropoff
Level 2
Level 2
Posts: 66
Joined: Fri Mar 21, 2014 12:32 pm

Re: Sound stops working after a few hours on Mint 20 Cinnamon

Post by nkoropoff »

OK. I'll do just that and open a thread in power management. Thank you for all your assistance in this matter.
User avatar
MrEen
Level 22
Level 22
Posts: 15169
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound stops working after a few hours on Mint 20 Cinnamon

Post by MrEen »

You/re very welcome. Good luck! :D
nkoropoff
Level 2
Level 2
Posts: 66
Joined: Fri Mar 21, 2014 12:32 pm

Re: Sound stops working after a few hours on Mint 20 Cinnamon

Post by nkoropoff »

Follow up. Now that the 5.8 kernel has been made available the power management/sound issue/reboot issue is gone.
User avatar
MrEen
Level 22
Level 22
Posts: 15169
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound stops working after a few hours on Mint 20 Cinnamon

Post by MrEen »

Yeah! That's great to hear nkoropoff!

Thanks for coming back to mention this.

Enjoy. :D
Post Reply

Return to “Sound, Multimedia, & Codecs”