Microphone stops working when headphones are plugged in

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
User avatar
Luxdragon
Level 1
Level 1
Posts: 38
Joined: Sat Feb 01, 2020 10:15 am

Microphone stops working when headphones are plugged in

Post by Luxdragon »

Good evening,

I have a peculiar issue with my microphone. Back on LM19.3, when I plugged in my headphones, my mic typically worked. Now on LM20 I have the issue that when I plug in my headphones the internal mic of my laptop stops working, just like on Windows 10. In the input section of sound settings it is possible to see how the level of input crashes to null when I plug in my earbuds.

Why does this happen and is there any way to activate my laptop's mic while headphones are plugged in?

Kind regards
User avatar
MrEen
Level 22
Level 22
Posts: 16918
Joined: Mon Jun 12, 2017 8:39 pm

Re: Microphone stops working when headphones are plugged in

Post by MrEen »

Hi Luxdragon,

Install and run PulseAudio Volume Control (pavucontrol) and watch the Input Devices tab when you plug in the headphones. I'm betting the headphones are getting recognized as a headset, so is changing to the Headset Mic. You can change it back to Internal Mic on this tab, even though it might say Internal Mic (unplugged)
User avatar
Luxdragon
Level 1
Level 1
Posts: 38
Joined: Sat Feb 01, 2020 10:15 am

Re: Microphone stops working when headphones are plugged in

Post by Luxdragon »

Hello,

I installed the utility with sudo apt install pavucontrol, but it gives the same result as in the sound settings.

Both my headphones and my headset are recognised as 'headphones' in the output and input section of both the PulseAudio and Sound settings utilities. However, when I choose the internal mic, it still doesn't record any sound until I plug my headphones out. Interestingly, when I use my headset (which has its own mic) and set the input device to 'internal microphone', my PC only records the sounds made from the headset's mic.

After some faint experimentation on Messenger, I was told that when plugged in, my headphones don't record any sound except for some quiet white noise in the background.

Odd, isn't it?
User avatar
MrEen
Level 22
Level 22
Posts: 16918
Joined: Mon Jun 12, 2017 8:39 pm

Re: Microphone stops working when headphones are plugged in

Post by MrEen »

Okay, chances are decent that having something plugged in is muting the Internal Mic. Run alsamixer in the terminal and arrow over to the Internal Mic column (not Internal Mic Boost) and if it has MM at the bottom of the column, press the m key to unmute it.

If there's still difficulty, paste the output of this command:

Code: Select all

curl https://gitlab.freedesktop.org/pulseaudio/pulseaudio/raw/master/src/utils/pa-info?inline=false | bash | nc termbin.com 9999
The last line of output will have a URL pointing to your sound setup. Maybe something in there will offer a clue as to what's happening.
User avatar
Luxdragon
Level 1
Level 1
Posts: 38
Joined: Sat Feb 01, 2020 10:15 am

Re: Microphone stops working when headphones are plugged in

Post by Luxdragon »

I ran alsamixer and got the following:

Image

If I pressed m, then the [00] would change into [MM], it was [00] even when I plugged in my headphones.

Link to the output of your command when my headphones are not plugged in:
https://termbin.com/1f9r

and when they are:
https://termbin.com/gnpi
User avatar
MrEen
Level 22
Level 22
Posts: 16918
Joined: Mon Jun 12, 2017 8:39 pm

Re: Microphone stops working when headphones are plugged in

Post by MrEen »

Okay, here's what I think is happening. Since 20 came out, a lot of people are showing a Headset Mic in this section of the output:

Code: Select all

[    4.740734] snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC233: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[    4.740738] snd_hda_codec_realtek hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    4.740740] snd_hda_codec_realtek hdaudioC1D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[    4.740740] snd_hda_codec_realtek hdaudioC1D0:    mono: mono_out=0x0
[    4.740741] snd_hda_codec_realtek hdaudioC1D0:    inputs:
[    4.740743] snd_hda_codec_realtek hdaudioC1D0:      Headset Mic=0x19
[    4.740744] snd_hda_codec_realtek hdaudioC1D0:      Internal Mic=0x12
I'm suspecting a driver change caused this, to try to allow more users to use a headset mic that weren't showing one previously. Let's disable that pin, and see if that allows your internal mic to work as expected.

Install alsa-tools-gui then run HDAJackRetask. When it opens, select ALC233 in the upper left. Then click on the Override check box for pin 0x19 below that and change the box to Not connected. Click on Apply now and test the mic. If that works, click on Install boot override to automate this so you don't have to do it after each boot.

The only other option I can think of is to mute the Headset Mic in alsamixer and see if that makes the internal mic work.
User avatar
Waarmson
Level 1
Level 1
Posts: 4
Joined: Thu Nov 19, 2020 4:36 am
Location: Atlanta

Re: Microphone stops working when headphones are plugged in

Post by Waarmson »

I am facing the same issue right now actually. As soon as I plug in my headphones, the microphone just stops working. Even the microphone from my headphones does not work. It is the same issue you listed, both the mic and the headphones are being recognized as "headphones". How did you fix it?! I am soooooo annoyed by this issue actually. I was already thinking to buy new headphones, however I am not really sure it will be any different. I guess, in case I will not be able to fix it, I will just buy a microphone. I have already read a lot of Microphone Reviews so I know which would be a good choice for me.
Last edited by Waarmson on Thu Jan 21, 2021 9:40 am, edited 1 time in total.
User avatar
MrEen
Level 22
Level 22
Posts: 16918
Joined: Mon Jun 12, 2017 8:39 pm

Re: Microphone stops working when headphones are plugged in

Post by MrEen »

Hi Waarmson,

Let's get a look at your sound setup with this command:

Code: Select all

curl https://gitlab.freedesktop.org/pulseaudio/pulseaudio/raw/master/src/utils/pa-info?inline=false | bash | nc termbin.com 9999
The last line of output will have a URL pointing to the info.
Post Reply

Return to “Sound, Multimedia, & Codecs”