[Solved] Linux Mint 20 64 bit Cinnamon, no sound from built in speakers or headphones

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Ninja_beaver
Level 1
Level 1
Posts: 16
Joined: Sun Aug 23, 2020 4:50 am

[Solved] Linux Mint 20 64 bit Cinnamon, no sound from built in speakers or headphones

Post by Ninja_beaver »

I installed Linux Mint 20 64 bit cinnamon on a Acer Veriton Z4810G yesterday and the install proceeded fine. I checked for drivers (there weren't any), applied all updates and installed the multimedia codecs and language pack for my region. Nothing produced an error.

However I am unable to get any sound from the built in speakers or headphones when I plug them into the mic in or audio port at the rear. The exception is the headphones port; plugged fully in I hear nothing but I noticed when only partially in I hear some sound, both left and right channels through both speakers at the same time.

I went back and booted from the installation DVD I created and have the same sound problems.

Other sound problem posts seem to ask for this

Code: Select all

curl https://gitlab.freedesktop.org/pulseaudio/pulseaudio/raw/master/src/utils/pa-info?inline=false | bash | nc termbin.com 9999
so it is here: https://termbin.com/cu9o

Output from inxi -Fxxxrz

Code: Select all

System:
  Kernel: 5.4.0-42-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 
  Desktop: Cinnamon 4.6.7 wm: muffin 4.6.3 dm: LightDM 1.30.0 
  Distro: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal 
Machine:
  Type: Desktop Mobo: Acer model: Veriton Z4810G serial: <filter> BIOS: Acer 
  v: P21-A1 date: 03/31/2014 
CPU:
  Topology: Dual Core model: Intel Core i5-4570T bits: 64 type: MT MCP 
  arch: Haswell rev: 3 L2 cache: 4096 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 23148 
  Speed: 799 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 799 2: 798 
  3: 798 4: 799 
Graphics:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics 
  vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0 
  chip ID: 8086:0412 
  Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2) 
  v: 4.5 Mesa 20.0.8 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio 
  vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
  bus ID: 00:03.0 chip ID: 8086:0c0c 
  Device-2: Intel 8 Series/C220 Series High Definition Audio 
  vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
  bus ID: 00:1b.0 chip ID: 8086:8c20 
  Sound Server: ALSA v: k5.4.0-42-generic 
Network:
  Device-1: Intel Ethernet I217-V vendor: Acer Incorporated ALI 
  driver: e1000e v: 3.2.6-k port: f080 bus ID: 00:19.0 chip ID: 8086:153b 
  IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Qualcomm Atheros AR9462 Wireless Network Adapter vendor: Lite-On 
  driver: ath9k v: kernel port: f040 bus ID: 02:00.0 chip ID: 168c:0034 
  IF: wlp2s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 473.23 GiB used: 15.41 GiB (3.3%) 
  ID-1: /dev/sda vendor: Seagate model: ST500LT012-1DG142 size: 465.76 GiB 
  speed: 3.0 Gb/s rotation: 5400 rpm serial: <filter> rev: SDM1 scheme: MBR 
  ID-2: /dev/sdb type: USB model: USB DISK 2.0 size: 7.46 GiB 
  serial: <filter> rev: PMAP scheme: MBR 
Partition:
  ID-1: / size: 456.95 GiB used: 15.41 GiB (3.4%) fs: ext4 dev: /dev/sda5 
Sensors:
  System Temperatures: cpu: 36.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Repos:
  No active apt repos in: /etc/apt/sources.list 
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
  1: deb http://www.mirrorservice.org/sites/packages.linuxmint.com/packages ulyana main upstream import backport
  2: deb http://archive.ubuntu.com/ubuntu focal main restricted universe multiverse
  3: deb http://archive.ubuntu.com/ubuntu focal-updates main restricted universe multiverse
  4: deb http://archive.ubuntu.com/ubuntu focal-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ focal partner
Info:
  Processes: 219 Uptime: 20m Memory: 3.75 GiB used: 929.0 MiB (24.2%) 
  Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Shell: bash 
  v: 5.0.17 running in: gnome-terminal inxi: 3.0.38
  
Last edited by Ninja_beaver on Sun Sep 06, 2020 8:52 am, edited 1 time in total.
User avatar
MrEen
Level 22
Level 22
Posts: 15266
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint 20 64 bit Cinnamon, no sound from built in speakers or headphones

Post by MrEen »

Hi Ninja_beaver, and welcome to the forum.

Your curl output had some surprises for me until I looked up your model and saw that it was an all-in-one. There is desktop stuff and laptop stuff in there which was really throwing me off. Now it makes more sense.

We might have to fiddle for a bit to find what works. The first thing I'd like you to try is to run alsamixer -c1 in the terminal. Navigate to the Headphone column, then press the up arrow to give it some volume. Don't plug in headphones just yet. Also, raise the Master column if it's still low. Now test the sound. Some machines require the Headphone column to have volume for the speakers to produce sound. That's usually a Laptop, but yours is close enough to try that.

If no luck with that, arrow over to the Auto-Mute Mode column and keep pressing the down arrow until it says Disabled. Test the sound again.

If none of that works, does this produce sound:

Code: Select all

aplay -D hw:1,2 /usr/share/sounds/alsa/Front_Center.wav
Or this:

Code: Select all

aplay -D hw:1,0 /usr/share/sounds/alsa/Front_Center.wav
Ninja_beaver
Level 1
Level 1
Posts: 16
Joined: Sun Aug 23, 2020 4:50 am

Re: Linux Mint 20 64 bit Cinnamon, no sound from built in speakers or headphones

Post by Ninja_beaver »

Hello MrEen and thanks for your help.

I set both the master and headphone columns to 80 and also unmuted the headphone column as it was muted, but still no sound.

Disabling the Auto-Mute Mode column also didn't help.

Running

Code: Select all

aplay -D hw:1,2 /usr/share/sounds/alsa/Front_Center.wav
didn't produce any sound but also outputted

Code: Select all

aplay: main:830: audio open error: No such file or directory
Running

Code: Select all

aplay -D hw:1,0 /usr/share/sounds/alsa/Front_Center.wav
didn't produce any sound but also outputted this:

Code: Select all

Playing WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
aplay: set_params:1349: Channels count not available
User avatar
MrEen
Level 22
Level 22
Posts: 15266
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint 20 64 bit Cinnamon, no sound from built in speakers or headphones

Post by MrEen »

I was afraid of that. This might be a bear to solve, just warning in advance. I'll stay with it as long as you do.

I'll mention now that something like this should work if we never find the cure.

The reason your system is going to be a pain is this:

Code: Select all

[   14.712944] snd_hda_codec_realtek hdaudioC1D2: autoconfig for ALC269VC: line_outs=1 (0x1a/0x0/0x0/0x0/0x0) type:line
[   14.712947] snd_hda_codec_realtek hdaudioC1D2:    speaker_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[   14.712949] snd_hda_codec_realtek hdaudioC1D2:    hp_outs=1 (0x15/0x0/0x0/0x0/0x0)
[   14.712950] snd_hda_codec_realtek hdaudioC1D2:    mono: mono_out=0x0
[   14.712951] snd_hda_codec_realtek hdaudioC1D2:    inputs:
[   14.712953] snd_hda_codec_realtek hdaudioC1D2:      Front Mic=0x18
[   14.712954] snd_hda_codec_realtek hdaudioC1D2:      Rear Mic=0x19
[   14.712956] snd_hda_codec_realtek hdaudioC1D2:      Internal Mic=0x12
That shows that the output is on card 1 device 2, but your aplya output shows card 1 device 0:

Code: Select all

APLAY

**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC269VC Analog [ALC269VC Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
I have seen this before, and I believe some have had the sound working with this stupid config, but it makes troubleshooting less straightforward.

One thing I need to ask; Is Speakers something built in, or a Line Out port to attached speakers? Solved by re reading the OP.

How many ports are there on that device? Headphone/Microphone/LineOut/In, etc. I suspect you have some mixer elements for things that don't exist is why I'm asking that.

One test I'd like you to run. Install alsa-tools, then run the following command 3 times. Once with no headphones plugged in, once with headphones fully plugged in, and finally with the headphones partially plugged in where you had some sound:

Code: Select all

sudo hdajacksensetest -a -c 1
Here I'm looking at the jack detection to see if that might need some work.
Ninja_beaver
Level 1
Level 1
Posts: 16
Joined: Sun Aug 23, 2020 4:50 am

Re: Linux Mint 20 64 bit Cinnamon, no sound from built in speakers or headphones

Post by Ninja_beaver »

There is one headphone out and one microphone in on the side and a combo audio jack on the rear.

Results with sudo hdajacksensetest -a -c 1

No headphones plugged in:

Code: Select all

No pins found for card 1 codec 0, did you pick the right one?
Headphones fully plugged in:

Code: Select all

No pins found for card 1 codec 0, did you pick the right one?
Partially plugged in when I get sound:

Code: Select all

No pins found for card 1 codec 0, did you pick the right one?
User avatar
MrEen
Level 22
Level 22
Posts: 15266
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint 20 64 bit Cinnamon, no sound from built in speakers or headphones

Post by MrEen »

Okay let's see this one:

Code: Select all

cat /proc/asound/cards
EDIT: Actually, I'll bet we need this:

Code: Select all

sudo hdajacksensetest -a -c 1 -d 2
Ninja_beaver
Level 1
Level 1
Posts: 16
Joined: Sun Aug 23, 2020 4:50 am

Re: Linux Mint 20 64 bit Cinnamon, no sound from built in speakers or headphones

Post by Ninja_beaver »

cat /proc/asound/cards produces

Code: Select all

 0 [HDMI           ]: HDA-Intel - HDA Intel HDMI
                      HDA Intel HDMI at 0xf7d34000 irq 33
 1 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7d30000 irq 34
sudo hdajacksensetest -a -c 1 -d 2 produces

Code: Select all

Pin 0x12 (Internal Mic): present = No
Pin 0x14 (Not connected): present = No
Pin 0x15 (Black Headphone, Front side): present = No
Pin 0x17 (Not connected): present = No
Pin 0x18 (Black Mic, Front side): present = No
Pin 0x19 (Pink Mic, Rear side): present = No
Pin 0x1a (Green Headphone, Rear side): present = No
Pin 0x1b (Internal Speaker): present = No
Pin 0x1d (Not connected): present = No
Pin 0x1e (Not connected): present = No
User avatar
MrEen
Level 22
Level 22
Posts: 15266
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint 20 64 bit Cinnamon, no sound from built in speakers or headphones

Post by MrEen »

Okay, use that all three times now.
Ninja_beaver
Level 1
Level 1
Posts: 16
Joined: Sun Aug 23, 2020 4:50 am

Re: Linux Mint 20 64 bit Cinnamon, no sound from built in speakers or headphones

Post by Ninja_beaver »

Headphones not plugged in:

Code: Select all

Pin 0x12 (Internal Mic): present = No
Pin 0x14 (Not connected): present = No
Pin 0x15 (Black Headphone, Front side): present = No
Pin 0x17 (Not connected): present = No
Pin 0x18 (Black Mic, Front side): present = No
Pin 0x19 (Pink Mic, Rear side): present = No
Pin 0x1a (Green Headphone, Rear side): present = No
Pin 0x1b (Internal Speaker): present = No
Pin 0x1d (Not connected): present = No
Pin 0x1e (Not connected): present = No
Headphones fully plugged in:

Code: Select all

Pin 0x12 (Internal Mic): present = No
Pin 0x14 (Not connected): present = No
Pin 0x15 (Black Headphone, Front side): present = No
Pin 0x17 (Not connected): present = No
Pin 0x18 (Black Mic, Front side): present = No
Pin 0x19 (Pink Mic, Rear side): present = No
Pin 0x1a (Green Headphone, Rear side): present = Yes
Pin 0x1b (Internal Speaker): present = No
Pin 0x1d (Not connected): present = No
Pin 0x1e (Not connected): present = No
Headphones partially plugged in when sound is heard:

Code: Select all

Pin 0x12 (Internal Mic): present = No
Pin 0x14 (Not connected): present = No
Pin 0x15 (Black Headphone, Front side): present = No
Pin 0x17 (Not connected): present = No
Pin 0x18 (Black Mic, Front side): present = No
Pin 0x19 (Pink Mic, Rear side): present = No
Pin 0x1a (Green Headphone, Rear side): present = No
Pin 0x1b (Internal Speaker): present = No
Pin 0x1d (Not connected): present = No
Pin 0x1e (Not connected): present = No
I also tried using some earphones and have realised I can hear audio when both earphones and headphones I was using earlier are fully plugged in, but it is extremely faint and I can only just make it out. Adjusting the system volume level doesn't seem to have any effect on how loud it is but adjusting the volume slider on YouTube does. I can't tell if this is also happening with the built in speakers, if it is it's drowned out by computers fan.
User avatar
MrEen
Level 22
Level 22
Posts: 15266
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint 20 64 bit Cinnamon, no sound from built in speakers or headphones

Post by MrEen »

Okay, the jack detection is seemingly working properly. I'm suspecting the output is being sent to the wrong port and the faint stuff you hear is bleed through from the other location.

I'm going to try to find something to address this theory and recheck your curl output.
User avatar
MrEen
Level 22
Level 22
Posts: 15266
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint 20 64 bit Cinnamon, no sound from built in speakers or headphones

Post by MrEen »

In the meantime, play something with sound and while it's playing run pacmd list-sinks in the terminal and paste that output please.
User avatar
MrEen
Level 22
Level 22
Posts: 15266
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint 20 64 bit Cinnamon, no sound from built in speakers or headphones

Post by MrEen »

Just has a thought. Install and run PulseAudio Volume Control. On the Output Devices tab, up the volume of the output Port that is active.

That might fix this all by itself. I've had several cases where simply installing that fixed issues similar to this.
Ninja_beaver
Level 1
Level 1
Posts: 16
Joined: Sun Aug 23, 2020 4:50 am

Re: Linux Mint 20 64 bit Cinnamon, no sound from built in speakers or headphones

Post by Ninja_beaver »

Running pacmd list-sinks

No headphones:

Code: Select all

1 sink(s) available.
  * index: 0
	name: <alsa_output.pci-0000_00_1b.0.analog-stereo>
	driver: <module-alsa-card.c>
	flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: RUNNING
	suspend cause: (none)
	priority: 9039
	volume: front-left: 53577 /  82% / -5.25 dB,   front-right: 53577 /  82% / -5.25 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 66.32 ms
	max request: 14 KiB
	max rewind: 14 KiB
	monitor source: 0
	sample spec: s16le 2ch 48000Hz
	channel map: front-left,front-right
	             Stereo
	used by: 1
	linked by: 1
	configured latency: 75.00 ms; range is 0.50 .. 341.33 ms
	card: 1 <alsa_card.pci-0000_00_1b.0>
	module: 8
	properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "ALC269VC Analog"
		alsa.id = "ALC269VC Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "1"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xf7d30000 irq 34"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1b.0"
		sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card1"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "8c20"
		device.product.name = "8 Series/C220 Series Chipset High Definition Audio Controller"
		device.form_factor = "internal"
		device.string = "front:1"
		device.buffering.buffer_size = "65536"
		device.buffering.fragment_size = "32768"
		device.access_mode = "mmap+timer"
		device.profile.name = "analog-stereo"
		device.profile.description = "Analogue Stereo"
		device.description = "Built-in Audio Analogue Stereo"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	ports:
		analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
			properties:
				device.icon_name = "audio-speakers"
		analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-headphones"
	active port: <analog-output-speaker>
Headphones fully plugged in:

Code: Select all

1 sink(s) available.
  * index: 0
	name: <alsa_output.pci-0000_00_1b.0.analog-stereo>
	driver: <module-alsa-card.c>
	flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: RUNNING
	suspend cause: (none)
	priority: 9039
	volume: front-left: 5420 /   8% / -64.95 dB,   front-right: 5420 /   8% / -64.95 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 74.84 ms
	max request: 14 KiB
	max rewind: 14 KiB
	monitor source: 0
	sample spec: s16le 2ch 48000Hz
	channel map: front-left,front-right
	             Stereo
	used by: 1
	linked by: 1
	configured latency: 75.00 ms; range is 0.50 .. 341.33 ms
	card: 1 <alsa_card.pci-0000_00_1b.0>
	module: 8
	properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "ALC269VC Analog"
		alsa.id = "ALC269VC Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "1"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xf7d30000 irq 34"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1b.0"
		sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card1"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "8c20"
		device.product.name = "8 Series/C220 Series Chipset High Definition Audio Controller"
		device.form_factor = "internal"
		device.string = "front:1"
		device.buffering.buffer_size = "65536"
		device.buffering.fragment_size = "32768"
		device.access_mode = "mmap+timer"
		device.profile.name = "analog-stereo"
		device.profile.description = "Analogue Stereo"
		device.description = "Built-in Audio Analogue Stereo"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	ports:
		analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-speakers"
		analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: yes)
			properties:
				device.icon_name = "audio-headphones"
	active port: <analog-output-headphones>
Headphones partially with sound heard:

Code: Select all

1 sink(s) available.
  * index: 0
	name: <alsa_output.pci-0000_00_1b.0.analog-stereo>
	driver: <module-alsa-card.c>
	flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: RUNNING
	suspend cause: (none)
	priority: 9039
	volume: front-left: 53577 /  82% / -5.25 dB,   front-right: 53577 /  82% / -5.25 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 74.90 ms
	max request: 14 KiB
	max rewind: 14 KiB
	monitor source: 0
	sample spec: s16le 2ch 48000Hz
	channel map: front-left,front-right
	             Stereo
	used by: 1
	linked by: 1
	configured latency: 75.00 ms; range is 0.50 .. 341.33 ms
	card: 1 <alsa_card.pci-0000_00_1b.0>
	module: 8
	properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "ALC269VC Analog"
		alsa.id = "ALC269VC Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "1"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xf7d30000 irq 34"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1b.0"
		sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card1"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "8c20"
		device.product.name = "8 Series/C220 Series Chipset High Definition Audio Controller"
		device.form_factor = "internal"
		device.string = "front:1"
		device.buffering.buffer_size = "65536"
		device.buffering.fragment_size = "32768"
		device.access_mode = "mmap+timer"
		device.profile.name = "analog-stereo"
		device.profile.description = "Analogue Stereo"
		device.description = "Built-in Audio Analogue Stereo"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	ports:
		analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
			properties:
				device.icon_name = "audio-speakers"
		analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-headphones"
	active port: <analog-output-speaker>
I installed PulseAudio Volume Control and upped the volume control but this did not fix the issue.

As you suggested the audio might be being sent to the wrong port, I also tried changing the port from "headphones (plugged in)" to "speakers (unavailable)" when headphones are fully plugged in and can now hear sound in stereo through the headphones. Doing a similar trick for the built-in speakers doesn't work though. The port also resets after I restart.

So that's progress I think.
User avatar
MrEen
Level 22
Level 22
Posts: 15266
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint 20 64 bit Cinnamon, no sound from built in speakers or headphones

Post by MrEen »

Is Windows still on this machine? If so, ensure Fast Startup is off. Shut down when done in Windows, don't reboot. Wait a few minutes then boot to Mint and test the sound.
Ninja_beaver
Level 1
Level 1
Posts: 16
Joined: Sun Aug 23, 2020 4:50 am

Re: Linux Mint 20 64 bit Cinnamon, no sound from built in speakers or headphones

Post by Ninja_beaver »

Windows is no longer on the machine, I overwrote it when installing Mint. I do have an old clone though. It had Windows 7 on it which as far as I can tell didn't have fast startup as a feature.
User avatar
MrEen
Level 22
Level 22
Posts: 15266
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint 20 64 bit Cinnamon, no sound from built in speakers or headphones

Post by MrEen »

Ninja_beaver wrote:
Mon Aug 24, 2020 2:58 pm
It had Windows 7 on it which as far as I can tell didn't have fast startup as a feature.
As far as I know, that's correct. It was worth asking anyway.

Let's give this a shot and see if it improves anything:

Code: Select all

apt install --reinstall alsa-base alsa-utils pulseaudio linux-sound-base libasound2
And if I didn't already mention it, also delete the files in /home/tom/.config/pulse then reboot after both and test.
Ninja_beaver
Level 1
Level 1
Posts: 16
Joined: Sun Aug 23, 2020 4:50 am

Re: Linux Mint 20 64 bit Cinnamon, no sound from built in speakers or headphones

Post by Ninja_beaver »

Unfortunately, I still don't have sound through either built-in speakers or headphones.
User avatar
MrEen
Level 22
Level 22
Posts: 15266
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint 20 64 bit Cinnamon, no sound from built in speakers or headphones

Post by MrEen »

Okay, let's start getting radical with your system. Run this:

Code: Select all

pacmd load-module module-alsa-sink device=hw:1,2
If there are no errors, test the sound. Make sure to check that things aren't muted, and there might be a new option in your sound settings you might need to choose manually.

A reboot will undo whatever this does, so there's nothing to fear here.

EDIT: I'll add the next step if the above fails. Reboot, then run this and test the sound:

Code: Select all

[code]pacmd load-module module-alsa-sink device=hw:1,0
[/code]

There is such a screwy mix of card#, device# mixes in your curl output I'm hoping one of those two solves this.

Once we know which one works, we'll make a small edit to automate this so you don't have to do it on each boot.
Ninja_beaver
Level 1
Level 1
Posts: 16
Joined: Sun Aug 23, 2020 4:50 am

Re: Linux Mint 20 64 bit Cinnamon, no sound from built in speakers or headphones

Post by Ninja_beaver »

First command ran without errors, but no sound. Also checked alsamixer and ensured both headphones and speaker columns were unmuted, but nothing.

Second command also ran without error. In sound settings an additional device names "Built-in audio" has appeared, but I still don't have sound.
User avatar
MrEen
Level 22
Level 22
Posts: 15266
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint 20 64 bit Cinnamon, no sound from built in speakers or headphones

Post by MrEen »

Ninja_beaver wrote:
Tue Aug 25, 2020 10:30 am
Second command also ran without error. In sound settings an additional device names "Built-in audio" has appeared, but I still don't have sound.
Okay, make sure you select that, then use pavucontrol to check if it's muted and has volume as well. If nothing is happening, while sound is playing run pacmd list-sinks and paste that output. PulseAudio has been playing to hw:1,1 thus far, so I'm hopeful we can get hw:1,0 to work.
Post Reply

Return to “Sound, Multimedia, & Codecs”