Page 1 of 1

[Solved] Duplicated sound at speakers and headphones - Resolution info

Posted: Mon Sep 14, 2020 8:26 pm
by Fontenele
Hello everyone,

I was having a issue with sound output between the speakers and the headphones of my desktop. The speakers are connected at the back of the computer case and the headphones in the front.

First of all, when i selected the headphones as output, the sound came from headphones and speakers at the same time, and if selected line out, had no sound, so i went to to the terminal and typed alsamixer. With the arrows, i found AutoMute enabled, so i disabled it.

Now, when i selected line out (speakers) i had sound, but, when i selected headphones at output, i had both headphones and speakers emitting sound.

I noticed that, at headphones option, through alsamixer, that the channels "headphones" and "front" were at 100, so i edited the file below (use the text editor of your preference):

sudo vim /usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones.conf

Code: Select all

; On some machines Front is actually a part of the Headphone path  (<===Relevant info)
[Element Front]
switch = off  (<===Switched to off)
volume = off  (<===Switched to off)
File saved, did the command sudo alsactl store to save the configuration, rebooted and everything was fine, with the proper audio outputs.

I made this post to share if someone else with the same problem and as reference for me in a future Linux Mint installation.

I hope anyone find it useful.

Fontenele

Re: [Solved] Duplicated sound at speakers and headphones - Resolution info

Posted: Mon Sep 14, 2020 8:33 pm
by MrEen
Hi Fontenele,

Nice work figuring out what to edit to achieve your goal!

And thanks for sharing how to reproduce it. :D

Re: [Solved] Duplicated sound at speakers and headphones - Resolution info

Posted: Mon Sep 14, 2020 8:36 pm
by Fontenele
Hello there MrEen,

That's why we are here for, to help each other.

Thanks for the reply.

Fontenele