LM 20 MATE, No login logout or system event sounds

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
JaguarNight
Level 3
Level 3
Posts: 119
Joined: Sat Feb 19, 2011 3:06 pm

LM 20 MATE, No login logout or system event sounds

Post by JaguarNight »

LM 20 MATE fresh install
I'm not getting any login or logout or system event or windows or notification sounds after installation.

Sound Preferences -> Output volume and Alert volume set to about 100%
Theme is set to Linux Mint
Alert sounds -> from Theme is checked, no alert sound listed in the box below.
Enable window and button sounds is checked.
Speaker tests work fine.
Firefox youtube sounds fine.
/user/share/sounds all sound files are there and they play ok.

However, not login logout system window event or notification sounds play.

Plz help here.
User avatar
MrEen
Level 22
Level 22
Posts: 16828
Joined: Mon Jun 12, 2017 8:39 pm

Re: LM 20 MATE, No login logout or system event sounds

Post by MrEen »

Hi JaguarNight,

Run PulseAudio Volume Control (pavucontrol) and raise the System Sounds volume on the Playback tab.

Install pavucontrol if necessary.
JaguarNight
Level 3
Level 3
Posts: 119
Joined: Sat Feb 19, 2011 3:06 pm

Re: LM 20 MATE, No login logout or system event sounds

Post by JaguarNight »

Pavu has been installed before posting and playback volume cranked to 100%, makes no difference,
the only sound there is ping on volume slider move.
JaguarNight
Level 3
Level 3
Posts: 119
Joined: Sat Feb 19, 2011 3:06 pm

Re: LM 20 MATE, No login logout or system event sounds

Post by JaguarNight »

Update:
installed cinnamon and logged into it - all system theme sounds work fine
logged out and logged back into mate -> no system theme sounds
meaning it's not hardware related nor ubuntu problem

mate -> pavucontrol -> playback tab ( system sounds ) --> moving volume slider -> no sound ping on movement
ie system sound volume not working !!!

mate -> sound preferences -> output volume or alert volume -> move slider -> getting sound ping on both

and another clue: booting live cd mate 20 - same exact problem, no login / logout sound and no system sounds with pavucontrol installed and playback volume cranked all the way up

Anybody else can help here ???
JaguarNight
Level 3
Level 3
Posts: 119
Joined: Sat Feb 19, 2011 3:06 pm

Re: LM 20 MATE, No login logout or system event sounds

Post by JaguarNight »

Update:
followed this xfce system sounds problem thread ->
https://forum.xfce.org/viewtopic.php?id=12609

added the following to ~/.profile to the end of file
GTK_MODULES="$GTK_MODULES:canberra-gtk-module"
export GTK_MODULES

window sounds now work
however there are still no login and logout sounds
and no notification sounds
JaguarNight
Level 3
Level 3
Posts: 119
Joined: Sat Feb 19, 2011 3:06 pm

Re: LM 20 MATE, No login logout or system event sounds

Post by JaguarNight »

Eventually, because I could not make all systems sounds work in LM20 Mate, I switched to Cinnamon.

Regards.
User avatar
MrEen
Level 22
Level 22
Posts: 16828
Joined: Mon Jun 12, 2017 8:39 pm

Re: LM 20 MATE, No login logout or system event sounds

Post by MrEen »

Hi JaguarNight,

Each Desktop Environment handles these things somewhat differently. I don't use MATE, so couldn't help with that. And Cinnamon's version is completely different from Xfce as the Mint developers have written a way for Cinnamon to have everything working. Even on Xfce, the login and logout sounds are not done as part of the System Sounds but as Startup Applications (assuming you don't want to hack your OS like I did just to make it work.)

Anyway, I hope you'll be happy with Cinnamon from here on out. :D
Post Reply

Return to “Sound, Multimedia, & Codecs”