No Sound Linux Mint 20 pulse audio update 1:13.99.1-1

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
Ok5Grizzly
Level 1
Level 1
Posts: 5
Joined: Thu Oct 01, 2020 8:41 pm

No Sound Linux Mint 20 pulse audio update 1:13.99.1-1

Post by Ok5Grizzly »

Linux mint 20 no sound. No output to speakers.
My sound was just fine on linux mint 19.3 on other ssd.
Installed linux mint 20 iso to new ssd.
Without any updates, linux mint 20 sound is ok, it works.
On updates I don't install pulse audio vs 1:13.99.1-1
All other updates in linux mint 20, including newest kernel, sound still works.
When I install pulse audio vs 1:13.99.1-1 it breaks the sound and no output?
I've tried and checked everything, and sound doesn't work with this update.
I've tried backup sound profile, restore profile doesn't work.
It will not restore my backup profile from when sound was working.
Checked for muted sound in alsa mixer, all ok.
Used pulse audio control app and configuration, set the sound and it will test and work.
Logout and reboot no sound with pulse audio vs 1:13.99.1-1 update installed.
Timeshift has saved this install and i keep going back to original install with sound working.
I have posted .png screenshots.
System hardware, sound working, and not working.

I have a few friends with this same issue with home built pc's with asus motherboards trying to run linux mint 20?
Ubuntu 20.04, manjaro, live, same issue from 32 gb flash drive.
They keep going back to Linux Mint 19.3 where sound just works with no problems.
My pc hardware is as follow.
Motherboard ASUS model: M5A97 R2.0 v: Rev 1.xx
AMD® 970 Chipset
Graphics Nvidia GeForce GT 730
CPU AMD FX-8300 cores 8, 64 bit.
Speakers Cyber Acoustics CA-4100 4.1.
Bottom line, pulse audio vs 1:13.99.1-1 update, sound doesn't work in Linux Mint 20.
I spent a week trying to solve this problem with no results.
Sure would like to run mint 20.
I plug my old ssd with Linux Mint 19.3 back in and every thing just works.
Links to screenshots below.

https://postimg.cc/gallery/HsHkfMJ
Image

Image

Image

Image
User avatar
MrEen
Level 22
Level 22
Posts: 15285
Joined: Mon Jun 12, 2017 8:39 pm

Re: No Sound Linux Mint 20 pulse audio update 1:13.99.1-1

Post by MrEen »

Hi Ok5Grizzly, and welcome to the forum.

First, the update that's killing your sound is 1:13.99.1-1ubuntu3.6 from any of 1:13.99.1-1ubuntu3 through 1:13.99.1-1ubuntu3.5. All of them have the same version in them as what you posted, so just wanted you and anyone reading this to be aware of that.

Now, while 1:13.99.1-1ubuntu3.7 will be available any second, we can probably take another route to fixing this short term. Let me see the output of dmesg | grep snd and I'm guessing we're going to see ALC295 involved here.

The "solution" that has worked for a bit more than half the users affected by this regression is to blacklist the realtek driver module, allowing the generic driver module to take over. If ALC295 is indeed in the dmesg output, run this then shut down for two minutes and you will hopefully be in the majority of users that this works for:

Code: Select all

sudo tee /etc/modprobe.d/blacklist-realtek.conf <<<'blacklist snd_hda_codec_realtek' 
The users that are not fixed with this tend to then have no sound at all. If that happens to you, we can undo the change with this command followed by a reboot:

Code: Select all

sudo rm /etc/modprobe.d/blacklist-realtek.conf
If there's still an issue, paste the output of this command in working and not working scenarios:

Code: Select all

curl https://gitlab.freedesktop.org/pulseaudio/pulseaudio/raw/master/src/utils/pa-info?inline=false | bash | nc termbin.com 9999
The last line of output will have a URL pointing to your sound setup. That might give us a clue on a better "fix" for this.
Ok5Grizzly
Level 1
Level 1
Posts: 5
Joined: Thu Oct 01, 2020 8:41 pm

Re: No Sound Linux Mint 20 pulse audio update 1:13.99.1-1

Post by Ok5Grizzly »

grizzly9@grizzly9-desktop:~$ sudo tee /etc/modprobe.d/blacklist-realtek.conf <<<'blacklist snd_hda_codec_realtek'
[sudo] password for grizzly9:
blacklist snd_hda_codec_realtek
grizzly9@grizzly9-desktop:~$
Ok5Grizzly
Level 1
Level 1
Posts: 5
Joined: Thu Oct 01, 2020 8:41 pm

Re: No Sound Linux Mint 20 pulse audio update 1:13.99.1-1

Post by Ok5Grizzly »

grizzly9@grizzly9-desktop:~$ curl https://gitlab.freedesktop.org/pulseaud ... line=false | bash | nc termbin.com 9999
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 2039 100 2039 0 0 1817 0 0:00:01 0:00:01 --:--:-- 1817
https://termbin.com/o7vr
grizzly9@grizzly9-desktop:~$
Ok5Grizzly
Level 1
Level 1
Posts: 5
Joined: Thu Oct 01, 2020 8:41 pm

Re: No Sound Linux Mint 20 pulse audio update 1:13.99.1-1

Post by Ok5Grizzly »

When I downgrade to pulseaudio 1:13.99.1-1ubuntu3.2 I have sound in Linux Mint 20.
I use this command:
apt update && apt install libpulse-mainloop-glib0=1:13.99.1-1ubuntu3.2 libpulse0=1:13.99.1-1ubuntu3.2 libpulsedsp=1:13.99.1-1ubuntu3.2 pulseaudio=1:13.99.1-1ubuntu3.2 pulseaudio-module-bluetooth=1:13.99.1-1ubuntu3.2 pulseaudio-utils=1:13.99.1-1ubuntu3.2

When I install wine 5.0.2 it installs pulseaudio 1:13.99.1-1ubuntu3.7 back into system, and after reboot I have no sound again.
I need wine to install my ms windows hoyle card and board games which all works fine in Linux Mint 19.3.
Here is my inxi -Fxxrzc0 report on my pc system.

Code: Select all

grizzly9@grizzly9-desktop:~$ inxi -Fxxrzc0
System:
  Kernel: 5.4.0-48-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 
  Desktop: Cinnamon 4.6.7 wm: muffin dm: LightDM 
  Distro: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal 
Machine:
  Type: Desktop Mobo: ASUSTeK model: M5A97 R2.0 v: Rev 1.xx serial: <filter> 
  UEFI: American Megatrends v: 2603 date: 06/26/2015 
CPU:
  Topology: 8-Core model: AMD FX-8300 bits: 64 type: MCP arch: Bulldozer 
  L2 cache: 2048 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 52974 
  Speed: 1472 MHz min/max: 1400/3300 MHz Core speeds (MHz): 1: 1464 2: 1740 
  3: 1403 4: 1402 5: 1401 6: 1404 7: 1402 8: 1401 
Graphics:
  Device-1: NVIDIA GK208B [GeForce GT 730] vendor: eVga.com. driver: nvidia 
  v: 450.80.02 bus ID: 01:00.0 chip ID: 10de:1287 
  Display: x11 server: X.Org 1.20.8 driver: nvidia 
  unloaded: fbdev,modesetting,nouveau,vesa resolution: 1680x1050~60Hz 
  OpenGL: renderer: GeForce GT 730/PCIe/SSE2 v: 4.6.0 NVIDIA 450.80.02 
  direct render: Yes 
Audio:
  Device-1: AMD SBx00 Azalia vendor: ASUSTeK driver: snd_hda_intel v: kernel 
  bus ID: 00:14.2 chip ID: 1002:4383 
  Device-2: NVIDIA GK208 HDMI/DP Audio vendor: eVga.com. 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0e0f 
  Sound Server: ALSA v: k5.4.0-48-generic 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK P8 series driver: r8169 v: kernel port: d000 
  bus ID: 02:00.0 chip ID: 10ec:8168 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Ralink RT5372 Wireless Adapter type: USB driver: rt2800usb 
  bus ID: 1-4:2 chip ID: 148f:5372 
  IF: wlx9cefd5fe7824 state: up mac: <filter> 
Drives:
  Local Storage: total: 960.16 GiB used: 30.88 GiB (3.2%) 
  ID-1: /dev/sda type: USB model: USB 3.0 size: 465.76 GiB serial: <filter> 
  ID-2: /dev/sdb vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB 
  speed: 6.0 Gb/s serial: <filter> 
  ID-3: /dev/sdc type: USB vendor: SanDisk model: Ultra size: 28.64 GiB 
  serial: <filter> 
Partition:
  ID-1: / size: 42.05 GiB used: 22.63 GiB (53.8%) fs: ext4 dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 30.1 C mobo: N/A gpu: nvidia temp: 45 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 32% 
Repos:
  No active apt repos in: /etc/apt/sources.list 
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
  1: deb http://packages.linuxmint.com ulyana main upstream import backport #id:linuxmint_main
  2: deb http://archive.ubuntu.com/ubuntu focal main restricted universe multiverse
  3: deb http://archive.ubuntu.com/ubuntu focal-updates main restricted universe multiverse
  4: deb http://archive.ubuntu.com/ubuntu focal-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ focal partner
  Active apt repos in: /etc/apt/sources.list.d/teejee2008-ppa-focal.list 
  1: deb http://ppa.launchpad.net/teejee2008/ppa/ubuntu focal main
Info:
  Processes: 251 Uptime: 5m Memory: 7.68 GiB used: 982.0 MiB (12.5%) 
  Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Shell: bash 
  v: 5.0.17 running in: gnome-terminal inxi: 3.0.38 
grizzly9@grizzly9-desktop:~$ uname -r
5.4.0-48-generic

Here is my sudo aplay -l report in terminal. It shows 2 sound devices, but I only need analog.

Code: Select all

grizzly9@grizzly9-desktop:~$ sudo aplay -l
[sudo] password for grizzly9:      
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
grizzly9@grizzly9-desktop:~$ 
Here are the screen shots of no sound in Linux Mint 20. I'm using the newest pulseaudio 1:13.99.1-1ubuntu3.7

https://i.postimg.cc/qB2wZ39G/No-Sound- ... ntu3-7.png

https://i.postimg.cc/wvLXPCbB/Alsamixer ... ntu3-7.png

https://i.postimg.cc/nr1P8jwM/No-Sound- ... -Mo-Bo.png

https://i.postimg.cc/KzSqRr6R/Sound-wor ... ntu3-2.png
Last edited by MrEen on Mon Oct 12, 2020 8:14 pm, edited 1 time in total.
Reason: Added code tags to preserve formatting.
User avatar
MrEen
Level 22
Level 22
Posts: 15285
Joined: Mon Jun 12, 2017 8:39 pm

Re: No Sound Linux Mint 20 pulse audio update 1:13.99.1-1

Post by MrEen »

Okay, a few things.

1. If you run this again, does it indicate it's going to uninstall Wine:

Code: Select all

apt update && apt install libpulse-mainloop-glib0=1:13.99.1-1ubuntu3.2 libpulse0=1:13.99.1-1ubuntu3.2 libpulsedsp=1:13.99.1-1ubuntu3.2 pulseaudio=1:13.99.1-1ubuntu3.2 pulseaudio-module-bluetooth=1:13.99.1-1ubuntu3.2 pulseaudio-utils=1:13.99.1-1ubuntu3.2
You'll have to read everything in the terminal output to know what it's going to do, so be careful, and don't allow it to continue if it's going to touch Wine.

2. The curl output; Was that with working sound? I ask because it looked mostly normal, including the surround output selected as default.

3. Did you ever reboot after trying the blacklist? It wasn't active when you ran the curl command.

4. You've also set a deprecated setting with dmic_detect=0 most likely in a file in /etc/modprobe.d. You should undo that change. If you can't remember where you set that, this will show you:

Code: Select all

grep dmic /etc/modprobe.d/*
Ok5Grizzly
Level 1
Level 1
Posts: 5
Joined: Thu Oct 01, 2020 8:41 pm

Re: No Sound Linux Mint 20 pulse audio update 1:13.99.1-1

Post by Ok5Grizzly »

Wine 5.0.2 is already not working after update to pulseaudio 1:13.99.1-1ubuntu3.7
Wine shows in the menu, but won't work.
I'm in very rural Oklahoma in the sticks, so internet is a little slow at times.
Please bear with me, and thanks for the help.
Results from modprobe:

grizzly9@grizzly9-desktop:~$ grep dmic /etc/modprobe.d/*
/etc/modprobe.d/alsa-base.conf:options snd-hda-intel dmic_detect=0
grizzly9@grizzly9-desktop:~$

I don't really want to down grade pulse audio again because wine is already showing uninstalled.
https://i.postimg.cc/3JJxSW1c/wine-not- ... update.png
I've used timeshift to restore many times now and at this point I don't know what to do.
User avatar
MrEen
Level 22
Level 22
Posts: 15285
Joined: Mon Jun 12, 2017 8:39 pm

Re: No Sound Linux Mint 20 pulse audio update 1:13.99.1-1

Post by MrEen »

Okay, to remove the edit you made run xed admin:///etc/modprobe.d/alsa-base.conf and when the file opens you probably added the line at the bottom. Simply remove the line, save the file, then reboot to be rid of that one. But don't reboot just yet.

Then run this one again:

Code: Select all

sudo tee /etc/modprobe.d/blacklist-realtek.conf <<<'blacklist snd_hda_codec_realtek'
That will simply overwrite the previous one if it's still there.

Now, shut down the computer for a few minutes. When you boot back up, if sound isn't working right away, reboot once more and test it again.

Only then, if it didn't help, should you run this to remove that edit:

Code: Select all

sudo rm /etc/modprobe.d/blacklist-realtek.conf
Then paste the output of this command:

Code: Select all

pacmd list-cards
Regarding Wine; I suggest you start a new thread for that issue. I don't use it, so can't help with it. But do mention in the new thread how you tried to install it. I know that matters.
Post Reply

Return to “Sound, Multimedia, & Codecs”