[Solved] No sound on Mint 20

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
Agrippinus
Level 1
Level 1
Posts: 14
Joined: Sat Aug 03, 2019 3:04 pm

[Solved] No sound on Mint 20

Post by Agrippinus »

Hello,

I have had Linux Mint installed for several years without any trouble.
I have installed Mint 20 (on the same laptop that had 19 installed) with no problem in the first place but now I only have the sound working on some boots and not others and I'm more frequently without sound than with.

In case of emergency (crash of the system) on an other partition I made an other installation of Mint 20, but with no modification and no update at all, and when I boot on this installation, as a test, the sound works fine.

Would anyone help me to solve this problem?

Here are the inxi data:

Code: Select all

philippe@Athena:~$ inxi -Fz
System:    Kernel: 5.4.0-48-generic x86_64 bits: 64 Desktop: Cinnamon 4.6.7 Distro: Linux Mint 20 Ulyana 
Machine:   Type: Laptop System: Entroware product: Athena v: EL01R6P serial: <filter> 
           Mobo: Entroware model: Athena v: EL01R6P serial: <filter> UEFI: INSYDE v: 1.07.08EE date: 05/07/2019 
Battery:   ID-1: BAT0 charge: 57.7 Wh condition: 57.7/56.2 Wh (103%) 
CPU:       Topology: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP L2 cache: 12.0 MiB 
           Speed: 800 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 801 5: 800 6: 800 7: 800 8: 800 
           9: 800 10: 800 11: 800 12: 800 
Graphics:  Device-1: Intel UHD Graphics 630 driver: i915 v: kernel 
           Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] driver: nvidia v: 450.66 
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia unloaded: fbdev,nouveau,vesa 
           resolution: 1920x1080~144Hz 
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.0.8 
Audio:     Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel 
           Sound Server: ALSA v: k5.4.0-48-generic 
Network:   Device-1: Intel Wireless-AC 9260 driver: iwlwifi 
           IF: wlp8s0 state: down mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
           IF: enp9s0 state: up speed: 10 Mbps duplex: half mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 412.37 GiB (44.3%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 1TB size: 931.51 GiB 
Partition: ID-1: / size: 28.80 GiB used: 10.45 GiB (36.3%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /home size: 826.00 GiB used: 394.09 GiB (47.7%) fs: ext4 dev: /dev/nvme0n1p5 
Sensors:   System Temperatures: cpu: 53.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 324 Uptime: 1h 19m Memory: 15.36 GiB used: 1.75 GiB (11.4%) Shell: bash inxi: 3.0.38 
I copied this command on another thread but don't know what it's useful for:

Code: Select all

philippe@Athena:~$ curl https://gitlab.freedesktop.org/pulseaudio/pulseaudio/raw/master/src/utils/pa-info?inline=false | bash | nc termbin.com 9999
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  2039  100  2039    0     0   4195      0 --:--:-- --:--:-- --:--:--  4186
https://termbin.com/si69 
I may post any data that you would require.

Thank you!
Last edited by Agrippinus on Thu Oct 08, 2020 5:12 pm, edited 1 time in total.
Linux Mint 20 _ 64 bits - Cinnamon 4.6.7 - Kernel 5.4.0-48 - Laptop Entroware Athena
Agrippinus
Level 1
Level 1
Posts: 14
Joined: Sat Aug 03, 2019 3:04 pm

Re: No sound on Mint 20

Post by Agrippinus »

Update: the sound works if:

— I use a DAC on the USB port
— or headphones with the bluetooth

and if I put the plug of my speakers on my smartphone.
Linux Mint 20 _ 64 bits - Cinnamon 4.6.7 - Kernel 5.4.0-48 - Laptop Entroware Athena
Agrippinus
Level 1
Level 1
Posts: 14
Joined: Sat Aug 03, 2019 3:04 pm

Re: No sound on Mint 20

Post by Agrippinus »

One more time, after reboot the sound works!
Linux Mint 20 _ 64 bits - Cinnamon 4.6.7 - Kernel 5.4.0-48 - Laptop Entroware Athena
User avatar
MrEen
Level 22
Level 22
Posts: 15236
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on Mint 20

Post by MrEen »

Hi Agrippinus,

You've got errors up the wazoo that are probably an indication of the trouble you're experiencing:

Code: Select all

[   11.077869] Bluetooth: RFCOMM ver 1.11
[   17.017452] snd_hda_intel 0000:00:1f.3: No response from codec, disabling MSI: last cmd=0x20224017
[   18.025456] snd_hda_intel 0000:00:1f.3: No response from codec, resetting bus: last cmd=0x20224017
[   19.233436] snd_hda_intel 0000:00:1f.3: No response from codec, resetting bus: last cmd=0x202a0000
[   20.525456] snd_hda_intel 0000:00:1f.3: azx_get_response timeout, switching to single_cmd mode: last cmd=0x20270600
[   20.525601] azx_single_wait_for_response: 14 callbacks suppressed
[   21.088138] snd_hda_codec_hdmi hdaudioC0D2: Unable to sync register 0x2f0d00. -5
[   21.539229] snd_hda_codec_realtek hdaudioC0D0: Unable to sync register 0x2b8000. -5
[   21.539438] snd_hda_codec_realtek hdaudioC0D0: Unable to sync register 0x2b8000. -5
[   27.805523] azx_single_send_cmd: 740 callbacks suppressed
--
[  179.257195] azx_single_send_cmd: 217 callbacks suppressed
[  179.699850] snd_hda_codec_realtek hdaudioC0D0: Unable to sync register 0x2b8000. -5
[  179.700035] snd_hda_codec_realtek hdaudioC0D0: Unable to sync register 0x2b8000. -5
[  343.908298] mce: CPU2: Core temperature above threshold, cpu clock throttled (total events = 4015)
--
[ 1158.403206] azx_single_send_cmd: 215 callbacks suppressed
[ 1158.853936] snd_hda_codec_realtek hdaudioC0D0: Unable to sync register 0x2b8000. -5
[ 1158.854134] snd_hda_codec_realtek hdaudioC0D0: Unable to sync register 0x2b8000. -5
[ 1207.163324] azx_single_send_cmd: 235 callbacks suppressed
--
[ 1279.316199] azx_single_send_cmd: 215 callbacks suppressed
[ 1279.757841] snd_hda_codec_realtek hdaudioC0D0: Unable to sync register 0x2b8000. -5
[ 1279.758049] snd_hda_codec_realtek hdaudioC0D0: Unable to sync register 0x2b8000. -5
[ 1285.611152] mce: CPU9: Package temperature above threshold, cpu clock throttled (total events = 6810)
--
[ 1597.755764] azx_single_send_cmd: 215 callbacks suppressed
[ 1598.205924] snd_hda_codec_realtek hdaudioC0D0: Unable to sync register 0x2b8000. -5
[ 1598.206134] snd_hda_codec_realtek hdaudioC0D0: Unable to sync register 0x2b8000. -5
[ 1604.757865] azx_single_send_cmd: 235 callbacks suppressed
--
[ 1666.673319] azx_single_send_cmd: 215 callbacks suppressed
[ 1667.117178] snd_hda_codec_realtek hdaudioC0D0: Unable to sync register 0x2b8000. -5
[ 1667.117388] snd_hda_codec_realtek hdaudioC0D0: Unable to sync register 0x2b8000. -5
[ 1792.567264] azx_single_send_cmd: 235 callbacks suppressed
--
[ 4697.832590] azx_single_send_cmd: 215 callbacks suppressed
[ 4698.275126] snd_hda_codec_realtek hdaudioC0D0: Unable to sync register 0x2b8000. -5
[ 4698.275335] snd_hda_codec_realtek hdaudioC0D0: Unable to sync register 0x2b8000. -5
[ 4698.564570] snd_hda_codec_hdmi hdaudioC0D2: Unable to sync register 0x2f0d00. -5
The first thing I'd try in your case is running this then rebooting and testing:

Code: Select all

sudo tee /etc/modprobe.d/1220-fix.conf <<<'options snd-hda-intel probe_mask=1'
If that doesn't help or makes things worse, it can be removed with this command:

Code: Select all

sudo rm /etc/modprobe.d/1220-fix.conf
I also don't like seeing this one:

Code: Select all

[ 1285.611152] mce: CPU9: Package temperature above threshold, cpu clock throttled (total events = 6810)
Make sure the vent ports are clear of obstructions.
Agrippinus
Level 1
Level 1
Posts: 14
Joined: Sat Aug 03, 2019 3:04 pm

Re: No sound on Mint 20

Post by Agrippinus »

Hello MrEen,

I don't understand: I didn't post the data that you use, where do they come from? Didn't you confuse 2 threads on the forum?
Linux Mint 20 _ 64 bits - Cinnamon 4.6.7 - Kernel 5.4.0-48 - Laptop Entroware Athena
User avatar
MrEen
Level 22
Level 22
Posts: 15236
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on Mint 20

Post by MrEen »

Hi Agrippinus,

The output you didn't understand is where I got the info from:

Code: Select all

philippe@Athena:~$ curl https://gitlab.freedesktop.org/pulseaudio/pulseaudio/raw/master/src/utils/pa-info?inline=false | bash | nc termbin.com 9999
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  2039  100  2039    0     0   4195      0 --:--:-- --:--:-- --:--:--  4186
https://termbin.com/si69 
Notice that the last line has a URL? That points to your sound setup.

Go ahead and try the suggestion I made and let us know if that solves this issue.
Agrippinus
Level 1
Level 1
Posts: 14
Joined: Sat Aug 03, 2019 3:04 pm

Re: No sound on Mint 20

Post by Agrippinus »

Oh yes, I understand! This system is very clever.

I entered the command:

Code: Select all

philippe@Athena:~$ sudo tee /etc/modprobe.d/1220-fix.conf <<<'options snd-hda-intel probe_mask=1'
[sudo] Mot de passe de philippe :          
options snd-hda-intel probe_mask=1
philippe@Athena:~$ 
And rebooted and the sound is working but as I said above the appearance of this issue depends on the boot.
I'll see what happens and be sure that I'll let you know how things are going.

Anyway, thank you very much for answering me MrEen!
Linux Mint 20 _ 64 bits - Cinnamon 4.6.7 - Kernel 5.4.0-48 - Laptop Entroware Athena
User avatar
MrEen
Level 22
Level 22
Posts: 15236
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on Mint 20

Post by MrEen »

You're welcome.

I suspect that may have fixed the issue, but if not we'll try more things.

Good luck. :D
Agrippinus
Level 1
Level 1
Posts: 14
Joined: Sat Aug 03, 2019 3:04 pm

Re: No sound on Mint 20

Post by Agrippinus »

Hello MrEen,

The sound is working after each boot.

Thank you very much for solving my problem!

May I ask you what the issue was and where it came from?
Linux Mint 20 _ 64 bits - Cinnamon 4.6.7 - Kernel 5.4.0-48 - Laptop Entroware Athena
Agrippinus
Level 1
Level 1
Posts: 14
Joined: Sat Aug 03, 2019 3:04 pm

Re: No sound on Mint 20

Post by Agrippinus »

Here:

https://help.ubuntu.com/community/HdaIntelSoundHowto

I found this:
Playing with probe_mask

Another possible option is the 'probe_mask' parameter, which has been known to fix sound issues characterized by the occurrence of "azx_get_response timeout, switching to single_cmd mode" messages reported with 'dmesg'. Try either "probe_mask=1" or "probe_mask=8" by adding a line like:

options snd-hda-intel probe_mask=1

For detailed information about this problem, see More Notes on HD-Audio Driver by Takashi Iwai, section 2.2. "Codec-Probing Problem".
Actually the link provided is broken but I could find the page here:

https://www.kernel.org/doc/html/v4.18/s ... notes.html

But I'm afraid it's all chinese to me! :oops:

It says:
A less often but a more severe problem is the codec probing. When BIOS reports the available codec slots wrongly, the driver gets confused and tries to access the non-existing codec slot.
Why would the BIOS suddenly (when it worked before with the same laptop) "report the available codec slots wrongly?"

I'd just like to be a little less ignorant and a little more able to resolve problems. :)
Linux Mint 20 _ 64 bits - Cinnamon 4.6.7 - Kernel 5.4.0-48 - Laptop Entroware Athena
User avatar
MrEen
Level 22
Level 22
Posts: 15236
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on Mint 20

Post by MrEen »

This was the specific error that led me to suggest the probe_mask parameter:

Code: Select all

[   20.525456] snd_hda_intel 0000:00:1f.3: azx_get_response timeout, switching to single_cmd mode: last cmd=0x20270600
I got that info from here:
Codec-Probing Problem
A less often but a more severe problem is the codec probing. When BIOS reports the available codec slots wrongly, the driver gets confused and tries to access the non-existing codec slot. This often results in the total screw-up, and destructs the further communication with the codec chips. The symptom appears usually as error messages like:

hda_intel: azx_get_response timeout, switching to polling mode:
last cmd=0x12345678
hda_intel: azx_get_response timeout, switching to single_cmd mode:
last cmd=0x12345678
The first line is a warning, and this is usually relatively harmless. It means that the codec response isn’t notified via an IRQ. The driver uses explicit polling method to read the response. It gives very slight CPU overhead, but you’d unlikely notice it.

The second line is, however, a fatal error. If this happens, usually it means that something is really wrong. Most likely you are accessing a non-existing codec slot.

Thus, if the second error message appears, try to narrow the probed codec slots via probe_mask option. It’s a bitmask, and each bit corresponds to the codec slot. For example, to probe only the first slot, pass probe_mask=1. For the first and the third slots, pass probe_mask=5 (where 5 = 1 | 4), and so on.

Since 2.6.29 kernel, the driver has a more robust probing method, so this error might happen rarely, though.

On a machine with a broken BIOS, sometimes you need to force the driver to probe the codec slots the hardware doesn’t report for use. In such a case, turn the bit 8 (0x100) of probe_mask option on. Then the rest 8 bits are passed as the codec slots to probe unconditionally. For example, probe_mask=0x103 will force to probe the codec slots 0 and 1 no matter what the hardware reports.
This is a total guess on my part, but maybe previously the BIOS issue was still present, but the driver was guessing correctly. With your present system, it even did so occasionally, but not regularly.

With the change we've made, it shouldn't be an issue any more, until the next change of OS. Updating from Mint 20 to Mint 20.1 (and .2 and .3) shouldn't be an issue, but installing Mint 21 will require making the same change again.

And it looks like you're well on your way to learning more. Glad I could help, and enjoy. :D
Agrippinus
Level 1
Level 1
Posts: 14
Joined: Sat Aug 03, 2019 3:04 pm

Re: No sound on Mint 20

Post by Agrippinus »

Yes, this is a good thing to know: I have carefully recorded the issue and the solving command in my files.

Once more: thank you very much!
Last edited by Agrippinus on Fri Oct 09, 2020 4:26 am, edited 1 time in total.
Linux Mint 20 _ 64 bits - Cinnamon 4.6.7 - Kernel 5.4.0-48 - Laptop Entroware Athena
User avatar
MrEen
Level 22
Level 22
Posts: 15236
Joined: Mon Jun 12, 2017 8:39 pm

Re: [Solved] No sound on Mint 20

Post by MrEen »

You're most welcome. :D
Post Reply

Return to “Sound, Multimedia, & Codecs”