Crackling in BMAX laptop Y11 after installing Mint 20 (Cinnamon)

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
Julianiperus
Level 1
Level 1
Posts: 2
Joined: Wed Oct 07, 2020 10:37 am

Crackling in BMAX laptop Y11 after installing Mint 20 (Cinnamon)

Post by Julianiperus »

I have been unable to solve this problem: the internal speaker sounds like crackling when booting and starting videos. I have not been able to find the sound card model, but the laptop is a BMAX MaxBook Y11 11.6''. I downloaded the ISO image of Linux Mint 20 (Cinnamon) 64-bit last week, with no additional problem. Any idea? Thank you very much.
User avatar
MrEen
Level 22
Level 22
Posts: 16673
Joined: Mon Jun 12, 2017 8:39 pm

Re: Crackling in BMAX laptop Y11 after installing Mint 20 (Cinnamon)

Post by MrEen »

Hi Julianiperus, and welcome to the forum.

I'm thinking one or more of three things are causing this, so I'll post fixes in the order I believe you should try them. Reboot after each change and test the sound to see if the issue is gone:

1. The audio driver power saving feature is my first suspect. This will disable it:

Code: Select all

sudo tee /etc/modprobe.d/snd-hda-intel.conf <<<'options snd-hda-intel power_save=0'
2. Related to the first idea, this was successful for a user or two this past week with very similar issues. In the terminal run xed admin:///etc/pulse/default.pa and when the file opens find this section:

Code: Select all

### Automatically suspend sinks/sources that become idle for too long
load-module module-suspend-on-idle
Change it to this:

Code: Select all

### Automatically suspend sinks/sources that become idle for too long
# load-module module-suspend-on-idle
3. If neither of those helped, then most likely this one will:
If you're experiencing glitches, skips, pops or crackling in your audio playback, it's quite possibly caused by the timer-based scheduling pulseaudio now uses. Disable timer-based scheduling this way:
Users of 18.3 and earlier versions of Mint type this in the terminal: gksudo xed /etc/pulse/default.pa
Users of 19 and later versions of Mint type this in the terminal: xed admin:///etc/pulse/default.pa
Find the line that says load-module module-udev-detect and change it to load-module module-udev-detect tsched=0
Save the file, then run pulseaudio -k in the terminal and test your sound
Regardless of what might fix this, there's still the possibility you'll get the noise at bootup. But it should stop all noise thereafter. That's basically the amp turning on that is causing the noise.

Good luck.
Julianiperus
Level 1
Level 1
Posts: 2
Joined: Wed Oct 07, 2020 10:37 am

Re: Crackling in BMAX laptop Y11 after installing Mint 20 (Cinnamon)

Post by Julianiperus »

Thank you very much, MrEen, your very first solution solved the entire problem! Very interesting "sound tricks" indeed.
User avatar
MrEen
Level 22
Level 22
Posts: 16673
Joined: Mon Jun 12, 2017 8:39 pm

Re: Crackling in BMAX laptop Y11 after installing Mint 20 (Cinnamon)

Post by MrEen »

I'm glad that worked for you Julianiperus!

That used to be the default setting, but Ubuntu changed it around two years ago. Since then, this issue has come up quite a few times.

Enjoy. :D
Post Reply

Return to “Sound, Multimedia, & Codecs”