{SOLVED} Cannot mirror my laptop to my TV

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
Chrissy20
Level 1
Level 1
Posts: 4
Joined: Thu Oct 15, 2020 12:33 am

{SOLVED} Cannot mirror my laptop to my TV

Post by Chrissy20 »

{SOLVED}

Hi everyone.
I’m a reasonably new Linux user and new to the forums, currently using Mint 20 with a cinnamon desktop. [details below] I have searched high and low to find an answer to my problem but no go.
I am trying to get my laptop to mirror to my TV, but having great difficulties.
My TV is detected, but I can only see the desktop background, no cursor or icons.
I can get sound on the TV, but no mirrored image.
When I click on ‘mirror display’, and ‘apply’ the second green screen [the tv] disappears and the following error message pops up,

Failed to apply configuration.
GDBus.Error:org.cinnamon.SettingsDaemon.XRANDR_2
was not provided by any .service files

I truly hope someone can guide me as to what to do next.
Thanks in anticipation
Here are the details of my system:

Code: Select all

chris@chris-Inspiron-5567:~$ inxi -Fxxxz
System:
  Kernel: 5.4.0-51-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 
  Desktop: Cinnamon 4.6.7 info: cairo-dock wm: muffin 4.6.3 
  dm: LightDM 1.30.0 Distro: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal 
Machine:
  Type: Laptop System: Dell product: Inspiron 5567 v: N/A serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Dell model: 05VRRG v: A00 serial: <filter> UEFI: Dell v: 1.2.8 
  date: 05/22/2019 
Battery:
  ID-1: BAT0 charge: 1.5 Wh condition: 17.0/42.0 Wh (40%) volts: 11.9/11.4 
  model: Samsung SDI DELL C4HCW6B type: Li-ion serial: <filter> 
  status: Charging 
CPU:
  Topology: Dual Core model: Intel Core i7-7500U bits: 64 type: MT MCP 
  arch: Amber Lake rev: 9 L2 cache: 4096 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 23199 
  Speed: 1900 MHz min/max: 400/3500 MHz Core speeds (MHz): 1: 1900 2: 1900 
  3: 1900 4: 1893 
Graphics:
  Device-1: Intel HD Graphics 620 vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:5916 
  Display: x11 server: X.Org 1.20.8 driver: amdgpu,ati,modesetting 
  unloaded: fbdev,vesa resolution: 1920x1080~60Hz, 1920x1080~60Hz 
  OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.0.8 
  direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9d71 
  Sound Server: ALSA v: k5.4.0-51-generic 
Network:
  Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel port: f040 
  bus ID: 02:00.0 chip ID: 8086:3165 
  IF: wlp2s0 state: up mac: <filter> 
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell 
  driver: r8169 v: kernel port: d000 bus ID: 03:00.0 chip ID: 10ec:8136 
  IF: enp3s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 238.47 GiB used: 27.59 GiB (11.6%) 
  ID-1: /dev/sda vendor: Intel model: SSDSC2KF256H6 SATA 256GB 
  size: 238.47 GiB speed: 6.0 Gb/s serial: <filter> rev: D16N scheme: GPT 
Partition:
  ID-1: / size: 72.89 GiB used: 27.50 GiB (37.7%) fs: ext4 dev: /dev/sda7 
Sensors:
  System Temperatures: cpu: 46.0 C mobo: 31.0 C sodimm: 27.0 C gpu: amdgpu 
  temp: 25 C 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 235 Uptime: 4h 29m Memory: 7.68 GiB used: 1.77 GiB (23.0%) 
  Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 7/9 
  Shell: bash v: 5.0.17 running in: gnome-terminal inxi: 3.0.38
Last edited by Chrissy20 on Fri Oct 16, 2020 8:18 am, edited 3 times in total.
dorsetUK
Level 4
Level 4
Posts: 498
Joined: Thu Sep 19, 2019 4:40 am

Re: Cannot mirror my laptop to my TV

Post by dorsetUK »

Chrissy20 wrote:
Thu Oct 15, 2020 4:52 am
Hi everyone.
I’m a reasonably new Linux user and new to the forums, currently using Mint 20 with a cinnamon desktop. [details below] I have searched high and low to find an answer to my problem but no go.
I am trying to get my laptop to mirror to my TV, but having great difficulties.
My TV is detected, but I can only see the desktop background, no cursor or icons.
I can get sound on the TV, but no mirrored image.
When I click on ‘mirror display’, and ‘apply’ the second green screen [the tv] disappears and the following error message pops up,

Failed to apply configuration.
GDBus.Error:org.cinnamon.SettingsDaemon.XRANDR_2
was not provided by any .service files

I truly hope someone can guide me as to what to do next.
Thanks in anticipation
Here are the details of my system:

Code: Select all

chris@chris-Inspiron-5567:~$ inxi -Fxxxz
System:
  Kernel: 5.4.0-51-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 
  Desktop: Cinnamon 4.6.7 info: cairo-dock wm: muffin 4.6.3 
  dm: LightDM 1.30.0 Distro: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal 
Machine:
  Type: Laptop System: Dell product: Inspiron 5567 v: N/A serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Dell model: 05VRRG v: A00 serial: <filter> UEFI: Dell v: 1.2.8 
  date: 05/22/2019 
Battery:
  ID-1: BAT0 charge: 1.5 Wh condition: 17.0/42.0 Wh (40%) volts: 11.9/11.4 
  model: Samsung SDI DELL C4HCW6B type: Li-ion serial: <filter> 
  status: Charging 
CPU:
  Topology: Dual Core model: Intel Core i7-7500U bits: 64 type: MT MCP 
  arch: Amber Lake rev: 9 L2 cache: 4096 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 23199 
  Speed: 1900 MHz min/max: 400/3500 MHz Core speeds (MHz): 1: 1900 2: 1900 
  3: 1900 4: 1893 
Graphics:
  Device-1: Intel HD Graphics 620 vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:5916 
  Display: x11 server: X.Org 1.20.8 driver: amdgpu,ati,modesetting 
  unloaded: fbdev,vesa resolution: 1920x1080~60Hz, 1920x1080~60Hz 
  OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.0.8 
  direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9d71 
  Sound Server: ALSA v: k5.4.0-51-generic 
Network:
  Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel port: f040 
  bus ID: 02:00.0 chip ID: 8086:3165 
  IF: wlp2s0 state: up mac: <filter> 
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell 
  driver: r8169 v: kernel port: d000 bus ID: 03:00.0 chip ID: 10ec:8136 
  IF: enp3s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 238.47 GiB used: 27.59 GiB (11.6%) 
  ID-1: /dev/sda vendor: Intel model: SSDSC2KF256H6 SATA 256GB 
  size: 238.47 GiB speed: 6.0 Gb/s serial: <filter> rev: D16N scheme: GPT 
Partition:
  ID-1: / size: 72.89 GiB used: 27.50 GiB (37.7%) fs: ext4 dev: /dev/sda7 
Sensors:
  System Temperatures: cpu: 46.0 C mobo: 31.0 C sodimm: 27.0 C gpu: amdgpu 
  temp: 25 C 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 235 Uptime: 4h 29m Memory: 7.68 GiB used: 1.77 GiB (23.0%) 
  Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 7/9 
  Shell: bash v: 5.0.17 running in: gnome-terminal inxi: 3.0.38
Hi Chrissy20 and welcome to the forum.

Can you check that "Cinnamon Settings Daemon xrandr" is enabled in Startup Applications, and if nor enable it then log out, then in, and try again please.

viewtopic.php?t=282412
Chrissy20
Level 1
Level 1
Posts: 4
Joined: Thu Oct 15, 2020 12:33 am

Re: Cannot mirror my laptop to my TV

Post by Chrissy20 »

<SOLVED>

Thank you for your reply dorsetUK , I so appreciate your help.
Daemon xrandr was indeed disabled, so I enabled it and all's well.
I had to fiddle with the 'display' settings a little, and had to switch the sound to the HDMI output, but all's good now.
I had been trying to fix this for weeks without success. I'm so pleased I don't have to switch back to Windows in order to play.

Thank to everyone for your suggestions. Much appreciated.
Have a wonderful day. It's nice and sunny here in Aus. I'm happy. Blessings :)
PS. Not sure where to mark it as solved. For now I've added it to my reply post.
RIH
Level 5
Level 5
Posts: 820
Joined: Sat Aug 22, 2015 3:47 am

Re: Cannot mirror my laptop to my TV

Post by RIH »

Chrissy20 wrote:
Thu Oct 15, 2020 8:43 pm
PS. Not sure where to mark it as solved. For now I've added it to my reply post.
Go to your first post. Click on the pencil (Edit) icon
Edit.png
Edit.png (3.13 KiB) Viewed 137 times
Add the word {Solved} to the start or finish of your original post title.

That is then seen by anyone searching the Forum with a similar issue..

p.s. Glad you got it solved, but, really
I had been trying to fix this for weeks without success
tut. tut - I hope you have learnt your lesson on what a quick post on the Forum can do for frustrations.. :D :D
Chrissy20
Level 1
Level 1
Posts: 4
Joined: Thu Oct 15, 2020 12:33 am

Re: Cannot mirror my laptop to my TV

Post by Chrissy20 »

Taken note, thank you. 😯
Post Reply

Return to “Sound, Multimedia, & Codecs”