I've got sound issues...

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
IceyGuide
Level 1
Level 1
Posts: 21
Joined: Sat Oct 24, 2020 11:57 pm

I've got sound issues...

Post by IceyGuide »

So, yesterday I downloaded Linux mint as a Newbie. There was nothing to complain about really. As I started playing some sort of audio or watch videos there was a crackling noise coming out my Headset speakers. Note that I'm not on a Laptop, pulseaudio -k did not fix it nor did anything related to power saving fix it. I've tried so many things but none worked, even reinstalled it again.
Version: Linux mint 20 "Ulayana"
I've noticed that my built-in Audio is doing some weird stuff in pavucontrol I tried to disable it, but it turned back on. Even pavucontrol is Establishing connection to pulseaudio every now and again....
I'm out of Ideas at that point
Last edited by MrEen on Sun Oct 25, 2020 1:40 pm, edited 1 time in total.
Reason: Moved from Chat section to Support section.
User avatar
MrEen
Level 22
Level 22
Posts: 15236
Joined: Mon Jun 12, 2017 8:39 pm

Re: I've got sound issues...

Post by MrEen »

Hi IceyGuide, and welcome to the forum.

Try this:
If you're experiencing glitches, skips, pops or crackling in your audio playback, it's quite possibly caused by the timer-based scheduling pulseaudio now uses. Disable timer-based scheduling this way:
Users of 18.3 and earlier versions of Mint type this in the terminal: gksudo xed /etc/pulse/default.pa
Users of 19 and later versions of Mint type this in the terminal: xed admin:///etc/pulse/default.pa
Find the line that says load-module module-udev-detect and change it to load-module module-udev-detect tsched=0
Save the file, then run pulseaudio -k in the terminal and test your sound
For the Establishing connection part, when that's happening run this and post the output:

Code: Select all

sudo fuser -v /dev/snd/*
IceyGuide
Level 1
Level 1
Posts: 21
Joined: Sat Oct 24, 2020 11:57 pm

Re: I've got sound issues...

Post by IceyGuide »

Thanks for your lovely response MrEen, I already tried the tsched=0 method that did not work for me... Any other ideas. Thanks in regards.
User avatar
MrEen
Level 22
Level 22
Posts: 15236
Joined: Mon Jun 12, 2017 8:39 pm

Re: I've got sound issues...

Post by MrEen »

Let's get a look at your full sound setup with this command:

Code: Select all

curl https://gitlab.freedesktop.org/pulseaudio/pulseaudio/raw/master/src/utils/pa-info?inline=false | bash | nc termbin.com 9999
The last line of output will have a URL pointing to the info.
IceyGuide
Level 1
Level 1
Posts: 21
Joined: Sat Oct 24, 2020 11:57 pm

Re: I've got sound issues...

Post by IceyGuide »

should I post the whole stuff in here?
User avatar
MrEen
Level 22
Level 22
Posts: 15236
Joined: Mon Jun 12, 2017 8:39 pm

Re: I've got sound issues...

Post by MrEen »

IceyGuide wrote:
Sun Oct 25, 2020 5:45 pm
should I post the whole stuff in here?
Just the URL is fine. If you're concerned about any of the info, you can send it to me in a PM if you wish.
IceyGuide
Level 1
Level 1
Posts: 21
Joined: Sat Oct 24, 2020 11:57 pm

Re: I've got sound issues...

Post by IceyGuide »

It's fine here you go
https://termbin.com/y71vk
User avatar
MrEen
Level 22
Level 22
Posts: 15236
Joined: Mon Jun 12, 2017 8:39 pm

Re: I've got sound issues...

Post by MrEen »

Is the "Razer Electra V2 USB" your headset? If so, we can see if changing the profile to Digital improves things. That can be done on the Configuration tab of pavucontrol, or in the terminal with this command:

Code: Select all

pacmd set-card-profile alsa_card.usb-Razer_Razer_Electra_V2_USB_AC1929D06801102-00 output:iec958-stereo
I'm still looking to see if there are other things that might help.
IceyGuide
Level 1
Level 1
Posts: 21
Joined: Sat Oct 24, 2020 11:57 pm

Re: I've got sound issues...

Post by IceyGuide »

It sadly did not fix it, and yea the Razer Electra is my Headset.
User avatar
MrEen
Level 22
Level 22
Posts: 15236
Joined: Mon Jun 12, 2017 8:39 pm

Re: I've got sound issues...

Post by MrEen »

Okay, I didn't see anything else unusual in the output.

Install (if necessary) and run PulseAudio Volume Control (pavucontrol) and on the Configuration tab set the other audio devices to Off to see if one of them is causing this issue.

If no luck with that, try deleting the files in /home/YourUserName/.config/pulse then running pulseaudio -k in the terminal clears this up.
User avatar
MrEen
Level 22
Level 22
Posts: 15236
Joined: Mon Jun 12, 2017 8:39 pm

Re: I've got sound issues...

Post by MrEen »

And if you're still have issues, try altering the sample rates. In the terminal run xed admin:///etc/pulse/daemon.conf and when the file opens find this section:

Code: Select all

; default-sample-rate = 44100
; alternate-sample-rate = 48000
Try both of these changes:

Code: Select all

default-sample-rate = 44100
alternate-sample-rate = 44100

Code: Select all

default-sample-rate = 48000
alternate-sample-rate = 48000
Reboot after each change and test the sound. Notice the beginning of each line was changed as well as the number.
IceyGuide
Level 1
Level 1
Posts: 21
Joined: Sat Oct 24, 2020 11:57 pm

Re: I've got sound issues...

Post by IceyGuide »

Thanks again for your ideas, as mentioned earlier the built-in audio is doing some "weird" stuff... I can't turn it off either.
User avatar
MrEen
Level 22
Level 22
Posts: 15236
Joined: Mon Jun 12, 2017 8:39 pm

Re: I've got sound issues...

Post by MrEen »

We can try the drastic method:

Code: Select all

sudo modprobe -r snd-hda-intel
That will unload the driver your built-in card and the HDMI card uses.
IceyGuide
Level 1
Level 1
Posts: 21
Joined: Sat Oct 24, 2020 11:57 pm

Re: I've got sound issues...

Post by IceyGuide »

It says the following :

libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse: /etc/modprobe.d/alsa-base.conf line 44: ignoring bad line starting with 'xed'
modprobe: FATAL: Module snd_hda_intel is in use.
User avatar
MrEen
Level 22
Level 22
Posts: 15236
Joined: Mon Jun 12, 2017 8:39 pm

Re: I've got sound issues...

Post by MrEen »

Well that's a weird looking error. Let's see the output of cat /etc/modprobe.d/alsa-base.conf
IceyGuide
Level 1
Level 1
Posts: 21
Joined: Sat Oct 24, 2020 11:57 pm

Re: I've got sound issues...

Post by IceyGuide »

And there it goes :

Code: Select all

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
xed admin:///etc/modprobe.d/alsa-base.conf
Last edited by MrEen on Sun Oct 25, 2020 7:05 pm, edited 1 time in total.
Reason: Added code tags to preserve formatting.
User avatar
MrEen
Level 22
Level 22
Posts: 15236
Joined: Mon Jun 12, 2017 8:39 pm

Re: I've got sound issues...

Post by MrEen »

Okay, either manually remove the last line in that file, or use this command once only to do it:

Code: Select all

sudo sed -i '$ d' /etc/modprobe.d/alsa-base.conf
Reboot after that and see where things stand.
IceyGuide
Level 1
Level 1
Posts: 21
Joined: Sat Oct 24, 2020 11:57 pm

Re: I've got sound issues...

Post by IceyGuide »

Nothing changed still the same problem as before....
So notice that there's a static / crackling noise while entering the login screen + logging in (on the login sound), and while playing back videos and/or playing games with audio
User avatar
MrEen
Level 22
Level 22
Posts: 15236
Joined: Mon Jun 12, 2017 8:39 pm

Re: I've got sound issues...

Post by MrEen »

Did you try the sample rate changes?
IceyGuide
Level 1
Level 1
Posts: 21
Joined: Sat Oct 24, 2020 11:57 pm

Re: I've got sound issues...

Post by IceyGuide »

Yea, both of them increased it!

NOTE : I didn't have that static / crackling noise in Windows 10
Post Reply

Return to “Sound, Multimedia, & Codecs”