<solved> - LM 20 Linux 5.4.0-52-generic - No sound (works on Windows)

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
esogas
Level 1
Level 1
Posts: 7
Joined: Sun Aug 09, 2020 1:20 pm

<solved> - LM 20 Linux 5.4.0-52-generic - No sound (works on Windows)

Post by esogas »

I have a dual boot system, sound works on Windows, doesn't work on LInux. Sound port that doesn't work is motherboard line out. How can I enable this?

Output of:

Code: Select all

curl https://gitlab.freedesktop.org/pulseaudio/pulseaudio/raw/master/src/utils/pa-info?inline=false | bash | nc termbin.com 9999
at: https://termbin.com/15e88

Setting the card manually used to work:

Code: Select all

pacmd set-card-profile alsa_card.pci-0000_00_1f.3 output:analog-stereo+input:analog-stereo
But doesn't any longer:

Code: Select all

No card found by this name or index.
pavucontrol only sees "dummy output" as the output device, and setting to "hardware output device" shows no devices.
Configuration tab only see HDA Nvidia and HD Pro Webcam 920

Code: Select all

family@kitchen ~ $ pactl list sinks
Sink #0
	State: IDLE
	Name: auto_null
	Description: Dummy Output
	Driver: module-null-sink.c
	Sample Specification: s16le 2ch 44100Hz
	Channel Map: front-left,front-right
	Owner Module: 13
	Mute: no
	Volume: front-left: 60766 /  93% / -1.97 dB,   front-right: 60766 /  93% / -1.97 dB
	        balance 0.00
	Base Volume: 65536 / 100% / 0.00 dB
	Monitor Source: auto_null.monitor
	Latency: 17615 usec, configured 40000 usec
	Flags: DECIBEL_VOLUME LATENCY SET_FORMATS 
	Properties:
		device.description = "Dummy Output"
		device.class = "abstract"
		device.icon_name = "audio-card"
	Formats:
		pcm
At boot, the system sees these 3 devices, what I want is Device-1 to show up (I think).

Code: Select all

family@kitchen ~ $ inxi -SMA

System:    Host: kitchen Kernel: 5.4.0-52-generic x86_64 bits: 64 Desktop: Cinnamon 4.6.7 Distro: Linux Mint 20 Ulyana 
Machine:   Type: Desktop Mobo: ASUSTeK model: Z170I PRO GAMING v: Rev X.0x serial: <superuser/root required> 
                  UEFI: American Megatrends v: 3805 date: 05/16/2018 
Audio:     
           Device-1: Intel 100 Series/C230 Series Family HD Audio driver: snd_hda_intel 
           Device-2: NVIDIA driver: snd_hda_intel 
           Device-3: Logitech HD Pro Webcam C920 type: USB driver: snd-usb-audio,uvcvideo 
           Sound Server: ALSA v: k5.4.0-52-generic 

Code: Select all

family@kitchen ~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC1150 Analog [ALC1150 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC1150 Digital [ALC1150 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 11: HDMI 5 [HDMI 5]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
But pacmd doesn't seem to have the card

Code: Select all

family@kitchen ~ $ pacmd list-cards
2 card(s) available.
    index: 0
	name: <alsa_card.pci-0000_01_00.1>
	driver: <module-alsa-card.c>
	owner module: 7
	properties:
		alsa.card = "2"
		alsa.card_name = "HDA NVidia"
		alsa.long_card_name = "HDA NVidia at 0xf7080000 irq 17"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:01:00.1"
		sysfs.path = "/devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card2"
		device.bus = "pci"
		device.vendor.id = "10de"
		device.vendor.name = "NVIDIA Corporation"
		device.product.id = "10fa"
		device.string = "2"
		device.description = "HDA NVidia"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	profiles:
		output:hdmi-stereo: Digital Stereo (HDMI) Output (priority 5900, available: no)
		output:hdmi-surround: Digital Surround 5.1 (HDMI) Output (priority 800, available: no)
		output:hdmi-surround71: Digital Surround 7.1 (HDMI) Output (priority 800, available: no)
		output:hdmi-stereo-extra1: Digital Stereo (HDMI 2) Output (priority 5700, available: no)
		output:hdmi-surround-extra1: Digital Surround 5.1 (HDMI 2) Output (priority 600, available: no)
		output:hdmi-surround71-extra1: Digital Surround 7.1 (HDMI 2) Output (priority 600, available: no)
		output:hdmi-stereo-extra2: Digital Stereo (HDMI 3) Output (priority 5700, available: no)
		output:hdmi-surround-extra2: Digital Surround 5.1 (HDMI 3) Output (priority 600, available: no)
		output:hdmi-surround71-extra2: Digital Surround 7.1 (HDMI 3) Output (priority 600, available: no)
		output:hdmi-stereo-extra3: Digital Stereo (HDMI 4) Output (priority 5700, available: no)
		output:hdmi-surround-extra3: Digital Surround 5.1 (HDMI 4) Output (priority 600, available: no)
		output:hdmi-surround71-extra3: Digital Surround 7.1 (HDMI 4) Output (priority 600, available: no)
		output:hdmi-stereo-extra4: Digital Stereo (HDMI 5) Output (priority 5700, available: no)
		output:hdmi-surround-extra4: Digital Surround 5.1 (HDMI 5) Output (priority 600, available: no)
		output:hdmi-surround71-extra4: Digital Surround 7.1 (HDMI 5) Output (priority 600, available: no)
		output:hdmi-stereo-extra5: Digital Stereo (HDMI 6) Output (priority 5700, available: no)
		output:hdmi-surround-extra5: Digital Surround 5.1 (HDMI 6) Output (priority 600, available: no)
		output:hdmi-surround71-extra5: Digital Surround 7.1 (HDMI 6) Output (priority 600, available: no)
		off: Off (priority 0, available: unknown)
	active profile: <off>
	ports:
		hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-2: HDMI / DisplayPort 3 (priority 5700, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-3: HDMI / DisplayPort 4 (priority 5600, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-4: HDMI / DisplayPort 5 (priority 5500, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-5: HDMI / DisplayPort 6 (priority 5400, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
    index: 1
	name: <alsa_card.usb-046d_HD_Pro_Webcam_C920_B62B20BF-02>
	driver: <module-alsa-card.c>
	owner module: 8
	properties:
		alsa.card = "1"
		alsa.card_name = "HD Pro Webcam C920"
		alsa.long_card_name = "HD Pro Webcam C920 at usb-0000:00:14.0-9, high speed"
		alsa.driver_name = "snd_usb_audio"
		device.bus_path = "pci-0000:00:14.0-usb-0:9:1.2"
		sysfs.path = "/devices/pci0000:00/0000:00:14.0/usb1/1-9/1-9:1.2/sound/card1"
		udev.id = "usb-046d_HD_Pro_Webcam_C920_B62B20BF-02"
		device.bus = "usb"
		device.vendor.id = "046d"
		device.vendor.name = "Logitech, Inc."
		device.product.id = "082d"
		device.product.name = "HD Pro Webcam C920"
		device.serial = "046d_HD_Pro_Webcam_C920_B62B20BF"
		device.form_factor = "webcam"
		device.string = "1"
		device.description = "HD Pro Webcam C920"
		module-udev-detect.discovered = "1"
		device.icon_name = "camera-web-usb"
	profiles:
		input:analog-stereo: Analog Stereo Input (priority 65, available: unknown)
		input:iec958-stereo: Digital Stereo (IEC958) Input (priority 55, available: unknown)
		off: Off (priority 0, available: unknown)
	active profile: <input:analog-stereo>
	sources:
		alsa_input.usb-046d_HD_Pro_Webcam_C920_B62B20BF-02.analog-stereo/#0: HD Pro Webcam C920 Analog Stereo
	ports:
		analog-input-mic: Microphone (priority 8700, latency offset 0 usec, available: unknown)
			properties:
				device.icon_name = "audio-input-microphone"
		iec958-stereo-input: Digital Input (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)
			properties:
Any help would be greatly appreciated!
Last edited by esogas on Sun Nov 08, 2020 12:36 pm, edited 2 times in total.
User avatar
MrEen
Level 22
Level 22
Posts: 15285
Joined: Mon Jun 12, 2017 8:39 pm

Re: LM 20 Linux 5.4.0-52-generic - No sound (works on Windows)

Post by MrEen »

Hi esogas,

You made a change, presumably to /etc/modprobe.d/alsa-base.conf, that added options snd-hda-intel model=dual-codecs

I would suggest removing that for starters.

Also, boot to Windows and ensure Fast Startup is off, then shut down, don't reboot. Wait 2 minutes, then boot up into Mint.

Your built-in sound card isn't getting detected properly, and the above may resolve this.
esogas
Level 1
Level 1
Posts: 7
Joined: Sun Aug 09, 2020 1:20 pm

Re: LM 20 Linux 5.4.0-52-generic - No sound (works on Windows)

Post by esogas »

Thank you! I must have added an "msi-fix.conf" that had this in there, I removed that file and now the devices are showing up.

updated with new results (much better)!
https://termbin.com/686e

The bad config was in this msi-fix.conf file in the modprode.d directory, I removed it...

Code: Select all

family@kitchen ~ $ cd /etc/modprobe.d/
family@kitchen /etc/modprobe.d $ !grep
grep codec *
msi-fix.conf:options snd-hda-intel model=dual-codecs
family@kitchen ~ $ rm msi-fix.conf
I can see the devices now in pulse audio! I still don't have sound (yet), but I think that is probably something simple on my side, I'll try the Windows suggestion after I work on this a bit more, but I feel like this is close now. Thanks you!
User avatar
MrEen
Level 22
Level 22
Posts: 15285
Joined: Mon Jun 12, 2017 8:39 pm

Re: LM 20 Linux 5.4.0-52-generic - No sound (works on Windows)

Post by MrEen »

You're welcome.

I'll bet your audio is just playing to the wrong device now. The running pacmd list-sinks while sound is trying to play should show you where it's playing to.

It's also possible the card has the wrong profile (off or input only) that can be fixed with pavucontrol.
esogas
Level 1
Level 1
Posts: 7
Joined: Sun Aug 09, 2020 1:20 pm

Re: LM 20 Linux 5.4.0-52-generic - No sound (works on Windows)

Post by esogas »

I haven't got it quite yet - although I "think" I have the sink and the profile set correctly. I tried setting each profile in the pulseaudio volume control UI - but something must be off still.

Output Device: (Line out: (plugged in)
Configuration: Analog Stereo Output (but I tried all the possible options)

Also from command line:

Code: Select all

family@kitchen ~ $ pacmd set-card-profile alsa_card.pci-0000_00_1f.3 output:analog-stereo+input:analog-stereo

Code: Select all

family@kitchen ~ $ pacmd list-sinks
1 sink(s) available.
  * index: 22
	name: <alsa_output.pci-0000_00_1f.3.analog-stereo>
	driver: <module-alsa-card.c>
	flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: RUNNING
	suspend cause: (none)
	priority: 9039
	volume: front-left: 55680 /  85% / -4.25 dB,   front-right: 55680 /  85% / -4.25 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 23.88 ms
	max request: 4 KiB
	max rewind: 4 KiB
	monitor source: 27
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 1
	linked by: 3
	configured latency: 23.22 ms; range is 0.50 .. 371.52 ms
	card: 2 <alsa_card.pci-0000_00_1f.3>
	module: 9
	properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "ALC1150 Analog"
		alsa.id = "ALC1150 Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xf7540000 irq 139"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1f.3"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "a170"
		device.product.name = "100 Series/C230 Series Chipset Family HD Audio Controller"
		device.form_factor = "internal"
		device.string = "front:0"
		device.buffering.buffer_size = "65536"
		device.buffering.fragment_size = "32768"
		device.access_mode = "mmap+timer"
		device.profile.name = "analog-stereo"
		device.profile.description = "Analog Stereo"
		device.description = "Built-in Audio Analog Stereo"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	ports:
		analog-output-lineout: Line Out (priority 9000, latency offset 0 usec, available: yes)
			properties:
				
		analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: yes)
			properties:
				device.icon_name = "audio-headphones"
	active port: <analog-output-lineout>

Code: Select all

family@kitchen ~ $ pacmd list-cards | grep 'active profile'
	active profile: <off>
	active profile: <input:analog-stereo>
	active profile: <output:analog-stereo>
User avatar
MrEen
Level 22
Level 22
Posts: 15285
Joined: Mon Jun 12, 2017 8:39 pm

Re: LM 20 Linux 5.4.0-52-generic - No sound (works on Windows)

Post by MrEen »

The system is detecting headphones plugged in, so it will always default to that. If headphones are actually plugged in, this should change your output:

Code: Select all

pacmd set-sink-port alsa_output.pci-0000_00_1f.3.analog-stereo analog-output-lineout
Presently playing audio won't switch over automatically, but newly started audio should go through the line out port.

If headphones are not plugged in, then we need to do some investigating.

Let me know either way.

EDIT: You might need to also run alsamixer in the terminal. There's a good chance the headphones being detected will mute the Line Out port there. If you're not sure what needs changing there, post the output of amixer please.
esogas
Level 1
Level 1
Posts: 7
Joined: Sun Aug 09, 2020 1:20 pm

Re: LM 20 Linux 5.4.0-52-generic - No sound (works on Windows)

Post by esogas »

Right, no head phones plugged in, but it does think they are on, but running:

Code: Select all

pacmd set-sink-port alsa_output.pci-0000_00_1f.3.analog-stereo analog-output-lineout
doesn't send the volume to onboard stereo output.

One thing I think may be affecting this is the graphics card GeForce GTX 1650 (GPU 0) - with nvidia driver 450.80.02. It "may" have been around the time I put the graphics card in that I started to have problems with the build in sound, I haven't tried taking it out yet to see if that affects this. I have noticed I can get sound over HDMI from the graphics card - but since my monitor doesn't have sound (output to TV does) - I don't usually output sound over HDMI.

I did try and run alsamixer from the command line, I've never looked at that, but I did get it to work as follows:

1. I turned up the line-out volume
2. I tabbed over to the Auto-Mute tab and 'disabled' it, and that worked!

This was really good advice - I really appreciate you pointing me this direction - I don't yet understand the role Alsa has in sound, but this gives me something to dig into
, thank you so much!


Before

Code: Select all

family@kitchen ~ $ amixer
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 81 [93%] [-4.50dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 0 [0%] [-65.25dB] [off]
  Front Right: Playback 0 [0%] [-65.25dB] [off]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Front',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 87 [100%] [0.00dB] [on]
  Front Right: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'Front Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Front Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'Surround',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 87 [100%] [0.00dB] [on]
  Front Right: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'Center',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'LFE',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'Line',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Line Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'IEC958 Default PCM',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Beep',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 63
  Front Left: Capture 39 [62%] [12.00dB] [on]
  Front Right: Capture 39 [62%] [12.00dB] [on]
Simple mixer control 'Capture',1
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 63
  Front Left: Capture 0 [0%] [-17.25dB] [off]
  Front Right: Capture 0 [0%] [-17.25dB] [off]
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Enabled'
Simple mixer control 'Input Source',0
  Capabilities: cenum
  Items: 'Front Mic' 'Rear Mic' 'Line'
  Item0: 'Front Mic'
Simple mixer control 'Input Source',1
  Capabilities: cenum
  Items: 'Front Mic' 'Rear Mic' 'Line'
  Item0: 'Front Mic'
Simple mixer control 'Loopback Mixing',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Disabled'
Simple mixer control 'Rear Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Rear Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Last edited by esogas on Sun Nov 08, 2020 12:41 pm, edited 1 time in total.
User avatar
MrEen
Level 22
Level 22
Posts: 15285
Joined: Mon Jun 12, 2017 8:39 pm

Re: LM 20 Linux 5.4.0-52-generic - No sound (works on Windows)

Post by MrEen »

It sound like either your jack detection is reversed, or just faulty. If you want to troubleshoot that, install alsa-tools then run this command with headphones plugged in and again with them unplugged:

Code: Select all

hdajacksensetest -a
You'll understand the output. If you get Yes and Yes for headphones, then the sensing device in the headphone port is faulty/stuck. Could just be a piece of crud in there.

ALSA (Advanced Linux Sound Architecture) is the base audio layer in Linux. Everything else sits on top of that and sends it's stuff through ALSA. This includes PulseAudio, JACK and soon we'll have PipeWire. PulseAudio is what most distributions of Linux use as the "user interface" for lack of a better expression.
esogas
Level 1
Level 1
Posts: 7
Joined: Sun Aug 09, 2020 1:20 pm

Re: <solved> - LM 20 Linux 5.4.0-52-generic - No sound (works on Windows)

Post by esogas »

Yeah, headphone jack is likely faulty - I can remove the module from the case (some other time)

The alsamixer fix of disabling auto-mute continues to work, I've marked this topic as solved, and thank you!

w/out jack plugged in

Code: Select all

family@kitchen ~ $ sudo hdajacksensetest -a
Pin 0x11 (Internal SPDIF Out, ATAPI): present = No
Pin 0x14 (Green Line Out, Rear side): present = Yes
Pin 0x15 (Black Line Out, Rear side): present = No
Pin 0x16 (Orange Line Out, Rear side): present = No
Pin 0x17 (Not connected): present = No
Pin 0x18 (Pink Mic, Rear side): present = No
Pin 0x19 (Pink Mic, Front side): present = No
Pin 0x1a (Blue Line In, Rear side): present = No
Pin 0x1b (Green Headphone, Front side): present = Yes
Pin 0x1e (Orange SPDIF Out, Rear side): present = No
with jack plugged in
(note disregard green line out not present, I just moved the jack from the back to the front Headphone jack)

Code: Select all

Pin 0x11 (Internal SPDIF Out, ATAPI): present = No
Pin 0x14 (Green Line Out, Rear side): present = No
Pin 0x15 (Black Line Out, Rear side): present = No
Pin 0x16 (Orange Line Out, Rear side): present = No
Pin 0x17 (Not connected): present = No
Pin 0x18 (Pink Mic, Rear side): present = No
Pin 0x19 (Pink Mic, Front side): present = No
Pin 0x1a (Blue Line In, Rear side): present = No
Pin 0x1b (Green Headphone, Front side): present = Yes
Pin 0x1e (Orange SPDIF Out, Rear side): present = No
User avatar
MrEen
Level 22
Level 22
Posts: 15285
Joined: Mon Jun 12, 2017 8:39 pm

Re: <solved> - LM 20 Linux 5.4.0-52-generic - No sound (works on Windows)

Post by MrEen »

Yup! There's the culprit!

With the system always detecting headphones plugged in, it defaults to that. One upside to your workaround is if you do plug in headphones down the road, they'll work right away, although you'll probably want to then mute the line out, or reset the Auto-Mute Mode.

A little blast of air into the headphone port might be enough to clear it. Or it could take a few insertions/removals of a jack to do the same.

Another option if you never use headphones is we can disable the headphone pin completely, so the system doesn't even know it's there. That's done with a tool called HDAJackRetask that is part of the alsa-tools-gui package. If you want help trying that, just say so.

Personally, I'd stick with what you've done.

I'm glad we got this figured out. :D
User avatar
MartyMint
Level 7
Level 7
Posts: 1613
Joined: Thu Dec 27, 2012 10:50 pm

Re: <solved> - LM 20 Linux 5.4.0-52-generic - No sound (works on Windows)

Post by MartyMint »

An inexpensive USB sound card from eBay or wherever could be a fix as well.
Less that $10 U.S. and Linux compatibility is usually quite good.
Post Reply

Return to “Sound, Multimedia, & Codecs”