Sound problems in Linux Mint Ulyana.

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
XRhetorical
Level 1
Level 1
Posts: 23
Joined: Thu Sep 24, 2020 4:12 pm

Sound problems in Linux Mint Ulyana.

Post by XRhetorical »

Hi, I am fairly new to Linux, so please don't judge if I am missing very simple information. I have installed Linux Mint Cinamon Ulyana 64 bit on my 128GB SSD, and I am noticing that whenever I play any form of audio, there is this horrible static noise that plays almost as loud as the actual audio that's playing. I had this problem before on my previous installation of Linux Mint on my HDD, but I could just unplug and replug my headphones and it stops, but I had re-installed Linux Mint on my SSD, and now that is not the case. I know it isn't a hardware problem, as when I go into my Windows VM, the sound is totally fine. I have been at this for a few hours now and nothing is working. I have tried using alsamixer in the terminal and pavucontrol, neither have worked. I suspect it's an audio driver thing, but all I see online is how to fix no sound.
Hoser Rob
Level 16
Level 16
Posts: 6824
Joined: Sat Dec 15, 2012 8:57 am

Re: Sound problems in Linux Mint Ulyana.

Post by Hoser Rob »

I don't know if I can fix this but anyopne who can will need some useful info, paste the text output of inxi -Fxz run in the terminal.

It's a good idea for beginners to read the how to get help section here: viewtopic.php?f=17&t=83444
User avatar
MrEen
Level 22
Level 22
Posts: 15169
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound problems in Linux Mint Ulyana.

Post by MrEen »

XRhetorical wrote:
Thu Oct 29, 2020 10:56 pm
I suspect it's an audio driver thing, but all I see online is how to fix no sound.
Oh yeah? You haven't clicked on the link in my signature yet, have you? :lol:

All kidding aside, welcome to the forum, and do check my link. Points 1 and/or 2 under Bad Sound Fix Tips might very well solve this.
XRhetorical
Level 1
Level 1
Posts: 23
Joined: Thu Sep 24, 2020 4:12 pm

Re: Re: Sound problems in Linux Mint Ulyana.

Post by XRhetorical »

I had tried doing the 1st and second points under the second topic, and even the second one in the first topic. It has worked to some extent, as there is very little static, but there is still just a little bit there. One thing I am noticing though is that in alsamixer, I'm not seeing loopback under controls.
User avatar
MrEen
Level 22
Level 22
Posts: 15169
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound problems in Linux Mint Ulyana.

Post by MrEen »

No worries. It's not there for everyone. Let's see if power management might be a cause as well. Run this then reboot and test:

Code: Select all

sudo tee /etc/modprobe.d/snd-hda-intel.conf <<<'options snd-hda-intel power_save=0'
XRhetorical
Level 1
Level 1
Posts: 23
Joined: Thu Sep 24, 2020 4:12 pm

Re: Sound problems in Linux Mint Ulyana.

Post by XRhetorical »

I tried that, and it worked for when the volume was below 50, but over 50 it started making the static noise again.
User avatar
MrEen
Level 22
Level 22
Posts: 15169
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound problems in Linux Mint Ulyana.

Post by MrEen »

Okay, let's get a look at your sound setup with this command:

Code: Select all

curl https://gitlab.freedesktop.org/pulseaudio/pulseaudio/raw/master/src/utils/pa-info?inline=false | bash | nc termbin.com 9999
The last line of output will have a URL pointing to the info.
XRhetorical
Level 1
Level 1
Posts: 23
Joined: Thu Sep 24, 2020 4:12 pm

Re: Sound problems in Linux Mint Ulyana.

Post by XRhetorical »

User avatar
MrEen
Level 22
Level 22
Posts: 15169
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound problems in Linux Mint Ulyana.

Post by MrEen »

Okay, right at the top probably indicates the source of your troubles:

Code: Select all

> pulseaudio_ps_do
root        1387  0.0  0.0   4500   736 ?        Ss   14:16   0:00 /bin/sh /snap/pulseaudio/9/bin/pulseaudio
root        1693  0.0  0.1 388568  9248 ?        S<l  14:16   0:00 /snap/pulseaudio/9/usr/bin/pulseaudio --exit-idle-time=-1 --disallow-exit=yes --system -F /snap/pulseaudio/9/etc/pulse/default.pa -p /snap/pulseaudio/9/usr/lib/pulse-8.0/modules -n
kristop+    2003  0.4  0.2 2194772 16076 ?       S<sl 14:16   0:13 /usr/bin/pulseaudio --daemonize=no --log-target=journal
kristop+    6729  0.0  0.0   3304   728 pts/0    S+   15:04   0:00 grep pulseaudio
Root should not be involved here, and snap shouldn't be either.

Let's see the output of snap list so we can make sure of what needs to be removed.
XRhetorical
Level 1
Level 1
Posts: 23
Joined: Thu Sep 24, 2020 4:12 pm

Re: Sound problems in Linux Mint Ulyana.

Post by XRhetorical »

Code: Select all

Name        Version    Rev    Tracking       Publisher   Notes
alsa-utils  1.1.2-5    68     latest/stable  canonical✓  -
core        16-2.47.1  10185  latest/stable  canonical✓  core
pulseaudio  8.0-3      9      latest/stable  canonical✓  -
is the output of

Code: Select all

snap list
User avatar
MrEen
Level 22
Level 22
Posts: 15169
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound problems in Linux Mint Ulyana.

Post by MrEen »

Eww! I hope we're not going to break things. Do you have a reason you installed those snaps? Was it an attempt to cure this issue or some other reason?
XRhetorical
Level 1
Level 1
Posts: 23
Joined: Thu Sep 24, 2020 4:12 pm

Re: Sound problems in Linux Mint Ulyana.

Post by XRhetorical »

Yes, I must've not looked up the keywords "Linux Mint" in the beginning, as it told me to use the snap package list to get pavucontrol and alsamixer, and it didn't work.
User avatar
MrEen
Level 22
Level 22
Posts: 15169
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound problems in Linux Mint Ulyana.

Post by MrEen »

Okay, I don't want to touch core as I have no idea what it is, but let's get rid of the other two so the default installed versions should be able to run properly.

Code: Select all

sudo snap remove pulseaudio

Code: Select all

sudo snap remove alsa-utils
Reboot after that and see where things stand sound wise. Run the curl command again if still having issues.
XRhetorical
Level 1
Level 1
Posts: 23
Joined: Thu Sep 24, 2020 4:12 pm

Re: Sound problems in Linux Mint Ulyana.

Post by XRhetorical »

Here is the output: https://termbin.com/pzxw and the sound is now louder, but it's more of a crackle than static noise.
User avatar
MrEen
Level 22
Level 22
Posts: 15169
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound problems in Linux Mint Ulyana.

Post by MrEen »

Okay, looking better.

Does your unplug/replug of the headphone jack now act like it did previously?

Do the speakers also emit this noise when the headphones are unplugged?
XRhetorical
Level 1
Level 1
Posts: 23
Joined: Thu Sep 24, 2020 4:12 pm

Re: Sound problems in Linux Mint Ulyana.

Post by XRhetorical »

No. When I unplug then replug, there is still the same amount of noise, and it isn't happening on the speakers.
User avatar
MrEen
Level 22
Level 22
Posts: 15169
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound problems in Linux Mint Ulyana.

Post by MrEen »

Okay, I just noticed you have a hidden third audio card. It probably only applies to your internal microphone, but let's see if we try to force the use of the new sof audio driver if that might improve things. Run this then reboot and test:

Code: Select all

sudo tee /etc/modprobe.d/sof-fix.conf <<<'options snd-intel-dspcfg dsp_driver=3'
If that breaks the sound altogether, which it might, we can undo it with this followed by another reboot:

Code: Select all

sudo rm /etc/modprobe.d/sof-fix.conf
It's also possible that the new audio card requires the use of the 5.8 kernel. We'll try giving that a shot next if what's here doesn't help.
XRhetorical
Level 1
Level 1
Posts: 23
Joined: Thu Sep 24, 2020 4:12 pm

Re: Sound problems in Linux Mint Ulyana.

Post by XRhetorical »

I'm so sorry I had gotten sidetracked. I had entered the command to switch to the 3rd audio driver, but nothing changed at all when I had rebooted.
User avatar
MrEen
Level 22
Level 22
Posts: 15169
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound problems in Linux Mint Ulyana.

Post by MrEen »

If you still have that edit in place, lets see the output of this please:

Code: Select all

dmesg | grep -C1 -E 'ALSA|HDA|sof|HDMI|snd[_-]|sound|hda.codec|hda.intel'
XRhetorical
Level 1
Level 1
Posts: 23
Joined: Thu Sep 24, 2020 4:12 pm

Re: Sound problems in Linux Mint Ulyana.

Post by XRhetorical »

Code: Select all

[    0.396343] ACPI: Added _OSI(Linux-Dell-Video)
[    0.396343] ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
[    0.396343] ACPI: Added _OSI(Linux-HPI-Hybrid-Graphics)
--
[    1.735811] integrity: Loading X.509 certificate: UEFI:db
[    1.735829] integrity: Loaded X.509 cert 'Microsoft Windows Production PCA 2011: a92902398e16c49778cd90f99e4f9ae17c55af53'
[    1.735829] integrity: Loading X.509 certificate: UEFI:db
[    1.735846] integrity: Loaded X.509 cert 'Microsoft Corporation UEFI CA 2011: 13adbf4309bd82709c8cd54f316ed522988a1bd4'
[    1.736214] integrity: Loading X.509 certificate: UEFI:MokListRT
--
[   35.779523] hp_accel: laptop model unknown, using default axes configuration
[   35.788351] snd_pci_acp3x 0000:03:00.5: enabling device (0000 -> 0002)
[   35.788620] snd_pci_acp3x 0000:03:00.5: Invalid ACP audio mode : 1
[   35.791794] snd_rn_pci_acp3x: probe of 0000:03:00.5 failed with error -22
[   35.797488] lis3lv02d: 8 bits 3DC sensor found
--
                (Note that use of the override may cause unknown side effects.)
[   36.057748] snd_hda_intel 0000:03:00.1: enabling device (0000 -> 0002)
[   36.057869] snd_hda_intel 0000:03:00.1: Handle vga_switcheroo audio client
[   36.058025] snd_hda_intel 0000:03:00.6: enabling device (0000 -> 0002)
[   36.127890] EDAC amd64: Node 0: DRAM ECC disabled.
--
                (Note that use of the override may cause unknown side effects.)
[   36.128665] snd_hda_intel 0000:03:00.1: bound 0000:03:00.0 (ops amdgpu_dm_audio_component_bind_ops [amdgpu])
[   36.129294] input: HD-Audio Generic HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:08.1/0000:03:00.1/sound/card0/input15
[   36.134944] snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC295: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[   36.134949] snd_hda_codec_realtek hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   36.134950] snd_hda_codec_realtek hdaudioC1D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[   36.134951] snd_hda_codec_realtek hdaudioC1D0:    mono: mono_out=0x0
[   36.134952] snd_hda_codec_realtek hdaudioC1D0:    inputs:
[   36.134954] snd_hda_codec_realtek hdaudioC1D0:      Mic=0x19
[   36.134955] snd_hda_codec_realtek hdaudioC1D0:      Internal Mic=0x12
[   36.172108] EDAC amd64: Node 0: DRAM ECC disabled.
--
                (Note that use of the override may cause unknown side effects.)
[   36.416041] input: HD-Audio Generic Mic as /devices/pci0000:00/0000:00:08.1/0000:03:00.6/sound/card1/input16
[   36.416106] input: HD-Audio Generic Headphone as /devices/pci0000:00/0000:00:08.1/0000:03:00.6/sound/card1/input17
[   36.873207] Bluetooth: hci0: RTL: fw version 0xab6b705c
Post Reply

Return to “Sound, Multimedia, & Codecs”