Mint 20 not recognizing sound cards

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
fred56
Level 1
Level 1
Posts: 22
Joined: Mon Feb 15, 2021 7:55 pm

Mint 20 not recognizing sound cards

Post by fred56 »

Hi, I've been trying to solve this, spent hours, but no luck. I've tried many suggested solutions to no avail. I'm a newbie.

I installed Mint 20 on an Acer 14 (Edgar) Chromebook. Everything is fine except the sound cards aren't being recognized. I had Dummy Output in the Audio settings.

Something that I did along the way made the Dummy Output go away and showed the HDA Intel PCH card in Auto settings. But no sound. (Sorry no details, I cut and paste to the Terminal and didn't keep notes).

Using AlsaMixer I can see two cards, but the "HDA Intel PCH" card does not show any controls. The other, "chtrt5650," shows controls that can be manipulated.

How can I make the chtrt5650 card the default? How can I make Audio settings recognize the card? Or, how can I get the HDA Intel PCH card to work?

Thank you!
Attachments
Kazam_screenshot_chtrt5650.png
Kazam_screenshot_HDA Intel PCM.png
Kazam_screenshot_cards.png
User avatar
MrEen
Level 23
Level 23
Posts: 17531
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint 20 not recognizing sound cards

Post by MrEen »

Hi fred56, and welcome to the forum.

Let's get a look at your sound setup with this command:

Code: Select all

curl https://gitlab.freedesktop.org/pulseaudio/pulseaudio/raw/master/src/utils/pa-info?inline=false | bash | nc termbin.com 9999
The last line of output will have a URL pointing to the info. Pasting that URL is all I need.

It's probably just a simple config change necessary, but it could be deeper than that.
fred56
Level 1
Level 1
Posts: 22
Joined: Mon Feb 15, 2021 7:55 pm

Re: Mint 20 not recognizing sound cards

Post by fred56 »

Hi! Thanks for the reply.

https://termbin.com/fm3j

Let me know if you need anything else.

I put Linux Mint on my PC (dual boot) about six weeks ago and loving it. And just put Mint on the Chromebook yesterday. It's been frustrating at times since everything is so new to me, but a lot of fun puzzles.
User avatar
MrEen
Level 23
Level 23
Posts: 17531
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint 20 not recognizing sound cards

Post by MrEen »

Okay, we didn't get the full output, but I think I know what's wrong. ALSA is seeing the chtrt5650 card but PulseAudio isn't. Try runing this in the terminal and see if there's a change in your sound settings:

Code: Select all

pacmd load-module module-alsa-sink device=hw:1,0
If that fails to help, run this command please:

Code: Select all

wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
That script will ask if you want to save locally or upload. Please choose upload and paste the URL it'll give you when it finishes.
fred56
Level 1
Level 1
Posts: 22
Joined: Mon Feb 15, 2021 7:55 pm

Re: Mint 20 not recognizing sound cards

Post by fred56 »

The first command did nothing. Here's the output of the second:

http://alsa-project.org/db/?f=ab40277aa ... acaa2a66af

Thanks for your help!
User avatar
MrEen
Level 23
Level 23
Posts: 17531
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint 20 not recognizing sound cards

Post by MrEen »

Okay, try these and tell me if either work:

Code: Select all

aplay -D plughw:1,0 /usr/share/sounds/alsa/Front_Center.wav

Code: Select all

aplay -D plughw:1,1 /usr/share/sounds/alsa/Front_Center.wav
fred56
Level 1
Level 1
Posts: 22
Joined: Mon Feb 15, 2021 7:55 pm

Re: Mint 20 not recognizing sound cards

Post by fred56 »

I entered both commands and then rebooted the computer, just in case that would help.

I looked at Sound settings, Pulse Audio Volume Control, and AlsaMixer. Everything looks the same as before. Still don't have sound.
User avatar
MrEen
Level 23
Level 23
Posts: 17531
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint 20 not recognizing sound cards

Post by MrEen »

I was hoping one of those two would produce sound. But no such luck apparently.

In your attempts to fix this you've added this line to a file in /etc/modprobe.d (maybe alsa-base.conf?) that I'd like you to remove, then reboot, then try the two lines in my last post again.

Were you testing with headphones or without? Normally, either the headphones or the speakers would be muted, but neither of yours were. Typically, headphones have a better chance of working when there are issues.
fred56
Level 1
Level 1
Posts: 22
Joined: Mon Feb 15, 2021 7:55 pm

Re: Mint 20 not recognizing sound cards

Post by fred56 »

Yes, the config file that you suggested is the one I changed. I added this line to the bottom (through cutting and pasting from the terminal); "options snd-hda-intel model=generic". The file is read-only and I don't know how to make it writable. Can you help?

I don't have headphones, so I've only been testing the built in speakers.
User avatar
MrEen
Level 23
Level 23
Posts: 17531
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint 20 not recognizing sound cards

Post by MrEen »

To open that file to remove the edit you made, use xed admin:///etc/modprobe.d/alsa-base.conf in the terminal.
fred56
Level 1
Level 1
Posts: 22
Joined: Mon Feb 15, 2021 7:55 pm

Re: Mint 20 not recognizing sound cards

Post by fred56 »

After removing the line and saving, the output device in the Sound setting has reverted to Dummy Output. So no sound.
User avatar
MrEen
Level 23
Level 23
Posts: 17531
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint 20 not recognizing sound cards

Post by MrEen »

Wow, interesting.

Do this one again please:

Code: Select all

wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
User avatar
MrEen
Level 23
Level 23
Posts: 17531
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint 20 not recognizing sound cards

Post by MrEen »

Actually, regardless of the output, I'd like you to try this next:

Code: Select all

sudo tee /etc/modprobe.d/sof-fix.conf <<<'options snd-intel-dspcfg dsp_driver=1'
Run that in the terminal then reboot and test.
fred56
Level 1
Level 1
Posts: 22
Joined: Mon Feb 15, 2021 7:55 pm

Re: Mint 20 not recognizing sound cards

Post by fred56 »

wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
fred56
Level 1
Level 1
Posts: 22
Joined: Mon Feb 15, 2021 7:55 pm

Re: Mint 20 not recognizing sound cards

Post by fred56 »

I ran it and rebooted, no changes, Dummy Output is still there.
User avatar
MrEen
Level 23
Level 23
Posts: 17531
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint 20 not recognizing sound cards

Post by MrEen »

In case you missed it, try what's in my last post. We were posting at the same time.
User avatar
MrEen
Level 23
Level 23
Posts: 17531
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint 20 not recognizing sound cards

Post by MrEen »

I'd like to see if it made changes to this once more:

Code: Select all

wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
User avatar
MrEen
Level 23
Level 23
Posts: 17531
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint 20 not recognizing sound cards

Post by MrEen »

This is going to be the next thing to try:

In the terminal run xed admin:///var/lib/alsa/asound.state and when the file opens find this section:

Code: Select all

state.chtrt5650 {
	control.1 {
		iface MIXER
Change it to this:

Code: Select all

state.chtrt5645 {
	control.1 {
		iface MIXER
Save the change, then run sudo alsactl restore then see if the sound is working.
Post Reply

Return to “Sound, Multimedia, & Codecs”