Page 2 of 2

Re: Mint 20 not recognizing sound cards

Posted: Tue Feb 16, 2021 10:31 pm
by MrEen
And here's the reason for my last suggestion:
[ 10.406205] input: chtrt5650 Headset as /devices/platform/808622A8:00/cht-bsw-rt5645/sound/card1/input10
I'm hoping that might actually fix this.

Re: Mint 20 not recognizing sound cards

Posted: Tue Feb 16, 2021 10:34 pm
by fred56
Dummy Output is still there.

Re: Mint 20 not recognizing sound cards

Posted: Tue Feb 16, 2021 10:35 pm
by MrEen
I've got to head to bed tonight. If the above doesn't fix this, I have more ideas, but it'll have to wait until tomorrow.

It'll involve /usr/share/alsa/ucm or ucm2.

Re: Mint 20 not recognizing sound cards

Posted: Tue Feb 16, 2021 10:37 pm
by fred56
Thanks MrEen! Talk to you tomorrow.

Re: Mint 20 not recognizing sound cards

Posted: Thu Feb 18, 2021 11:06 pm
by fred56
Good evening! If you think it would be useful, I'm not opposed to doing a fresh install. Before posting here, I tried so many things and I'm not sure what state it's in now. I might have been a little a reckless. Let me know what you think!

Re: Mint 20 not recognizing sound cards

Posted: Fri Feb 19, 2021 10:25 pm
by MrEen
My apologies fred56! I started a new job this week, and my time for the forum has been severely limited.

If a reinstall is something you're not afraid of, that might be the best option here. If nothing else, we'd be starting from a known state even if it's still not working.

My ucm/ucm2 idea is a bit "out there" and not something that I had much hope for anyway. But if you'd prefer, we can still travel down that path and see where it leads. For starters, I'd need to see the output of ls -l /usr/share/alsa/ucm and ls -l /usr/share/alsa/ucm2

Re: Mint 20 not recognizing sound cards

Posted: Sat Feb 20, 2021 1:39 pm
by fred56
Good luck with the new job! I'm out of town for the weekend. I'll reinstall and then try some of your suggested solutions. I'll be in touch after that. enjoy your weekend!

Re: Mint 20 not recognizing sound cards

Posted: Sat Feb 20, 2021 10:21 pm
by MrEen
Thank you fred56!

The job has been working out wonderfully so far. The only "negative" is the time constraints it has imposed on me being able to be here.

We'll pick this up when you're ready. Just be aware it could be a day or so before I reply.

Hope your weekend goes great! :D

Re: Mint 20 not recognizing sound cards

Posted: Sun Feb 21, 2021 6:36 pm
by fred56
Hey MrEen. I've reinstalled Mint. I tried the first couple of suggestions, but still have a Dummy Output. I'll wait until you have time to get back to me before I do anything else. Thanks for your time and help!

Re: Mint 20 not recognizing sound cards

Posted: Sun Feb 21, 2021 8:27 pm
by MrEen
Aww shucks. Let's see this one again:

Code: Select all

curl https://gitlab.freedesktop.org/pulseaudio/pulseaudio/raw/master/src/utils/pa-info?inline=false | bash | nc termbin.com 9999

Re: Mint 20 not recognizing sound cards

Posted: Mon Feb 22, 2021 12:26 pm
by fred56
This is the output:

Code: Select all

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  2093  100  2093    0     0   1582      0  0:00:01  0:00:01 --:--:--  1582


Re: Mint 20 not recognizing sound cards

Posted: Mon Feb 22, 2021 10:23 pm
by MrEen
It failed to run successfully. Just try it again until you see the termbin.com URL on the last line.

Re: Mint 20 not recognizing sound cards

Posted: Tue Feb 23, 2021 1:32 am
by fred56

Code: Select all

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  2093  100  2093    0     0   2041      0  0:00:01  0:00:01 --:--:--  2041
https://termbin.com/1f0e
cat: '/sys/module/snd_soc_sst_cht_bsw_rt5645/parameters/*': No such file or directory



Re: Mint 20 not recognizing sound cards

Posted: Wed Feb 24, 2021 9:22 pm
by MrEen
Damn, now we're not getting everything I needed. Try this one:

Code: Select all

wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh

Re: Mint 20 not recognizing sound cards

Posted: Wed Feb 24, 2021 10:57 pm
by fred56

Re: Mint 20 not recognizing sound cards

Posted: Wed Feb 24, 2021 11:02 pm
by MrEen
Yes it was exactly what I needed.

Still showing this "confusion":

Code: Select all

[   10.347673] cht-bsw-rt5645 cht-bsw-rt5645: snd-soc-dummy-dai <-> media-cpu-dai mapping ok
[   10.348092] cht-bsw-rt5645 cht-bsw-rt5645: snd-soc-dummy-dai <-> deepbuffer-cpu-dai mapping ok
[   10.358046] cht-bsw-rt5645 cht-bsw-rt5645: rt5645-aif1 <-> ssp2-port mapping ok
[   10.358195] cht-bsw-rt5645 cht-bsw-rt5645: ASoC: no DMI vendor name!
[   10.418633] input: chtrt5650 Headset as /devices/platform/808622A8:00/cht-bsw-rt5645/sound/card1/input14
Maybe the 5.8 kernel might fix this. Update Manager > View > Linux kernels. Reboot after installing the highest 5.8 kernel and see if dmesg | grep snd still shows the same thing as above.

Re: Mint 20 not recognizing sound cards

Posted: Wed Feb 24, 2021 11:28 pm
by fred56
I installed and rebooted. Then ran

Code: Select all

dmesg | grep snd
in the terminal (is that what you had intended?). The output is:

Code: Select all

[    8.259000] snd_hda_intel 0000:00:1b.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    9.406817] cht-bsw-rt5645 cht-bsw-rt5645: snd-soc-dummy-dai <-> media-cpu-dai mapping ok
[    9.407229] cht-bsw-rt5645 cht-bsw-rt5645: snd-soc-dummy-dai <-> deepbuffer-cpu-dai mapping ok