Playing video shows green empty screen + sound only

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Riel
Level 1
Level 1
Posts: 4
Joined: Thu Jan 03, 2008 9:53 pm

Playing video shows green empty screen + sound only

Postby Riel » Fri Jan 04, 2008 9:51 am

Hello,

first I had tried putting a dvd movie in the drive. Totem started, I had sound, but only the BLUE screen.
I searched around a lot ( no solution found) but there was mentioned I'd twiggle with the multimedia selector.

Had to make it available in the menu first.

Got the settings: it only works on X Windows system (No Xv). That way the testsceen shows up ok. The other options keep a dark green screen where nothing happens.

now, I got that screen in Totem too. When playing DVD's.

Same issue with playing ASF files and with VLC and also with MPlayer.
Didn't try any other formats, but I think I have to look for a solution somewhere else.

Anyone has a clue?

Husse
Level 23
Level 23
Posts: 19593
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Playing video shows green empty screen + sound only

Postby Husse » Fri Jan 04, 2008 6:02 pm

This is new to me (I think)
Which version of Mint and have you got any "extra" multimedia programs installed?
As you indicate it's always a good idea to look at settings...
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

nick
Level 5
Level 5
Posts: 685
Joined: Sat Dec 02, 2006 8:04 am

Re: Playing video shows green empty screen + sound only

Postby nick » Sat Jan 05, 2008 8:07 am

Hi
Have you got "effects" enabled -compiz etc, if so try disabling
while watching video

Also
http://ubuntu-utah.ubuntuforums.org/sho ... hp?t=40273

Also: How to configure Mplayer in howtos

Also: http://simos.info/blog/archives/594

Also: http://ubuntuguide.org/wiki/Ubuntu:Feis ... o_playback


Nick

McLovin
Level 5
Level 5
Posts: 788
Joined: Thu Aug 23, 2007 6:53 pm
Contact:

Re: Playing video shows green empty screen + sound only

Postby McLovin » Sat Jan 05, 2008 2:21 pm

another thing you can try if you are using compiz is to enable the video playback plug-in.

carltonh
Level 2
Level 2
Posts: 52
Joined: Sat Dec 23, 2006 12:34 am
Location: Dallas, Texas

Re: Playing video shows green empty screen + sound only

Postby carltonh » Sun Jan 20, 2008 6:44 pm

I had the same problem in Mint 4.0, even though 3.0 was fine. It seemed that Mplayer and Totem (GStreamer) had to be fixed separately, and Compiz was the originator of both problems. I tried enabling the Compiz video playback plugin, but that didn't work. (Though it may have allowed the below to work.)

For GStreamer I typed "gstreamer-properties" in a terminal. go to Video tab and change "Default Output" plugin to "X Window System (no Xv)".

For Mplayer, I right clicked on a black video screen from within a Firefox Mplayer plugin, changed "video output" to "X11" and clicked "ok". I then had to reload the page. It didn't seem to work until I reloaded the page.

Husse
Level 23
Level 23
Posts: 19593
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Playing video shows green empty screen + sound only

Postby Husse » Sun Jan 20, 2008 7:02 pm

Image
Don't fix it if it ain't broken, don't break it if you can't fix it


Return to “Sound, Multimedia, & Codecs”

Who is online

Users browsing this forum: No registered users and 3 guests