GDK Failures - Hulu Desktop

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 2
Joined: Mon Dec 12, 2011 3:37 pm

GDK Failures - Hulu Desktop

Postby rikeshar » Mon Dec 12, 2011 3:40 pm

Hey everyone, I'm trying to run Hulu Desktop on Mint 12, and this is what I see when I try to run it from the terminal:

Code: Select all

huludesktop:2368): Gdk-WARNING **: gdk_window_new(): parent is destroyed

(huludesktop:2368): Gdk-CRITICAL **: IA__gdk_window_get_display: assertion `GDK_IS_WINDOW (window)' failed

(huludesktop:2368): Gdk-CRITICAL **: IA__gdk_x11_get_xatom_by_name_for_display: assertion `GDK_IS_DISPLAY (display)' failed

(huludesktop:2368): Gdk-WARNING **: /build/buildd/gtk+2.0-2.24.6/gdk/x11/gdkdrawable-x11.c:952 drawable is not a pixmap or window

(huludesktop:2368): Gdk-CRITICAL **: IA__gdk_x11_display_get_xdisplay: assertion `GDK_IS_DISPLAY (display)' failed
Segmentation fault

It gave me this message on Ubuntu 11.10 as well, and I was hoping Mint 12 would resolve, but no go. I originally installed it on Ubuntu 10.10 and it worked fine on that, and 11.04, but started freezing on 11.10. I uninstalled and reinstalled it and that's when I started getting this message. Any ideas what it could be? If I try to run it from the applications menu nothing happens at all.

Level 1
Level 1
Posts: 37
Joined: Fri Sep 19, 2008 6:55 am

Re: GDK Failures - Hulu Desktop

Postby metamorphousthe » Mon Feb 06, 2012 8:34 pm

I also HAD the same problem (READ BELOW) running huludesktop from LM 12 MATE. I have yet to try it in any other DE. It works fine in my LM9 GNOME. All the wiki I can find say to point ~/.huludesktop to the file which is the error I get when trying to run HuluDesktop app as the popup window below shows the error message ...

Hulu Desktop could not locate the Flash plugin.

If you already have it installed, please modify ~/.huludesktop with the correct location of

However, there is no /.huludesktop folder in my home folder (showing hidden files/folders), nor in any other area (that I can find) in my file system.

Default flash IS installed installed in a few places in my OS including /etc/alternatives but nothing to point it to with.

When trying to run huludesktop in terminal, I get no results except the popup window error.

BTW, HuluDesktop runs fine in LM9 and also does NOT have a /.huludesktop folder

Post Script: While typing this I decided to compare my LM9 flash installs (in Synaptic) with my L12 installs. I decided t match my flash installs in 12 wit what was in 9, since huludesktop worked in 9.

I did this and now huludesktop works ...

While choosing ONLY (to match 9)

The results were:
To Be Installed:

To Be Removed:

Again, huludesktop now works n 12
"It's all about change"

Level 1
Level 1
Posts: 1
Joined: Sun Apr 08, 2012 7:35 am

Re: GDK Failures - Hulu Desktop

Postby NorahAura » Sun Apr 08, 2012 7:43 am

I found these steps to work:

From terminal, install flashplayer-downloader (it will also install flashplayer-installer and remove other adobe flash installs):

Code: Select all

sudo apt-get install flashplayer-downloader

Install huludesktop, if not already installed, via the hulu desktop download page

Run huludesktop, agree to terms.

Lastly, open ~/.huludesktop:

Code: Select all

gksu gedit ~/.huludesktop

Edit the following line and point to mint flash install

Code: Select all

flash_location = /opt/mint-flashplugin-11/

Hope this helps a few lost souls :)

Level 1
Level 1
Posts: 1
Joined: Wed Oct 03, 2012 12:01 am

Re: GDK Failures - Hulu Desktop

Postby bobl57 » Wed Oct 03, 2012 12:05 am

:D sometimes it is that simple to fix...just can't stop optimizing mint...THANKS!!!

Return to “Sound, Multimedia, & Codecs”

Who is online

Users browsing this forum: No registered users and 4 guests