Black screen after switching to nvidia drivers

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 1
Joined: Thu Dec 07, 2017 7:25 pm

Black screen after switching to nvidia drivers

Post by andrewhenriquez » Thu Dec 07, 2017 8:33 pm

Hi! Pretty new user here, so sorry if this should have gone in "Newbie Questions," but here goes.

I recently installed the latest 64-bit KDE version of Linux Mint on my laptop (Acer Aspire V), dual-booting with Windows 10. I managed to mostly get everything set up the way I wanted, and as the last step before rebooting, I used the driver manager to switch over from the open source xserver-xcorg-video-nouveau driver to the proprietary nvidia-340 driver. On the next reboot, I ended up stuck with a black, unresponsive screen after the GRUB bootloader.

Did some googling, tried adding "nomodeset" to the boot parameters, but it didn't work. Either I did it wrong, somehow, or it was just the wrong solution to the problem. Tried to boot into recovery mode, but still was unable to get a GUI up and running.

In the end, I booted to Windows, deleted the Linux partitions and started again. Now, I've mostly got everything set up the way I want. I would still like to use the nvidia-340 drivers, but I'd rather not have to go through the whole rigamarole again.

Is there anything you could suggest to make sure the transition goes more smoothly?

Alternatively, if I end up stuck with a blank screen anyway, is there an easy way to roll back that change? Booting to a command prompt and changing the selected driver that way, for example?

Thanks in advance.

User avatar
Level 20
Level 20
Posts: 11946
Joined: Thu Apr 07, 2011 8:15 pm

Re: Black screen after switching to nvidia drivers

Post by WharfRat » Thu Dec 07, 2017 9:01 pm

Hello andrewhenriquez Image

Welcome to Linux Mint and the Linux Mint forum :)

You can roll back the changes by entering the commands found in this topic

All of them can be executed in a tty console after entering one by pressing ctl-alt-f1

I really can't make any suggestions regarding the driver version as I'm still using nouveau.

Post Reply

Return to “Hardware Support”