Mint 19 Won't boot goes to emergency mode [SOLVED]

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Siv
Level 1
Level 1
Posts: 5
Joined: Mon Jan 08, 2018 9:05 am

Mint 19 Won't boot goes to emergency mode [SOLVED]

Post by Siv » Thu Aug 09, 2018 10:36 pm

Hi,
I recently cloned a HDD in an external USB 3.0 adapter as the disk was a Windows disk and it was starting to have issues. I used GParted to clone the failing disk to a new SSD and successfully ejected the SSD after finishing with GParted. When I came to eject the HDD it was showing in the file manager as two partitions:

sdj3
RECOVERY

I clicked the eject symbol next to Sdj3 which appeared as "230GB Volume" and the ejecting message notification appeared but it just stayed on screen. I clicked it and it disappeared but I never got the "You can safely remove" type message.

I then repeated the process with the Recovery partition which appeared as RECOVERY and clicked the eject next to that and it also would not give me the "You can safely remove" option.

I decided to shut down the PC and remove the disk (this usually works on Windows so thought it might on Mint 19).

When I came to boot up the next day Mint sat on the Linux Mint logo with the cycling dots and nothing happened for a while until it eventually came up saying I was in emergency mode and gave some options. One of which was to view the system log. I reviered that and it appears to be remembering that the device was plugged in and is trying to restore the connection.

I am seeing this error:
"Timed out waiting for device dev-disk-by\x2duuid-CEEA57DDEA57C07F.device."
"Subject: Unit dev-disk-by\x2duuid-CEEA57DDEA57C07F.device has failed
Defined-by: systemd

The result is RESULT.
date machine name systemd[1]: Dependency failed for /media/RECOVERY.
Subject: Unit media-RECOVERY.mount has failed
Defined by: systemd

I also get another line:

Unit swap.target has failed.

How can I convince the system to ignore the device as I no longer want it connected to the system?

I tried booting up with the device plugged in and it booted OK and then tried ejecting the two partitions that were mounted sdj3 and RECOVERY but via the file manager this failed. I then started GParted and unmounted the two partitions applied the changes and then checked the file manager again. The two partitions were listed but did not have the eject symbol next to them. I then shut down completely and disconnected the external drive but on starting up I am still getting it failing to boot.

Finally I booted up with the drive attached and used GParted to remove the RECOVERY partition and another FAT16 partition that is not appearing in the file manager. I also unmounted the remaining main NTFS parttion that does have some Windows data on it that I don't wish to destroy just yet. I then unmounted the remaining partition using GParted and then shut down the system and again I am still getting the same errors??

How can I get Mint to stop trying to access the drives on boot up so that it can boot normally.

Any help appreciated.
Last edited by Siv on Fri Aug 10, 2018 6:28 am, edited 1 time in total.

Siv
Level 1
Level 1
Posts: 5
Joined: Mon Jan 08, 2018 9:05 am

Re: Mint 19 Won't boot goes to emergency mode

Post by Siv » Fri Aug 10, 2018 6:28 am

OK, figured this out myself, I had a look at /etc/fstab using:

nano /etc/fstab

And noticed there were entries in the fstab file for the two partitions on the external HDD. So I remmed those out by adding a "#" at the start of the line and then rebooted and after a short delay was able to log into Mint 19 GUI again.

So please ignore this post as it is now solved.

Siv

deepakdeshp
Level 11
Level 11
Posts: 3528
Joined: Sun Aug 09, 2015 10:00 am

Re: Mint 19 Won't boot goes to emergency mode [SOLVED]

Post by deepakdeshp » Fri Aug 10, 2018 11:34 am

Great. Good for you.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

Post Reply

Return to “Hardware Support”