Troubleshoot trackpad

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
erw1
Level 1
Level 1
Posts: 44
Joined: Sun Apr 08, 2018 12:58 am

Troubleshoot trackpad

Post by erw1 » Thu Dec 06, 2018 4:40 pm

Sudden trackpad failure. Only works to scroll menu down up. Relying on trackpoint. At times cursor wiggly. Steps 2 troubleshoot, please?
x64/LM 18.3 alongside Win 10

sleeper12
Level 4
Level 4
Posts: 216
Joined: Thu May 25, 2017 3:22 pm

Re: Troubleshoot trackpad

Post by sleeper12 » Thu Dec 06, 2018 11:11 pm

Check: Menu, Mouse, Touchpad, be sure 'Enable touchpad' box is checked.

User avatar
all41
Level 13
Level 13
Posts: 4987
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: Troubleshoot trackpad

Post by all41 » Fri Dec 07, 2018 1:19 am

This may not be a remedy but will provide further information to help with your issue.
See if the trackpad is listed in xinput,
Open a terminal window and enter or copy/paste:

Code: Select all

xinput --list
If your trackpad is listed there the system recognizes the device.

There will be a device id# associated with the trackpad--make note of this number.
In the same terminal enter:
xinput list-props <id#>
(example of form: xinput list props ##)
substitute your id number mentioned above
You will see a list of attributes. Near the top of the list make sure the 'Device Enabled' is 1.
Post your findings here
Proud to be a supporter and monthly contributor to Mint.

BrunoMiranda
Level 3
Level 3
Posts: 136
Joined: Thu Jun 24, 2010 2:22 pm

Re: Troubleshoot trackpad

Post by BrunoMiranda » Wed Dec 12, 2018 7:15 pm

Just to make sure if this is a software or hardware problem...


Are you sure the trackpad failure is due to software?

Are you sure the hardware is working ok?

Have you tried any other OS on that machine (Windows, or some Linux Mint boot ISO) for testing, and it all works perfectly?
Bye for now,
Bruno


(Always backup before you fvckup :mrgreen: )

Post Reply

Return to “Hardware Support”