No sleep mode if USB port used

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Francky4fingers
Level 1
Level 1
Posts: 11
Joined: Tue Oct 22, 2019 4:39 pm

No sleep mode if USB port used

Post by Francky4fingers » Sat Nov 09, 2019 10:40 am

Hello,

First of all, excuse my english ! I'm French but my question had no success on the french support...

I install Linuxmint 19.2 on this old toshiba laptop ( http://il.dynabook.com/en/discontinued- ... c650d-10d/

Code: Select all

mary@pcdemary:~$ inxi -Fxxz
System:
  Host: pcdemary Kernel: 4.15.0-65-generic x86_64 bits: 64 compiler: gcc 
  v: 7.4.0 Desktop: Cinnamon 4.2.4 wm: muffin dm: LightDM 
  Distro: Linux Mint 19.2 Tina base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: TOSHIBA product: Satellite C650D v: PSC16E-007008FR 
  serial: <filter> Chassis: AMD type: 10 serial: <filter> 
  Mobo: TOSHIBA model: Portable PC serial: <filter> BIOS: Insyde v: 1.40 
  date: 05/19/2010 
Battery:
  ID-1: BAT0 charge: 51.9 Wh condition: 55.2/56.2 Wh (98%) volts: 10.8/10.8 
  model: PA3817U-1BRS serial: <filter> status: Discharging 
CPU:
  Topology: Single Core model: AMD V120 bits: 64 type: UP arch: K10 rev: 3 
  L2 cache: 512 KiB 
  flags: lm nx pae sse sse2 sse3 sse4a svm bogomips: 4388 
  Speed: 800 MHz min/max: 800/2200 MHz Core speed (MHz): 1: 800 
Graphics:
  Device-1: AMD RS880M [Mobility Radeon HD 4225/4250] 
  vendor: Toshiba America Info Systems driver: radeon v: kernel 
  bus ID: 01:05.0 chip ID: 1002:9712 
  Display: x11 server: X.Org 1.19.6 driver: ati,radeon 
  unloaded: fbdev,modesetting,vesa resolution: 1366x768~60Hz 
  OpenGL: renderer: AMD RS880 (DRM 2.50.0 / 4.15.0-65-generic LLVM 8.0.0) 
  v: 3.3 Mesa 19.0.8 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: AMD SBx00 Azalia vendor: Toshiba America Info Systems 
  driver: snd_hda_intel v: kernel bus ID: 00:14.2 chip ID: 1002:4383 
  Sound Server: ALSA v: k4.15.0-65-generic 
Network:
  Device-1: Qualcomm Atheros AR9285 Wireless Network Adapter vendor: Askey 
  driver: ath9k v: kernel port: 7000 bus ID: 02:00.0 chip ID: 168c:002b 
  IF: wlp2s0 state: up mac: <filter> 
  Device-2: Qualcomm Atheros AR8152 v1.1 Fast Ethernet 
  vendor: Toshiba America Info Systems driver: atl1c v: 1.0.1.1-NAPI 
  port: 2000 bus ID: 08:00.0 chip ID: 1969:2060 
  IF: enp8s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 261.70 GiB used: 10.92 GiB (4.2%) 
  ID-1: /dev/sda vendor: Seagate model: ST9250315AS size: 232.89 GiB 
  speed: 3.0 Gb/s serial: <filter> 
  ID-2: /dev/sdb type: USB vendor: Verbatim model: STORE N GO 
  size: 28.82 GiB serial: <filter> 
Partition:
  ID-1: / size: 27.37 GiB used: 6.70 GiB (24.5%) fs: ext4 dev: /dev/sda1 
  ID-2: /home size: 197.06 GiB used: 2.23 GiB (1.1%) fs: ext4 dev: /dev/sda3 
  ID-3: swap-1 size: 3.73 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 49.2 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 159 Uptime: 9m Memory: 2.68 GiB used: 902.1 MiB (32.9%) 
  Init: systemd v: 237 runlevel: 5 Compilers: gcc: 7.4.0 alt: 7 Shell: bash 
  v: 4.4.20 running in: gnome-terminal inxi: 3.0.32
Every time I want this laptop to sleep and if in the same time there is a device into that USB port (a key or an external HD) the sleep mode didn't work. The sleep mode is OK for 2 seconds and then the PC start again. Sometimes it's not too bad and I can use it but most of the time I can't use the keyboard, the screen is dark, and my only solution is to turn off brutally the computer.
The only solution that was giving to me is to use mate more than cinnamon. Why not, but when i try a live CD of linuxmint mate I've got the same problem !

Even if it's not an asus I try this too https://askubuntu.com/questions/53372/s ... sus-laptop but it didn't work.

Is someone know what to do for that ? What do I have to check ?

Thanks for all

User avatar
kato181
Level 4
Level 4
Posts: 422
Joined: Fri Mar 24, 2017 12:33 am
Location: Frederickton NSW

Re: No sleep mode if USB port used

Post by kato181 » Sun Nov 10, 2019 3:50 am

You need to update your kernel to 5.3.0-19. That may fix you problem.
In terminal enter the following then post the results here..
lsusb

Francky4fingers
Level 1
Level 1
Posts: 11
Joined: Tue Oct 22, 2019 4:39 pm

Re: No sleep mode if USB port used

Post by Francky4fingers » Sun Nov 10, 2019 7:39 am

Thanks for your answer
Here is the result for lsusb :

Code: Select all

mary@pcdemary:~$ lsusb
Bus 003 Device 002: ID 10f1:1a2a Importek Laptop Integrated Webcam
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 0bda:0138 Realtek Semiconductor Corp. RTS5138 Card Reader Controller
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Furthermore I notice that when I use the dmesg command I've got lots of line in the result, but 2 are wrote in red, saying :

Code: Select all

[  791.364843] [drm:atom_op_jump [radeon]] *ERROR* atombios stuck in loop for more than 5secs aborting
[  791.364861] [drm:atom_execute_table_locked [radeon]] *ERROR* atombios stuck executing E978 (len 492, WS 0, PS 4) @ 0xE9B9
But I don't know if there's a link with my problem...

User avatar
kato181
Level 4
Level 4
Posts: 422
Joined: Fri Mar 24, 2017 12:33 am
Location: Frederickton NSW

Re: No sleep mode if USB port used

Post by kato181 » Sun Nov 10, 2019 9:49 am

Looks like you may have a video card problem with radeon.
Here is a link to the bug with a suggested fix. If not then you may have to go back to an earlier kernel version.
https://askubuntu.com/questions/978525/ ... ck-in-loop

Francky4fingers
Level 1
Level 1
Posts: 11
Joined: Tue Oct 22, 2019 4:39 pm

Re: No sleep mode if USB port used

Post by Francky4fingers » Sun Nov 10, 2019 1:13 pm

Yes I've read that page but those persons seems to have boot problem. My problem is quite different.
But as it say I add blacklist radeon into the blacklist.conf file but it change nothing. I'm not sure it was disablle because when after I run lsmod | grep radeon I had an answer...
The other solution is to modify grub. I'm really not sure of what I am going to do so I prefer not !
I'm gonna take a look on what to do to change the kernel, but do I have to update to a 5.3 or go back to a 4.4 ?

User avatar
JerryF
Level 11
Level 11
Posts: 3873
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: No sleep mode if USB port used

Post by JerryF » Sun Nov 10, 2019 1:28 pm

In BIOS, check to see if you have an option called "Wake on USB". If so, disable that.
IF your problem has been solved, please edit your ORIGINAL post and add [SOLVED] to the beginning of the Subject Line. It helps other members when browsing posts.

Francky4fingers
Level 1
Level 1
Posts: 11
Joined: Tue Oct 22, 2019 4:39 pm

Re: No sleep mode if USB port used

Post by Francky4fingers » Sun Nov 10, 2019 4:29 pm

Thanks for your answer but unfortunately no option like that.

User avatar
kato181
Level 4
Level 4
Posts: 422
Joined: Fri Mar 24, 2017 12:33 am
Location: Frederickton NSW

Re: No sleep mode if USB port used

Post by kato181 » Sun Nov 10, 2019 8:23 pm

Francky4fingers wrote:
Sun Nov 10, 2019 4:29 pm
Thanks for your answer but unfortunately no option like that.
There is a bug in the radeon drivers causing the bios loop...here are some link regarding it..
https://bugzilla.kernel.org/show_bug.cgi?id=51381
https://askubuntu.com/questions/978525/ ... ck-in-loop
Some are solved with driver update and some are not solved.
But by all accounts it's definately a graphics driver problem
Last edited by kato181 on Tue Nov 12, 2019 7:57 pm, edited 1 time in total.

Francky4fingers
Level 1
Level 1
Posts: 11
Joined: Tue Oct 22, 2019 4:39 pm

Re: No sleep mode if USB port used

Post by Francky4fingers » Tue Nov 12, 2019 3:10 pm

I try the 5.0 kernel and the 5.3 but it change nothing.
Before to stop I'd like to try to change/update drivers but I don't know how to do :-/
When I use driver manager it says that "no proprietary driver are in use"

Does it mean that I can't change my graphic card driver ?
If it is, I think that the solution is to put a warning sticker on the computer ;-)

Thanks anyway !

User avatar
kato181
Level 4
Level 4
Posts: 422
Joined: Fri Mar 24, 2017 12:33 am
Location: Frederickton NSW

Re: No sleep mode if USB port used

Post by kato181 » Tue Nov 12, 2019 8:08 pm

Francky4fingers wrote:
Tue Nov 12, 2019 3:10 pm
I try the 5.0 kernel and the 5.3 but it change nothing.
Before to stop I'd like to try to change/update drivers but I don't know how to do :-/
When I use driver manager it says that "no proprietary driver are in use"

Does it mean that I can't change my graphic card driver ?
If it is, I think that the solution is to put a warning sticker on the computer ;-)

Thanks anyway !
Your video card is an ATI card so you will need to check if there is an updated driver for it for linux.
In Terminal enter the following command and post the results here please..
inxi -G

User avatar
kato181
Level 4
Level 4
Posts: 422
Joined: Fri Mar 24, 2017 12:33 am
Location: Frederickton NSW

Re: No sleep mode if USB port used

Post by kato181 » Tue Nov 12, 2019 8:18 pm

You are using Mint 19.2 Cinnamon. Cinnamon I believe can be resource hungry with regards to graphics. You could try either Mint Mate or Xfce and see if that fixes the problem. Use a live system and see if it works for either desktop themes Mate or Xfce.
Check the following link out also..
https://help.ubuntu.com/community/RadeonDriver

Francky4fingers
Level 1
Level 1
Posts: 11
Joined: Tue Oct 22, 2019 4:39 pm

Re: No sleep mode if USB port used

Post by Francky4fingers » Thu Nov 14, 2019 1:53 pm

Here's the return

Code: Select all

mary@pcdemary:~$ inxi -G
Graphics:
  Device-1: AMD RS880M [Mobility Radeon HD 4225/4250] driver: radeon 
  v: kernel 
  Display: x11 server: X.Org 1.19.6 driver: ati,radeon 
  unloaded: fbdev,modesetting,vesa resolution: 1366x768~60Hz 
  OpenGL: renderer: AMD RS880 (DRM 2.50.0 / 4.15.0-70-generic LLVM 8.0.0) 
  v: 3.3 Mesa 19.0.8 
I've already try mate (with a live session) but the problem was the same.
I look at the page about radeon driver. Mine seems OK, wich is true in a way except when a USB device is on...

Post Reply

Return to “Hardware Support”