Mint 13: Problem activating ATI/AMD proprietary FGLRX driver

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 13
Joined: Thu Jul 19, 2012 11:21 am

Re: Mint 13: Problem activating ATI/AMD proprietary FGLRX dr

Postby bradman334 » Sat Jul 21, 2012 4:58 am

In response to my previous post the non post-release-updates version worked for me too.

I can report one significant advantage to activitating it too. I am running this machine primarily as an HTPC and therefore my monitor is a TV (Panasonic plasma bought 5 years ago). The desktop never fit the screen, it was partially outside the viewing area and that was very annoying because I could only partially see the panel! I had tried changing my TV settings as per some threads I had read but nothing worked. Happily, activiting this driver has fixed the problem and I can now see everthing, most importantly the whole "Panel" :D

Not only that but I can set a decent resolution and everything looks a whole lot nicer!

Level 1
Level 1
Posts: 2
Joined: Thu Aug 09, 2012 4:10 pm

Re: Mint 13: Problem activating ATI/AMD proprietary FGLRX dr

Postby Kreacher » Wed Aug 15, 2012 10:58 am

flugmint wrote:Here's what I did:

Using the command line (or synaptic):

Code: Select all

~$ sudo apt-get remove fglrx fglrx-amdcccle


Code: Select all

~$ sudo apt-get install fglrx-updates fglrx-amdcccle-updates

Then restart...

The "post release updates" should now be installed even though they won't show up under the "Additional Drivers" menu.

Code: Select all

sudo dpkg -l fgl*
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name             Version          Description
un  fglrx            <none>           (no description available)
un  fglrx-amdcccle   <none>           (no description available)
ii  fglrx-amdcccle-u 2:8.960-0ubuntu1 Catalyst Control Center for the AMD graphics acc
un  fglrx-control    <none>           (no description available)
un  fglrx-control-qt <none>           (no description available)
un  fglrx-driver     <none>           (no description available)
un  fglrx-glx        <none>           (no description available)
un  fglrx-kernel-sou <none>           (no description available)
un  fglrx-modaliases <none>           (no description available)
ii  fglrx-updates    2:8.960-0ubuntu1 Video driver for the AMD graphics accelerators

I'm running on a Thinkpad:
- Mint Maya Cinnamon
- Release 13 (maya) 64-bit)
- Kernel Linux 3.2.0-23-generic
- Intel® Core™2 Duo CPU P8700 @ 2.53GHz × 2
- ATI Mobility Radeon HD 3400 Series

I haven't noticed a great deal of improvement on screen in terms of graphics over the Ubuntu/Mint/Linux ATI drivers, and there are even the very occassional few flickers etc. with the proprietary ATI drivers (as well as the documented issues with "screen shot" not working, and a problem with killing the X-Server using CTRL+ALT+BKSP... but not when selecting "Log Out" from the menu).

For me, however, the big advantage was the reduction in power consumption and CPU tolling which dropped dramatically.


Thank you very much for thsi tip, it worked great!

Level 1
Level 1
Posts: 4
Joined: Wed Nov 30, 2011 9:57 am

Re: Mint 13: Problem activating ATI/AMD proprietary FGLRX dr

Postby sagarthegreat1 » Thu Sep 06, 2012 1:59 pm

Guys it seems that the drivers get downloaded, but do not get root privileges while installing.
manually starting installation works.
enter this command in terminal

Code: Select all

nautilus /var/cache/apt/archives/

in the window that opens, double click on the file starting with fglrx-... (around 39 mb in size)
It will open in package installer.
Choose either Install or reinstall(whichever one is present), enter the root passwor and you are good to go!


Re: Mint 13: Problem activating ATI/AMD proprietary FGLRX dr

Postby infoleather » Tue Sep 11, 2012 9:40 am

I installed from the AMD website and run in a terminal, what not to do, until the restart, then wow, I can see the way of the mint, I think.

Level 1
Level 1
Posts: 3
Joined: Wed Mar 13, 2013 1:38 am

Re: Mint 13: Problem activating ATI/AMD proprietary FGLRX dr

Postby darknight44 » Wed Mar 13, 2013 1:46 am

sudo dpkg -l fgl* is the key..if you get 'nothing found' you arent running it.

SOMEONE needs to STICKY this in an AMD/ATI forum area.
Restart from the top if you get that.

I noticed something from when I initially installed(posted on a SUSE forum page). ANY NON-ZERO erro means your kernel and sources DO NOT MATCH.
You need to install as appropriate and try these steps again. I had serious VirtualBox issue due to installing a optimized RT kernel due to this. So a heads up if using different than the stock kernel installed by default. (I like bleeding edge from, but cant use it.)

If you can build the FGLRX sources from /usr/src with ZERO as an exit code, you should be fine.

this is the correct line:

sudo dpkg -l fglrx
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
rc fglrx 2:12.100~bet i386 Video driver for the AMD graphics

Return to “Hardware Support”

Who is online

Users browsing this forum: kc1di and 35 guests