ASUS R701V laptop

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
davoje
Level 1
Level 1
Posts: 1
Joined: Sat Jun 09, 2012 6:52 am

ASUS R701V laptop

Post by davoje »

Hi

I've seen a couple of really useful posts about experiences with new laptops and I'd like to add mine hoping someone else finds it useful.

I bought a new ASUS R701V (AKA N76VM) in Australia the other day (bleeding edge 3rd gen i7) and had some pain initially getting a version of linux on it. For people reading this wondering what they've got themselves into, don't panic, you haven't done your dough..

I first tried debian mint which installed ok but the screen was shifted about 10% to the right and lapped around to the left with some messy artifacts both ends. I actually found this fixed itself if you shut the lid for a minute and then opened it again :-) But worse was no ethernet or wireless networks showing up.

The wireless is Intel and the ethernet is Atheros which threw me for a while as I only know Atheros wireless stuff and searches on the 'net always turned up wireless info..

Code: Select all

# lspci
00:00.0 Host bridge: Intel Corporation Ivy Bridge DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Ivy Bridge PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation Panther Point USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation Panther Point MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation Panther Point High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 2 (rev c4)
00:1c.3 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Panther Point LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation Panther Point 6 port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation Panther Point SMBus Controller (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation Device 0de9 (rev a1)
03:00.0 Network controller: Intel Corporation Centrino Wireless-N 2230 (rev c4)
04:00.0 Ethernet controller: Atheros Communications Inc. AR8161 Gigabit Ethernet (rev 08)
I got around that using an external usb wireless card and eventually noticed in "dmesg" output that the intel wireless adaptor needed some firmware "iwlwifi-2030-5.ucode". I eventually found iwlwifi-2030-6.ucode on the http://intellinuxwireless.org/?n=Downloads site (Thanks Folks!) and put that in /lib/firmware, rebooted and the intel wifi card started working.

In the process of trying to get this laptop working, I tried installing:

Fedora core 17 (I couldn't get a USB boot image to work at all using dd, ubootln or usb-disk-image (I think it was called).

OpenSuse 12 which wedged severly at two different points in the install

Ubuntu 12.4 which would probably have been ok (the intel card worked out of the box) but I can't stand Unity.

Finally, Linux Mint (maya) installed cleanly and the Intel wireless worked properly, I didn't need to open and close the lid to get a decent screen :-) and after some updates and reboots, the sound card started to work (bonus) if only in analogue mode!

I'm still working on the following:

Atheros AR8161 Gigabit Ethernet: The biggest issue at the moment
[ edit ]
I got this working by following this guide. I had to use the exact source tree used in the article as later tarballs didn't seem to have the alx driver..
http://www.jfdesignnet.com/?p=2133
[ edit ]

Nvidia GT630M drivers: This is confusing as it looks like the Intel ivy bridge is doing all the work at the moment. I haven't tried HDMI or VGA output yet.
[ edit ]
I've learnt that the video on this laptop uses "Optimus" technology where a low power video card does most of the work but a high power card can be used when needed. For Linux support, you need to use code from the bumblebee project (https://wiki.archlinux.org/index.php/Bumblebee). I'm still a bit confused as to how this works though. From what I can tell, it's made little or no difference in practice.

VGA output works fine and I'm able to use twinview.
[ end edit ]

Digital sound: Sub woofer is not working with the analogue outputs

Some function keys are not working

Maybe more stuff later..

If anyone can help with any of the above, I'd appreciate a heads up. I'm too old to waste time re-inventing wheels..

Anyhow, a big thanks to the team! I have to say I was starting to panic a while back as I'd already trashed the Windows partition in my arrogance :-) I still paid the Microsoft tax though. That's 5 laptops I've bought now that I have been forced to pay for Microsoft licences which I never used and never intended to use.. But that's another story I guess..

It looks at the moment that Linux Mint (maya) is the best distribution for this laptop. I've got Ubuntu installed as well but I think I've had enough doing battle with the new interface so I'm a convert...

ciao
dave
davidbarton
Level 1
Level 1
Posts: 1
Joined: Tue Jun 26, 2012 3:21 am

Re: ASUS R701V laptop

Post by davidbarton »

Hi Dave,

Did you ever get the HDMI output working? I was running the same laptop on Ubuntu 12.04 which should be pretty similar to Mint and it would not even detect external monitors when running on the Intel drivers. As a result, I returned the laptop since I had specified that it couldn't have Optimus before purchasing.

So far I've had 2 laptops running Optimus and neither have been able to use external monitors. This is a serious dealbreaker for me, but all the top end laptops now ship with Optimus, so what options do I have?

Regards, Another Dave
quietchaos1
Level 1
Level 1
Posts: 1
Joined: Fri Jul 13, 2012 10:16 pm

Re: ASUS R701V laptop

Post by quietchaos1 »

I registered an account just to say thank you for all your helpful information!

I recently purchased an ASUS U47A and have most of the issue you have described here.
processor: Intel Core i5 - 3210M, 2.5GHz (3rd generation, 64-bit)
graphics: Intel Corporation Ivy Bridge Graphics Controller [8086:0166] (rev09)
wireless: Atheros Communications Device [1969:1083] (rev c0)
I have been working spare hours during the night for two weeks fighting distro installation, wireless, and display issues.

Thank you for the open and close lid trick to fix my offset/shifted/misaligned/wrapping issue with the screen. Have you managed to find a real fix for this hack, or understand the root issue for why this is occurring?

As for the issues installing distros, the fix I used to finally install Linux Mint Debian Edition without the install hanging/freezing on copying files was to create a partition table during the install process. Apparently, you have to re-create the parition table each time you attempt to install from the live cd...

It is a little difficult finding fixes for the somewhat-newer hardware.

Please keep us updated. I will do the same.

Thanks!
Jesse.Denton
Level 1
Level 1
Posts: 1
Joined: Wed Jun 19, 2013 7:39 pm

Re: ASUS R701V laptop

Post by Jesse.Denton »

Hi Dave,

I too registered an account to comment here,

I have the same model laptop as you, also from Australia, and have been struggling to get past the black screen after the inital boot from my DVD.
I'm installing Linux mint 14.1 cinnamon 64bit and am fairly new at this. Have installed other distro's on other laptops before but this one is by far the most confusing.
Wondering if you can point me in any direction as to how you managed to get past this, any command strings that need to be added to the install?

Cheers
Jesse
Post Reply

Return to “Hardware Support”