Failed to lock hardware DVD eject button

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 1
Joined: Thu Oct 11, 2012 11:10 am

Failed to lock hardware DVD eject button

Postby kixunil » Thu Oct 11, 2012 11:17 am


I've upgraded from Ubuntu 10.10 to LM Maya (With Mate Desktop). On Ubuntu 10.10 I was able to lock DVD hardware button using eject -i 1 (and unlock with eject -i 0), so my drive doesn't accidentally open. After upgrade, this stopped work. I've tried eject -i 1 /dev/sr0, echo 1 > /proc/sys/dev/cdrom/lock and little C program which uses ioctl. Everything failed - I'm still able to open door using HW button.

Any ideas?


Level 4
Level 4
Posts: 270
Joined: Fri May 25, 2012 5:22 pm

Re: Failed to lock hardware DVD eject button

Postby stratus_ss » Thu Oct 11, 2012 12:16 pm

Thats an interesting problem.

I can confirm that despite the man pages eject -i on does not prevent the drive from being opened (regardless of the fact that the ouput says "CD-Drive may NOT be ejected with device button")

I dont have any specific suggestions though

Level 17
Level 17
Posts: 7645
Joined: Fri May 09, 2008 1:14 pm

Re: Failed to lock hardware DVD eject button

Postby remoulder » Thu Oct 11, 2012 2:28 pm

[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.

Return to “Hardware Support”