Multimedia keyboard keys dont work

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
shiznatix
Level 1
Level 1
Posts: 14
Joined: Mon Oct 15, 2012 5:42 am

Multimedia keyboard keys dont work

Post by shiznatix »

I just installed Mint 13 MATE after failing to get Cinnamon to work the way I wanted. MATE has so far been kicking butt but with 1 issue that I can't figure out.

I have a Logitech multimedia keyboard. Basically, a keyboard with a Stop, Play/Pause, Volume, and Fwd/Back buttons. These buttons have worked on every OS I have ever tried, from Ubuntu to Debian to Mint 13 (with Cinnamon) but they have issues with MATE.

The volume buttons work just fine, no issues. But for some reason the rest of the buttons do nothing. When I hit the "next" button, neither Totem or Banshee will actuall skip to the next anything. Banshee will flicker a bit, so I know the keyboard input is being detected but that is as far as I can get. I have checked and tried to re-assign the keyboard shortcuts under the GUI menu but they all show correctly.

Am I missing something here to get Banshee / Totem to listen to these inputs? How can I get these working properly?

Also, when I press the calculator button on my keyboard it tries to launch gcalctool which doesn't exist (mate-calc is the calculator tool here). How can I change the program that is launched when that is pressed?

User avatar
xenopeek
Level 24
Level 24
Posts: 24674
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Multimedia keyboard keys dont work

Post by xenopeek »

The multimedia keys work fine, it is just that your programs are written for Gnome 2 namespace and MATE has a different namespace. So it looks like the keys don't work, while if fact it is just your programs ignoring the keys. You can work around this easily, until such time that programmers will also write programs to be compatible with MATE. The easy workaround is here: http://forums.linuxmint.com/viewtopic.p ... 20#p630136
Image

shiznatix
Level 1
Level 1
Posts: 14
Joined: Mon Oct 15, 2012 5:42 am

Re: Multimedia keyboard keys dont work

Post by shiznatix »

Thanks! That little script worked perfectly for the media keys.

But the last thing, is there a way to make the calculator key open the mate-calc program instead of the gcalctool?

User avatar
xenopeek
Level 24
Level 24
Posts: 24674
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Multimedia keyboard keys dont work

Post by xenopeek »

In the Keyboard Shortcuts program you can define what program gets started when you press the calculator button. The shortcut name for that button is "XF86Calculator", and by default the action is "Launch calculator".

I'm not sure how the "Launch calculator" action is configured, but what you can do is click the text "XF86Calculator" next to the "Launch calculator" action and press the Backspace key. This will disable that shortcut. Then press the Add button and add a new shortcut for mate-calc. After adding it, find it at the end of the list again and again click the text to the right of it to configure its shortcut. Press the calculator key on your keyboard and you should be set.
Image

squeezy
Level 5
Level 5
Posts: 557
Joined: Thu Feb 23, 2012 2:05 pm
Location: The Land of Enchantment

Re: Multimedia keyboard keys dont work

Post by squeezy »

shiznatix wrote:Thanks! That little script worked perfectly for the media keys.

But the last thing, is there a way to make the calculator key open the mate-calc program instead of the gcalctool?
+1 on the mmkeys script! It does work just fine for Banshee.

Are you still using MATE 1.2? In MATE 1.4 I found the Calculator button works out of the box to launch mate-calc.

shiznatix
Level 1
Level 1
Posts: 14
Joined: Mon Oct 15, 2012 5:42 am

Re: Multimedia keyboard keys dont work

Post by shiznatix »

xenopeek: Thanks, that worked perfect.
squeezy: I am sure I am running the latest everything, just double checked. Had to go with the fix but the fix was easy and now all works.

Steamix
Level 1
Level 1
Posts: 7
Joined: Fri Dec 14, 2012 6:23 am

Re: Multimedia keyboard keys dont work

Post by Steamix »

I have a ducky keyboard that comes with 4 mmkeys: calc, home folder (aka explorer), e-mail and browser. What's interesting is that all of them work except for home folder. I tried the steps you have given, Vincent, but couldn't go beyond deleting the "x86explorer" command. Probably I'm not doing something right. I'll be searching for a solution still, but if anyone could give any hints in the meantime they will be greatly appreciated.

update* please disregard the message. I have found the solution. I just double clicked the "x86explorer" line and was prompted to input a new key. I was pleasantly surprised to find the MM button recognized when I pressed it.

User avatar
xenopeek
Level 24
Level 24
Posts: 24674
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Multimedia keyboard keys dont work

Post by xenopeek »

Steamix wrote:I have a ducky keyboard that comes with 4 mmkeys: calc, home folder (aka explorer), e-mail and browser.
Those aren't multimedia keys. Play/Pause, Previous Track, Next Track, those are the multimedia keys. Yours are just shortcuts :wink:
Image

Post Reply

Return to “Hardware Support”