Page 1 of 1

How to set higher res, was: Sup. regr. S3 Unichrome

Posted: Mon Nov 05, 2012 1:50 am
by Solar
DISCLAIMER: I have administrated Linux boxes for many years now, but X11 has always been a notoriously murky corner of the system in my eyes, so please excuse if I sound like a complete noob.

I have a laptop of the Acer Aspire 1360 series here, with a S3 Unichrome Pro graphics chip. I've been running Linux Mint 10 on it for quite some time, without (m)any problems.

Since Mint 10 support has run out and I am updating my machines to the Mint 13 LTS release, I tried installing Mint 13 on this box. However, it does not detect the display correctly, limiting me to 800x600 (instead of the full 1024x768). While trying to figure out what went wrong and how to fix it, probing showed that X11 complains about /usr/lib/dri/ missing.

Reinstalling the Mint 10 setup from backup, I found that this file /usr/lib/dri/ was previously provided by the package libgl1-mesa-dri. This is apparently no longer the case.

Support for the S3 Unichrome Pro cannot been discontinued, as the 2D driver (/usr/lib/xorg/modules/drivers/ is still provided (by xserver-xorg-video-openchrome).

So, 1) how do I get X11 to run the display at full 1024x768 resolution, and 2) how do I get my hands on a working DRI driver?

Using the old xorg.conf from Mint 10 didn't work. I also tried getting the 1024x768 modline from the Mint 10 setup via cvt and running xrandr -newmode / -addmode, but setting the new mode via xrandr resulted in the (too-small) display flickering once and remaining as it were.

As I said up front, X11 isn't my strong side, so I am a bit lost here...?!?

Re: Support regression S3 Unichrome Pro?

Posted: Mon Nov 05, 2012 6:24 am
by Solar
OK, one part of the question has been answered:

From the Mesa3D 8.0 release notes:
Removed all DRI drivers that did not support DRI2. Specifically, i810, mach64, mga, r128, savage, sis, tdfx, and unichrome were removed.
So, I'll rephrase:

1) Why does the 2D driver still look for the DRI/3D driver if it's no longer supported, and,

2) How do I set the display resolution to 1024x768?