pendrive unable to mount.........!

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
enator24
Level 1
Level 1
Posts: 11
Joined: Fri Apr 25, 2008 3:01 pm

pendrive unable to mount.........!

Postby enator24 » Fri Apr 25, 2008 3:37 pm

hi when ever i try to mount my my pendrive it shows message "Invalid mount option when attempting to mount the volume".i tried to mount using partition editor but it gives the option to mount on "media/cdrom0".if mounted it does not allows to write any thing in.restricting the write permission..............plz help me.

User avatar
67GTA
Level 6
Level 6
Posts: 1303
Joined: Wed Jun 06, 2007 9:49 pm
Location: Kentucky, USA

Re: pendrive unable to mount.........!

Postby 67GTA » Fri Apr 25, 2008 7:08 pm

Try running

Code: Select all

sudo rmmod ehci_hcd
in a terminal and try mounting it again. If that doesn't work then run

Code: Select all

sudo modprobe ehci_hcd
to undo the first command.
"The only thing necessary for the triumph of evil is for good men to do nothing." Edmund Burke

enator24
Level 1
Level 1
Posts: 11
Joined: Fri Apr 25, 2008 3:01 pm

Re: pendrive unable to mount.........!

Postby enator24 » Sat Apr 26, 2008 7:19 am

SORRY IT FAILED TO..............SHOWS THE SAME PROBLEM.

User avatar
67GTA
Level 6
Level 6
Posts: 1303
Joined: Wed Jun 06, 2007 9:49 pm
Location: Kentucky, USA

Re: pendrive unable to mount.........!

Postby 67GTA » Sat Apr 26, 2008 9:28 am

What brand/model is it? Has it been formatted?
"The only thing necessary for the triumph of evil is for good men to do nothing." Edmund Burke

enator24
Level 1
Level 1
Posts: 11
Joined: Fri Apr 25, 2008 3:01 pm

Re: pendrive unable to mount.........!

Postby enator24 » Sat Apr 26, 2008 12:55 pm

its kingston data traveler 4gb pendrive formated in fat 32,i tried to use it with ext3 but result was same .the same pen drive works well on debian ,on the same system that is dual booted with mint.after logging in as root i selected the mount option it shows mount point as "/media/cdrom0" after selecting this option it works well ,as root user bu doesn't allows write access as a general user.Changing permission also doesn't works,doing this every time is realy a punishment............is there any way out???????????????????????????

User avatar
67GTA
Level 6
Level 6
Posts: 1303
Joined: Wed Jun 06, 2007 9:49 pm
Location: Kentucky, USA

Re: pendrive unable to mount.........!

Postby 67GTA » Sat Apr 26, 2008 1:04 pm

Plug it in, and then post the last 20-30 lines of output from

Code: Select all

dmesg
and also post a copy of your /etc/fstab file.
"The only thing necessary for the triumph of evil is for good men to do nothing." Edmund Burke

enator24
Level 1
Level 1
Posts: 11
Joined: Fri Apr 25, 2008 3:01 pm

Re: pendrive unable to mount.........!

Postby enator24 » Sat Apr 26, 2008 1:57 pm

hey this is the information:-


[20482.360000] usb 1-2: USB disconnect, address 6
[20487.728000] usb 5-2: new high speed USB device using ehci_hcd and address 5
[20487.868000] usb 5-2: configuration #1 chosen from 1 choice
[20487.868000] scsi8 : SCSI emulation for USB Mass Storage devices
[20487.872000] usb-storage: device found at 5
[20487.872000] usb-storage: waiting for device to settle before scanning
[20492.872000] usb-storage: device scan complete
[20492.872000] scsi 8:0:0:0: Direct-Access Kingston DataTraveler 2.0 PMAP PQ: 0 ANSI: 0 CCS
[20493.072000] sd 8:0:0:0: [sdb] 7823360 512-byte hardware sectors (4006 MB)
[20493.076000] sd 8:0:0:0: [sdb] Write Protect is off
[20493.076000] sd 8:0:0:0: [sdb] Mode Sense: 23 00 00 00
[20493.076000] sd 8:0:0:0: [sdb] Assuming drive cache: write through
[20493.076000] sd 8:0:0:0: [sdb] 7823360 512-byte hardware sectors (4006 MB)
[20493.076000] sd 8:0:0:0: [sdb] Write Protect is off
[20493.076000] sd 8:0:0:0: [sdb] Mode Sense: 23 00 00 00
[20493.076000] sd 8:0:0:0: [sdb] Assuming drive cache: write through
[20493.076000] sdb: sdb1
[20493.080000] sd 8:0:0:0: [sdb] Attached SCSI removable disk
[20493.080000] sd 8:0:0:0: Attached scsi generic sg2 type 0
[20494.936000] UDF-fs: No partition found (1)
[20494.980000] Unable to identify CD-ROM format.
[20880.948000] usb 5-2: USB disconnect, address 5
[20963.204000] usb 5-2: new high speed USB device using ehci_hcd and address 6
[20963.344000] usb 5-2: configuration #1 chosen from 1 choice
[20963.344000] scsi9 : SCSI emulation for USB Mass Storage devices
[20963.344000] usb-storage: device found at 6
[20963.344000] usb-storage: waiting for device to settle before scanning
[20968.344000] usb-storage: device scan complete
[20968.344000] scsi 9:0:0:0: Direct-Access Kingston DataTraveler 2.0 PMAP PQ: 0 ANSI: 0 CCS
[20968.548000] sd 9:0:0:0: [sdb] 7823360 512-byte hardware sectors (4006 MB)
[20968.548000] sd 9:0:0:0: [sdb] Write Protect is off
[20968.548000] sd 9:0:0:0: [sdb] Mode Sense: 23 00 00 00
[20968.548000] sd 9:0:0:0: [sdb] Assuming drive cache: write through
[20968.548000] sd 9:0:0:0: [sdb] 7823360 512-byte hardware sectors (4006 MB)
[20968.548000] sd 9:0:0:0: [sdb] Write Protect is off
[20968.548000] sd 9:0:0:0: [sdb] Mode Sense: 23 00 00 00
[20968.548000] sd 9:0:0:0: [sdb] Assuming drive cache: write through
[20968.548000] sdb: sdb1
[20968.552000] sd 9:0:0:0: [sdb] Attached SCSI removable disk
[20968.552000] sd 9:0:0:0: Attached scsi generic sg2 type 0
[20969.972000] UDF-fs: No partition found (1)
[20970.032000] Unable to identify CD-ROM format.
[21809.732000] usb 2-2: new low speed USB device using uhci_hcd and address 2
[21809.900000] usb 2-2: configuration #1 chosen from 1 choice
[21809.916000] input: USB Optical Mouse as /class/input/input8
[21809.916000] input: USB HID v1.10 Mouse [USB Optical Mouse] on usb-0000:00:1d.1-2
[22310.752000] sky2 eth0: Link is down.
[22594.132000] usb 5-2: USB disconnect, address 6
[24188.996000] UDF-fs: No VRS found
[24189.020000] ISO 9660 Extensions: Microsoft Joliet Level 3
[24189.108000] ISO 9660 Extensions: RRIP_1991A
[24367.284000] sky2 eth0: Link is up at 100 Mbps, full duplex, flow control both
[25024.796000] usb 5-2: new high speed USB device using ehci_hcd and address 8
[25024.936000] usb 5-2: configuration #1 chosen from 1 choice
[25024.936000] scsi10 : SCSI emulation for USB Mass Storage devices
[25024.936000] usb-storage: device found at 8
[25024.936000] usb-storage: waiting for device to settle before scanning
[25029.936000] usb-storage: device scan complete
[25029.936000] scsi 10:0:0:0: Direct-Access Kingston DataTraveler 2.0 PMAP PQ: 0 ANSI: 0 CCS
[25030.856000] sd 10:0:0:0: [sdb] 7823360 512-byte hardware sectors (4006 MB)
[25030.856000] sd 10:0:0:0: [sdb] Write Protect is off
[25030.856000] sd 10:0:0:0: [sdb] Mode Sense: 23 00 00 00
[25030.856000] sd 10:0:0:0: [sdb] Assuming drive cache: write through
[25030.864000] sd 10:0:0:0: [sdb] 7823360 512-byte hardware sectors (4006 MB)
[25030.864000] sd 10:0:0:0: [sdb] Write Protect is off
[25030.864000] sd 10:0:0:0: [sdb] Mode Sense: 23 00 00 00
[25030.864000] sd 10:0:0:0: [sdb] Assuming drive cache: write through
[25030.864000] sdb: sdb1
[25030.864000] sd 10:0:0:0: [sdb] Attached SCSI removable disk
[25030.864000] sd 10:0:0:0: Attached scsi generic sg2 type 0
[25034.300000] UDF-fs: No partition found (1)
[25034.344000] Unable to identify CD-ROM format.
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
this is the fstab file

/etc/fstab# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda1
UUID=0345ec8a-dacc-4ebc-acd5-050969913a65 / reiserfs notail 0 1
# /dev/sda10
UUID=6bf190d9-9bd0-4321-802a-008ab5bfd0da /media/sda10 reiserfs defaults 0 2
# /dev/sda5
UUID=6A60B9B660B98979 /media/sda5 ntfs defaults,umask=007,gid=46 0 1
# /dev/sda6
UUID=3CD4AF72D4AF2CD8 /media/sda6 ntfs defaults,umask=007,gid=46 0 1
# /dev/sda7
UUID=B8E88F8CE88F4818 /media/sda7 ntfs defaults,umask=007,gid=46 0 1
# /dev/sda9
UUID=2acf3fbc-70dc-48f1-966c-8e9e42e7f349 /media/sda9 reiserfs defaults 0 2
# /dev/sda8
UUID=3c2ec8f6-e7fd-4e36-b019-c171f7c092fe none swap sw 0 0
/dev/sdb1 /media/cdrom0 udf,iso9660 user,noauto,exec 0 0
/dev/scd0 /media/cdrom1 udf,iso9660 user,noauto,exec 0 0
Last edited by enator24 on Sat Apr 26, 2008 2:06 pm, edited 1 time in total.

User avatar
67GTA
Level 6
Level 6
Posts: 1303
Joined: Wed Jun 06, 2007 9:49 pm
Location: Kentucky, USA

Re: pendrive unable to mount.........!

Postby 67GTA » Sat Apr 26, 2008 2:06 pm

Post a copy of your /etc/fstab file.
"The only thing necessary for the triumph of evil is for good men to do nothing." Edmund Burke

enator24
Level 1
Level 1
Posts: 11
Joined: Fri Apr 25, 2008 3:01 pm

Re: pendrive unable to mount.........!

Postby enator24 » Sat Apr 26, 2008 10:47 pm

this is the fstab file

/etc/fstab# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda1
UUID=0345ec8a-dacc-4ebc-acd5-050969913a65 / reiserfs notail 0 1
# /dev/sda10
UUID=6bf190d9-9bd0-4321-802a-008ab5bfd0da /media/sda10 reiserfs defaults 0 2
# /dev/sda5
UUID=6A60B9B660B98979 /media/sda5 ntfs defaults,umask=007,gid=46 0 1
# /dev/sda6
UUID=3CD4AF72D4AF2CD8 /media/sda6 ntfs defaults,umask=007,gid=46 0 1
# /dev/sda7
UUID=B8E88F8CE88F4818 /media/sda7 ntfs defaults,umask=007,gid=46 0 1
# /dev/sda9
UUID=2acf3fbc-70dc-48f1-966c-8e9e42e7f349 /media/sda9 reiserfs defaults 0 2
# /dev/sda8
UUID=3c2ec8f6-e7fd-4e36-b019-c171f7c092fe none swap sw 0 0
/dev/sdb1 /media/cdrom0 udf,iso9660 user,noauto,exec 0 0
/dev/scd0 /media/cdrom1 udf,iso9660 user,noauto,exec 0 0

User avatar
67GTA
Level 6
Level 6
Posts: 1303
Joined: Wed Jun 06, 2007 9:49 pm
Location: Kentucky, USA

Re: pendrive unable to mount.........!

Postby 67GTA » Sun Apr 27, 2008 11:02 am

It looks like fstab has it listed as a cdrom. Delete this line from fstab, reboot, and try it again.

/dev/sdb1 /media/cdrom0 udf,iso9660 user,noauto,exec 0 0
"The only thing necessary for the triumph of evil is for good men to do nothing." Edmund Burke

enator24
Level 1
Level 1
Posts: 11
Joined: Fri Apr 25, 2008 3:01 pm

Re: pendrive unable to mount.........!

Postby enator24 » Sun Apr 27, 2008 9:22 pm

sorry no change ,ithink it happened socoz i used my pen drive as live cd to to install mint. what should be a suitable mount option.

enator24
Level 1
Level 1
Posts: 11
Joined: Fri Apr 25, 2008 3:01 pm

Re: pendrive unable to mount.........!

Postby enator24 » Mon Apr 28, 2008 6:41 am

hey my pen drive now easily mounts at root login but as general user ,shows in popup "mount_point cannot contain the following characters :newline,G_DIR_SEPARATOR(USUALLY /)
SO WAT TO DO .......?

User avatar
67GTA
Level 6
Level 6
Posts: 1303
Joined: Wed Jun 06, 2007 9:49 pm
Location: Kentucky, USA

Re: pendrive unable to mount.........!

Postby 67GTA » Mon Apr 28, 2008 2:36 pm

I'm not sure what is happening. One suggestion would be to try and reformat it, and try again. I have heard of some USB sticks with U3 capability trying to mount as a CD. Yours might be one of those. Also check the properties(right click on icon) after plugging it in to see if anything looks funny.
"The only thing necessary for the triumph of evil is for good men to do nothing." Edmund Burke

enator24
Level 1
Level 1
Posts: 11
Joined: Fri Apr 25, 2008 3:01 pm

Re: pendrive unable to mount.........!

Postby enator24 » Fri May 02, 2008 12:42 am

hey i am now out of the trouble , after deleting the entry from fstab ,i created a new desktop user account and pendrie auto mounted , but that particular account is still having the same problem.............any way thanks for ur support 67GTA


Return to “Hardware Support”

Who is online

Users browsing this forum: Laurent85 and 11 guests