Atheros AR5006EG: no scan results

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 1
Joined: Sun May 04, 2008 5:47 am

Atheros AR5006EG: no scan results

Postby Rita » Sun May 04, 2008 6:03 am

Hi all!

I just approached Linux Mint, and I find it a magic distro! It gave me no problems at all, except...

I know this topic has been discussed in many forums, but I still can't find a solution.
I have a Fujitsu-Siemens Amilo Li1718, with an Atheros AR5006EG wireless card. I googled to see how to make it work and I found 2 main solutions:
1. Use ndiswrapper
2. Use the latest snapshot of Madwifi-NG ( ... tform.html).

I tried both the solutions, and both seem to work: in fact my wifi is correctly detected as ath0; here are some outputs:

Code: Select all

rita@ebony:~$ lsmod | grep ath
ath_pci               114728  0
ath_rate_sample        15232  1
ath_hal               280544  3 ath_pci,ath_rate_sample
wlan                  211248  5 ath_pci,wlan_wep,wlan_scan_sta,ath_rate_sample

Code: Select all

rita@ebony:~$ ifconfig ath0
ath0      Link encap:Ethernet  HWaddr 00:C0:A8:FD:B6:3E 
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

Code: Select all

rita@ebony:~$ iwconfig ath0
ath0      IEEE 802.11g  ESSID:""  Nickname:""
          Mode:Managed  Frequency:2.437 GHz  Access Point: Not-Associated   
          Bit Rate:0 kb/s   Tx-Power:16 dBm   Sensitivity=1/1 
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=0/70  Signal level=-256 dBm  Noise level=-256 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

But the problem is:

Code: Select all

rita@ebony:~$ iwlist ath0 scan
ath0      No scan results

The wifi should see two access points instead, in fact on Windows I see them both.
I read somewhere on the net that probably the kill switch is off, so the possible solution is to activate it by default from the BIOS. I tried that to, but without any success. Any suggestions? Thank you! :)

User avatar
Level 4
Level 4
Posts: 294
Joined: Sun Mar 02, 2008 6:44 pm
Location: Laramie, WY

Re: Atheros AR5006EG: no scan results

Postby jokersloose » Sun May 04, 2008 7:36 pm


I installed Mint on a HP laptop that had the 5007 chipset. Now from what I found when trying to get the wireless too work is that sometimes the lspci -v gives you the wrong chip set. So I use: ... tform.html followed the direction to the letter and bang had wireless. Now sometimes, just sometimes you do have to re-enter the last 3 command lines because it drops off the map per say.

Hope this helps.


Return to “Hardware Support”

Who is online

Users browsing this forum: No registered users and 5 guests