[Solved] ALPS detected PS/2 & Multitouch Gesture not working

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 4
Joined: Tue Jul 31, 2012 2:57 pm

[Solved] ALPS detected PS/2 & Multitouch Gesture not working

Post by jadelord »

I use a Dell Inspiron 5420 and it was so frustrating to use the laptop with Linux until I figured out how to use. A lot of forums discuss this as a Kernel bug, but it is bullshit.
The solution may have been posted before, but here are the instructions in full clarity.

For ease save the following in a .sh script file, using any text editor, make it executable by going to 'Properties' and run the file:

Code: Select all

cd /usr/src/
sudo wget http://www.dahetral.com/public-download/psmouse-alps-dst-1.2.tbz
sudo tar jxvf ./psmouse-alps-dst-1.2.tbz -C /
cd /usr/src/psmouse-alps-dst-1.2
sudo dkms add .
sudo dkms build -m psmouse -v alps-dst-1.2
sudo dkms install -m psmouse -v alps-dst-1.2
sudo modprobe psmouse
echo -n "Installation complete"
read text
OR you could run the commands one by one.

I found the solution here http://askubuntu.com/questions/154770/a ... multitouch
which leads to the sites.
https://bugs.launchpad.net/ubuntu/+sour ... mments/152
https://bugs.launchpad.net/ubuntu/+sour ... mments/147
https://bugs.launchpad.net/ubuntu/+sour ... mments/144

Level 1
Level 1
Posts: 11
Joined: Fri Oct 26, 2012 5:11 pm

Re: [Solved] ALPS detected PS/2 & Multitouch Gesture not wor

Post by cipri_tom »

I do not know how to thank you enough for this.
It worked on my Dell N5110. Now I have scrolling! :D either two finger or on the edge. Brilliant! Thanks again!

Although I set my sensivity at maximum, the touchpad doesn't seem to be as responsive as before. maybe it's just me. What I mean is that it doesn't react if the area is not large enough, like using just the tip of the finger...
But anyway, I'm so happy I have the scrolling!

Post Reply

Return to “Hardware Support”