Page 1 of 1

Bluetooth dongle + Nadia. Please help

Posted: Tue Jan 08, 2013 2:20 am
by lagranvaca
Hi guys,

I've got an usb bluetooth dongle with a Cambridge Silicon Radio chipset, which seems to be very problematic. I got a lot of freezes (the machine locks up completely) and I can't get it to work properly. I give up. I've been reading about several bugs with this chipset, but not everybody suffer them.
Anyway. I'm going to buy a new dongle with another chipset (atheros, broadcom, etc) but I'm not sure which one will work fine.
So please, anybody with an usb bluetooth dongle working properly with Nadia? What chipset are you using?

Thanks in advance

Re: Bluetooth dongle + Nadia. Please help

Posted: Wed Jan 09, 2013 5:54 pm
by lagranvaca
Anybody with a working bluetooth dongle?

Re: Bluetooth dongle + Nadia. Please help

Posted: Fri Jan 11, 2013 3:11 am
by basilwatson
sorry Ive got the same problem

My secs are

Asus K53t
s@s-K53TK ~ $ lsusb
Bus 001 Device 003: ID 04f2:b23b Chicony Electronics Co., Ltd
Bus 002 Device 003: ID 12cf:3003
Bus 003 Device 004: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
s@s-K53TK ~ $ rfkill list all
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
2: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

hci0: Type: BR/EDR Bus: USB
BD Address: 00:1B:41:06:0A:23 ACL MTU: 310:10 SCO MTU: 64:8
UP RUNNING PSCAN ISCAN
RX bytes:34239 acl:86 sco:0 events:433 errors:0
TX bytes:28608 acl:177 sco:0 commands:108 errors:0

it seems to be an up steteam bug on ubuntu side , but I also cannot find any help , other than downgrade ,,,,,,

Stephen

Re: Bluetooth dongle + Nadia. Please help

Posted: Fri Jan 11, 2013 6:28 pm
by lagranvaca
Hi Stephen,

Thanks for the feedback. I'm thinking about buying a broadcom bluetooth adapter... it's cheap

Re: Bluetooth dongle + Nadia. Please help

Posted: Fri Jan 11, 2013 6:45 pm
by jungle_boy
I have the same bluetooth dongle.

Code: Select all

Bus 001 Device 003: ID 0c45:62c0 Microdia Sonix USB 2.0 Camera
Bus 002 Device 002: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Attention:

This bluetooth dongle works fine in LM13 KDE.

In MATE edition and Cinnamon edition, sometimes I can not send files from PC to cell-phone (for example), and NEVER can send files to PC...

I think the problem is not in bluetooth but in Linuxmint...

Re: Bluetooth dongle + Nadia. Please help

Posted: Sat Jan 12, 2013 2:34 am
by lagranvaca
jungle_boy wrote: I think the problem is not in bluetooth but in Linuxmint...
There are at least two reported bugs in ubuntu:
https://bugs.launchpad.net/ubuntu/+sour ... bug/930848
https://bugs.launchpad.net/ubuntu/+sour ... bug/460743

Don't know if only affects 64bit arch (which is my case) or whatever

Re: Bluetooth dongle + Nadia. Please help

Posted: Sun Jan 13, 2013 10:26 am
by jungle_boy
I repeat: it works fine in LM13 KDE, sending and receiving files for/to PC/phone-cell...

Re: Bluetooth dongle + Nadia. Please help

Posted: Wed Jan 16, 2013 5:00 am
by clatterfordslim
Hi I am having problems with a bluesoleil bluetooth dongle, it works in windows as everything for windows is there for you automatically. The problem I am having though, is that it is not being recognised at all when plugged into linux mint 13 64bit. I used to have ubuntu 11.10 and it worked fine, now all I get is this when I try lsusb.
lsusb.png
lsusb.png (47.66 KiB) Viewed 2014 times
Now the only thing that comes up is Bus 002 Device 004: ID 0c10:0000 which is the dongle, but if it was being recognised it would have the full name surely? What is going on? I have tried uninstalling all bluetooth stuff from synaptic and re-installing, but to no avail, does anyone out there have the answer?

Re: Bluetooth dongle + Nadia. Please help

Posted: Sat Jan 19, 2013 3:05 pm
by lagranvaca
Mark, I really don't know what's happening in your case.
I would like to comment that I've bought another cambridge silicon radio dongle (I bout it cause I thought it was a broadcom!!) and surprisingly it works!!! Same chipset, but different dongle brand did the trick...

Re: Bluetooth dongle + Nadia. Please help

Posted: Sat Jan 19, 2013 3:08 pm
by lagranvaca
Mark, same problem (and apparently solved) here: http://ubuntuforums.org/archive/index.php/t-943133.html