Page 1 of 1

Lenovo W530 with docking station

Posted: Sat Feb 09, 2013 3:48 pm
by MakOwner
I have a Lenovo T61 that is being replaced with a W530.
I ran Mate 13 and 14 on the T61 and both versions of MAte would find the external monito connected to the dock with no issues.

I loaded 14 onto the W530 and I can't get the exteranl montor to work.
There are three graphics options in the Bios for the W530, and I currently have the "Discrete" option selectedas that alllows me to select one of the ports on the dock for boot up screen, however, while that does allow you to see the initial boot-splash, you see nother after the grub menu. The screen just shuts down.

I have booted a Mate 13 and tried to run the hardware driver discovery thing that is gone in 14, but it doesn't find anything.

I desparately need to make this work by Monday in order to make the decison on which laptop to return - the old one or the new one.

Edit: one other thing - in Mate 14 I installed the nvidia-current package. That installed the drivers, but tehy weren't enabled and the nvidia config utilty didn't recognize them being in use -- and the result of running nvidia-xconfig was that nvidia can't find the running xconfg and writes out a new one that causes 640x480 resolution ont he next boot...

Re: Lenovo W530 with docking station

Posted: Sun Feb 10, 2013 12:47 am
by MakOwner
What a trip. I have been able to get an external display working from the docking station - haven't tried the VGA port on the laptop yet.

Install with the BIOS setting for Graphics set to "Discrete" with the optimus option disabled.
Disable both Virtuliztion options.
After installing, do all your updates and set "nox2apic" in the grub command line (I set it as the first parameter in mine).
At this point you should be able to set up the dock connected monitor, and enable the nvidia proprietary drivers if you want.
After you get the installation stable and the video set like you like, if virtualization is important to you, you can try turning it back on after you ensure that you can boot with the nox2apic parameter.

Be careful as I have read reports where this ddin't work for some people - but it worked for me.