Arduino's virtual com1 has been broken

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 4
Joined: Sun Feb 10, 2013 5:32 am

Arduino's virtual com1 has been broken

Postby notransponder » Sun Feb 10, 2013 5:56 am

The Arduino Integrated Development Environment (IDE) uses a virtual com1: definition via usb to the arduino being programmed.
I am using an up to date Maya 64 bit install.
It appears that Linux Mint, certainly this version, no longer supports the definition of a com1:.
The instructions in the Arduino installation guide for this version have a command that no longer works.
" su -c 'usermod -aG dialout <username>' root "

Arduino uses a 2 step configuration to keep things simple. you identify the type of Arduino board, then tell the arduino ide where it is by tagging it to com1:
this hides all the protocol details and makes the arduino configuration quite simple.

If the demigods among the programmers have decided that com1 is to go the way of the dinosaurs, well and good.
could we please have an updated way of pointing the Arduino IDE to the USB cable that goes to the arduino board being programmed ?

in anticipation. many thanks from the arduino world.

Level 1
Level 1
Posts: 4
Joined: Sun Feb 10, 2013 5:32 am

Re:[Solved] Arduino's virtual com1 has been broken

Postby notransponder » Mon Feb 11, 2013 2:07 am

The arduino install for Linux Mint Maya64 uses apt-get to install the software.
that works well.
then it uses
su -c 'usermod -aG dialout <username>' root
to add you to a dialout group to get access to the virtual serial port.
then the instructions say...
type 'groups' and you should see something like
<username> dialout
If not, repeat the previous step.

that last line is the innocuous key to solving the configuration problem.
you type the command in again and the second time it actually executes.
this is really nice but can we have code that executes without the black magic of needing one's mouth held in a certain way? :D
can a guru offer a quick explanation of why the code executes differently on subsequent iterations?
the commands were typed in a fresh terminal window a day apart.
the upside of all this is that Linux Mint running on a Toshiba C850D laptop appears now to be totally error free and successfully replaces the nightmare of Windows 8.
now to play with the arduinos ....

Level 1
Level 1
Posts: 1
Joined: Sat Mar 30, 2013 9:31 am

Re: Arduino's virtual com1 has been broken

Postby menthaspicata » Sat Mar 30, 2013 10:23 am

Hi notransponder,
Even after ensuring my username was added to the dialout group, I was still blocked by the virtual COM1 configuration. Just in case it is of any use to anyone else, what worked for me (with Mint 14 Nadia, Arduino Mega2560 and arduino 1:1.0.1+dfsg) was the following brute force (it includes editing a package file) approach :-

Ensured that the dialout group included my username (as you reported).

In ~/.arduino/preferences.txt I edited :-
to :-

In /usr/share/arduino/hardware/arduino/programmers.txt, I hacked :-
to :-
(but this is changing a package file so NOT an ideal solution).

In arduino :
Tools -> Board -> Arduino Mega 2560 or Mega ADK
Tools -> Programmer -> AVRISP mkII
Compile sketch
File -> Upload Using Programmer

Return to “Hardware Support”