[Partially solved] No sound with USB DAC

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 11
Joined: Thu Mar 14, 2013 10:26 am

[Partially solved] No sound with USB DAC

Post by Picani » Thu Mar 14, 2013 10:58 am

Hi everybody !

I recently acquired an Audinst HUD-mx2. Most usb DAC in this price range are plug-and-play and use VIA, and his little brother, the HUD-mx1, is plug-and-play too, so I expected it to bee. But it's not really the case.

I mean it's correctly recognized by the system, appeared in Parameters -> Sound or pavucontrol and when playing a song (or any other sound from any other application), the indicator turns to green, meaning the device is active and receives a well PCM signal. But no sound comes from my headphones ...

I downloaded Live-USB of Ubuntu 12.10 and Fedora 18 and tried on an other PC running LinuxMint 13 Maya, and the problem is exactly the same. It's works fine on Windows 7

Here are some technicals (or not) informations :

I'm under LinuxMint 14 Nadia 64bits, cinnamon Edition. I use pulseaudio and Decibel Audio Player (but the result is the same with vlc or when playing video on youtube).

The Windows 7 is 32bits.

The HUD-mx2 uses a VIA Vinyl EnvyUSB 2.0 Audio Controller which is recognized by the kernel :

Code: Select all

$ dmesg | grep VIA
[ 1469.854456] usb 3-1: Manufacturer: VIA Technologies Inc.
[ 1470.064407] input: VIA Technologies Inc. Audinst HUD-mx2 as /devices/pci0000:00/0000:00:14.0/usb3/3-1/3-1:1.2/input/input10
[ 1470.064597] hid-generic 0003:040D:340F.0001: input,hidraw0: USB HID v1.00 Device [VIA Technologies Inc. Audinst HUD-mx2] on usb-0000:00:14.0-1/input2
When playing a song, the device is pretended to be correctly used :

Code: Select all

$ ls /proc/asound/
card0  cards    HUDmx2  modules  PCH  seq     version
card1  devices  hwdep   oss      pcm  timers

$ ls /proc/asound/HUDmx2
id  pcm0p  pcm1p  stream0  stream1  usbbus  usbid  usbmixer

$ cat /proc/asound/HUDmx2/stream0 
VIA Technologies Inc. Audinst HUD-mx2 at usb-0000:00:14.0-1, full speed : USB Audio

  Status: Running
    Interface = 1
    Altset = 1
    Packet Size = 192
    Momentary freq = 44100 Hz (0x2c.199a)
  Interface 1
    Altset 1
    Format: S16_LE
    Channels: 2
    Endpoint: 1 OUT (ADAPTIVE)
    Rates: 44100, 48000
I also mention that I tried my father's VDAC II and a NuForce Icon 2 and they both work fine, on LinuxMint 13, 14 and Windows 7.
I don't know what other information I should give. If you need, please ask.

Thanks a lot for helping me

[EDIT : changed the title in a more informative way]
Last edited by Picani on Sat Mar 16, 2013 4:29 am, edited 1 time in total.

Level 1
Level 1
Posts: 11
Joined: Thu Mar 14, 2013 10:26 am

Re: No sound with external sound card

Post by Picani » Thu Mar 14, 2013 4:51 pm

I've just got a alternative solution. When using Audacious with ALSA out instead of pulseaudio, configuring to use hw:1,1 it works.

Does anyone know what's happening ? And how to make pulseaudio works ? It's more convenient to use ... :oops:

Level 1
Level 1
Posts: 1
Joined: Mon Mar 17, 2014 3:49 am

Re: [Partially solved] No sound with USB DAC

Post by unnecessary » Mon Mar 17, 2014 3:55 am

I solved similar problem in HUDmini by editing /etc/pulse/default.pa

Code: Select all

### Make some devices default
set-default-sink output hw:CARD=HUDmini,DEV=1
Output device you should get:

Code: Select all

aplay -L

User avatar
Pilosopong Tasyo
Level 6
Level 6
Posts: 1436
Joined: Mon Jun 22, 2009 3:26 am
Location: Philippines

Re: [Partially solved] No sound with USB DAC

Post by Pilosopong Tasyo » Mon Mar 17, 2014 4:14 am

Back to sleep, old thread. Rest in the annals of Linux Mint forum history. Thread locked as per §2.2 ¶2 of the Forum Rules, Guidelines, and Policy.
o Give a man a fish and he will eat for a day. Teach him how to fish and he will eat for a lifetime!
o If an issue has been fixed, please edit your first post and add the word [SOLVED].


Return to “Hardware Support”