Nvidia Geforce 7900

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
curranlfc
Level 1
Level 1
Posts: 9
Joined: Tue Apr 30, 2013 8:59 am

Nvidia Geforce 7900

Post by curranlfc »

Hello, I have Mint 14 (Cinnamon) installed on my old Athlon 64 system. Everything works as it should except for display. Menus lag and dragging windows is also laggy - also items in the cinnamon menu disappear when I move the mouse over. I searched the web and these forums for my problem but cannot find anything.

I have been into Menu > Preferences > Software Sources and tried all the available drivers listed.

When I change the driver, I let the software sources install and do what it is doing, then on the next boot I get a message (may not be exactly as it's displayed) Failed to connect to X server do you want to view the log to debug? If I choose yes, I get a log file and at the bottom I get Display not detected.

The motherboard has a built in nvidia Quatro display (not in use, however cannot be disabled in bios anywhere).

I THINK the built in vga may be causing this problem but not sure. I have mint 14 on two of my laptops and it runs beautifully and also on a few friends desktops and also no problem. I don't use the computer for gaming and normally It would not bother me having a generic driver installed, it's just the lag that bugs me. I am sure the hardware is capable to run Mint as one of my laptops has worse specs than this system but is noticeably smoother. Thanks in advance for any help.

System: AMD Athlon 64 3700+, 2GB Ram, Geforce 7900GT, Mint (Cinnamon) 64bit.
trapperjohn
Level 5
Level 5
Posts: 849
Joined: Wed Jul 11, 2012 4:10 pm
Contact:

Re: Nvidia Geforce 7900

Post by trapperjohn »

I use the NVidia drivers. Hunting down the driver for linux 64 will take a bit of work. Start at http://www.nvidia.com/Download/index.aspx?lang=en-us.

The install will need to be done from the console with the display manager shutdown.

I actually run an NVidia Development drivers on my machines. Here is an article that I wrote that contains a set of steps that reveals how I got the driver working. Your process will be similar.

http://www.codeproject.com/Articles/513 ... a-with-JCu

Scroll down the page to "You cannot have an X server running when you install the..." Your procedure will be similar but will need to be modified for the installation of the standard driver (file names primarily). You can ignore everything else in the article that doesn't apply to the driver install.

I use Mint Mate. Cinnimon probably works too, but at the time I wrote the article, it was a bit buggy for my objectives.
stanley82
Level 2
Level 2
Posts: 96
Joined: Sat Jan 28, 2012 11:01 pm

Re: Nvidia Geforce 7900

Post by stanley82 »

I have an 8500GT and Driver Manager gives me a blank window with the note on the bottom "No drivers running or similar". I can pull over a 45Meg Linux driver from Nvidia and maybe install from the command line. Do you guys see any complicated problems with that. Yes Im on Mint15 64bit cinnamon and I've updated the installation. Regards Ian
Post Reply

Return to “Hardware Support”