Shutting down problems

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
User avatar
Level 1
Level 1
Posts: 9
Joined: Fri May 17, 2013 12:33 am

Shutting down problems

Post by minemax » Fri May 17, 2013 1:01 am

OK, I've installed a LMDE Mate and my PC doesn't want to shut down properly. It goes like this:

1) if I click Menu->Quit->Shut Down then the system starts terminating all running processes, gets out of the GUI session and then nothing happens and there some visual artifacts on the screen. (Similar to the attached picture but only the top half of the screen).
2) If I hit Control-Alt-Delete and choose Shut Down -- the same as above;
3) If I type "sudo shutdown -h 0" from the terminal everything works;
4) When I push the the power button (assigned to Shutdown in the "Power Management" section of the Control Center) on my PC case everything works;

I've installed the proprietary ATI drivers and have some suspicions they are partly to blame but I'm not completely sure about that.
visual artifacts_small.jpg

Level 1
Level 1
Posts: 6
Joined: Wed May 29, 2013 10:49 am

Re: Shutting down problems

Post by computerlab » Sun Jun 02, 2013 12:17 pm

I have a similar problem. I'm running LM15 Mate on an HP Pavilion a408x, but every form of shutdown leaves the power on. I uncommented the grub option "GRUB_TERMINAL=console" in order to get some post-shutdown feedback to make sure that the system was in fact shut down. The kernel configuration file shows that apm is compiled as a module, but when I try modprobe it fails for lack of a device. I use finnix as a rescue system. The finnix kernel also has apm compiled as a module and it also fails to load the module by default; and the shutdown behavior is the same. There is however a BIG difference. Modprobe apm loads the module, after which shutdown -h now and halt work properly. They turn the computer's power off. So now I know that not only Windows but also Debian (finnix is a debian distro) can properly turn off the power on this computer. I would really like to know how to get Mint to do the same.

Level 1
Level 1
Posts: 8
Joined: Wed May 01, 2013 7:51 am

Re: Shutting down problems

Post by LittleTimmy » Fri Jun 28, 2013 3:22 pm

I had a similar issue recently - my laptop kept getting hung at a blackscreen on trying to shutdown. For me, it got solved by adding the parameter "reboot=acpi" to grub.

To do this:
1. First take a backup of your grub settings - copy the file '/etc/default/grub' to someplace safe
2. Open a terminal and type: sudo nano /etc/default/grub
3. Scroll down to: GRUB_CMDLINE_LINUX_DEFAULT="..."
4. Just add reboot=acpi here, so it'll look something like:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash reboot=acpi"

(you might have some other params inside the double quotes, just add "reboot=acpi" here)
5. Save and exit from nano
6. Type: sudo update-grub
This will update yout grub config
7. When you shutdown for the first time after this, you'll see no effect (as grub did not have this param when you booted). But after booting up again, try shutting down though the menu.
8. If it does not work, you can replace your grub file with the backup and do sudo update-grub to get back your old config.

You can also use the above steps to try the solution mentioned in:

(it mentions adding the param "acpi_osi=Linux" to grub)

Level 1
Level 1
Posts: 1
Joined: Tue Aug 27, 2013 6:34 am

Re: Shutting down problems

Post by Aergan » Tue Aug 27, 2013 6:25 pm

LittleTimmy wrote:I had a similar issue recently - my laptop kept getting hung at a blackscreen on trying to shutdown. For me, it got solved by adding the parameter "reboot=acpi" to grub.
Awesome things
This fixed mine for me on Linux Mint 15 x86 - many thanks!

Post Reply

Return to “Hardware Support”