How do I enable Video Hardware Acceleration

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
leobenlee
Level 1
Level 1
Posts: 4
Joined: Sat May 25, 2013 5:17 pm

How do I enable Video Hardware Acceleration

Post by leobenlee »

Hello

I've just installed Mint 15 and am having some trouble with the graphics card. I needed to add "nomodeset" into the command otherwise the Live CD wouldn't load properly. I manged to install the distro but "nomodset" is in the GRUB by default. I have tried removing this line after doing all the system updates and rebooted but all I get is a flickering screen so it seems that I need the "nomodeset" line for the system to load properly.

Now I believe (although I could be wrong as I'm not very well experienced with Linux) that due to the graphics being at "nomodeset", as the system has loaded I get a pop message saying that it is running in software rendering mode and that Cinnamon is running without video hardware acceleration. Therefore videos I view online are very jerky and (although I am not sure if this too is related) when I scroll up or down on webpages it is slow and jerky as well. How do I re-enable video hardware acceleration to hopefully resolve this issue?

Here is my system details.

Code: Select all

leobenlee@Revo-RL80 ~ $ inxi -Fxz
System:    Host: Revo-RL80 Kernel: 3.8.0-19-generic i686 (32 bit, gcc: 4.7.3) Desktop: Gnome Distro: Linux Mint 15 Olivia
Machine:   Mobo: Acer model: Revo RL80 version: 1.0 Bios: American Megatrends version: P11-A1L date: 11/19/2012
CPU:       Dual core Intel Celeron CPU 887 (-MCP-) cache: 2048 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 5986.18 
           Clock Speeds: 1: 1500.00 MHz 2: 1500.00 MHz
Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller bus-ID: 00:02.0 
           X.Org: 1.13.3 drivers: vesa,intel (unloaded: fbdev) Resolution: 1680x1050@0.0hz 
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.2, 128 bits) GLX Version: 2.1 Mesa 9.1.1 Direct Rendering: Yes
Audio:     Card: Intel 7 Series/C210 Series Chipset Family High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture ver: k3.8.0-19-generic
Network:   Card-1: Intel 82579V Gigabit Network Connection driver: e1000e ver: 2.1.4-k port: f060 bus-ID: 00:19.0
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Atheros AR9462 Wireless Network Adapter driver: ath9k bus-ID: 02:00.0
           IF: wlan0 state: down mac: <filter>
Drives:    HDD Total Size: 744.1GB (0.5% used) 1: id: /dev/sda model: WDC_WD7500BPVT size: 744.1GB 
Partition: ID: / size: 679G used: 3.6G (1%) fs: ext4 ID: swap-1 size: 4.17GB used: 0.00GB (0%) fs: swap 
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 151 Uptime: 13 min Memory: 558.2/3922.5MB Runlevel: 2 Gcc sys: 4.7.3 Client: Shell inxi: 1.8.4 
leobenlee@Revo-RL80 ~ $
Any help and guidance would be greatly appreciated. Please let me know if any further details are required.

Many thanks

User avatar
catweazel
Level 19
Level 19
Posts: 9910
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: How do I enable Video Hardware Acceleration

Post by catweazel »

"There is, ultimately, only one truth -- cogito, ergo sum -- everything else is an assumption." - Me, my swansong.

mint_values
Level 1
Level 1
Posts: 16
Joined: Sun Jun 02, 2013 2:56 am

Re: How do I enable Video Hardware Acceleration

Post by mint_values »

hello catweasel. thanks for your help on the other thread I created.

I'm ALSO having a similar warning about graphics acceleration, to what leobenlee described. I followed the link you posted but I'm getting "permission denied" messages when I try to run some of those commands in the terminal.

The only command I was able to run was the very first in the list:
grep -i switcheroo /boot/config-*

with output:
CONFIG_VGA_SWITCHEROO=y

How do I get permission to run those commands? Thanks.

User avatar
eanfrid
Level 7
Level 7
Posts: 1859
Joined: Mon Apr 30, 2012 2:49 am
Location: FR

Re: How do I enable Video Hardware Acceleration

Post by eanfrid »

You must be "root" or add "sudo" before executing any command related to system configuration :)
Main desktop: Debian GNU/Linux Jessie 64bit - MATE
(i5 2400@3.7GHz - 16GB DDR3 - HD6770 w/radeon driver - SSD+RAID1)
Safer than Dropbox

User avatar
proxima_centauri
Level 11
Level 11
Posts: 3961
Joined: Tue Dec 25, 2007 3:24 pm
Location: NB, Canada

Re: How do I enable Video Hardware Acceleration

Post by proxima_centauri »

Try entering the command prefixed with 'sudo', you'll have to enter your password to run the command.

mint_values
Level 1
Level 1
Posts: 16
Joined: Sun Jun 02, 2013 2:56 am

Re: How do I enable Video Hardware Acceleration

Post by mint_values »

hello thank you kindly for your responses.

I tried the sudo prefix earlier but recieved no password prompt, but then later after restarting (and reading these responses) I tried the sudo prefix again and was asked for password. I dunno why computer so hard to understand!

So I tried the next command prompt with sudo:

To test if vga_switcheroo is enabled, look for the switch file:
ls -l /sys/kernel/debug/vgaswitcheroo/switch

and this output:
ls: cannot access /sys/kernel/debug/vgaswitcheroo/switch: No such file or directory

This fist command I ran outputted:
CONFIG_VGA_SWITCHEROO=y

"=y" means yes, right? so I have "switcheroo"? but next command say no file or directory found.

Now I feel discouraged. :(

palo
Level 4
Level 4
Posts: 462
Joined: Mon Jun 25, 2012 7:28 am
Location: Walking on sunshine

Re: How do I enable Video Hardware Acceleration

Post by palo »

Comment deleted

Pat
Last edited by palo on Sun Jun 02, 2013 12:51 pm, edited 1 time in total.

User avatar
eanfrid
Level 7
Level 7
Posts: 1859
Joined: Mon Apr 30, 2012 2:49 am
Location: FR

Re: How do I enable Video Hardware Acceleration

Post by eanfrid »

Did you remove "nomodeset" from your boot options ? If yes, perhaps your hardware does not provide any internal MUX switch, therefore it could not be activated...
Main desktop: Debian GNU/Linux Jessie 64bit - MATE
(i5 2400@3.7GHz - 16GB DDR3 - HD6770 w/radeon driver - SSD+RAID1)
Safer than Dropbox

AlbertP
Level 16
Level 16
Posts: 6719
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: How do I enable Video Hardware Acceleration

Post by AlbertP »

The inxi output is telling me that this person doesn't have Optimus or other hybrid graphics at all - just Intel only. It makes no sense to try vga_switcheroo or Bumblebee here!

With "nomodeset" you're effectively disabling Intel drivers, hence no acceleration.

It might be worth installing libva-intel-vaapi-driver from the repository if you got the Intel driver working properly without nomodeset.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

User avatar
catweazel
Level 19
Level 19
Posts: 9910
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: How do I enable Video Hardware Acceleration

Post by catweazel »

AlbertP wrote:The inxi output is telling me that this person doesn't have Optimus or other hybrid graphics at all - just Intel only. It makes no sense to try vga_switcheroo or Bumblebee here!
AAARGGH! I was too quick on the draw and pasted the wrong link.

My sincere apologies to the original poster. This is the correct link:
https://help.ubuntu.com/community/BinaryDriverHowto/ATI
"There is, ultimately, only one truth -- cogito, ergo sum -- everything else is an assumption." - Me, my swansong.

mint_values
Level 1
Level 1
Posts: 16
Joined: Sun Jun 02, 2013 2:56 am

Re: How do I enable Video Hardware Acceleration

Post by mint_values »

Hello and agian, thanks for your help.

I downloaded libva-intel-vaapi-driver, though I don't know if I was supposed to do that; taking a chance. How may I remove "nomodeset"? Sorry I've not had time to research the options myself, though if you want to point me to tutorial I am happy for that.

Thanks.

AlbertP
Level 16
Level 16
Posts: 6719
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: How do I enable Video Hardware Acceleration

Post by AlbertP »

You can edit the options you usee in the file /etc/default/grub.

Code: Select all

gksudo gedit /etc/default/grub
(replace gedit with pluma on Mate)

After that please run:

Code: Select all

sudo update-grub
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

leobenlee
Level 1
Level 1
Posts: 4
Joined: Sat May 25, 2013 5:17 pm

Re: How do I enable Video Hardware Acceleration

Post by leobenlee »

Thanks to everyone for contributing in helping me (and mint_values) to try and resolve this video hardware acceleration issue.

Just to let you know that I have now installed Mint 13 with the "nomodeset" enabled and therefore assumed that video hardware acceleration is still disabled but at least the videos are playing smoothly. However, I have not checked what the CPU usage is like and whether it is running higher than normal but again assume that this would not be good in the long term? I would eventually like to re-install Mint 15 if the advice results in a fix. I have some further questions on some of the advice and would be grateful for further feedback please. Apologies in advance if these are basic or silly questions.
catweazel wrote:
AlbertP wrote:The inxi output is telling me that this person doesn't have Optimus or other hybrid graphics at all - just Intel only. It makes no sense to try vga_switcheroo or Bumblebee here!
AAARGGH! I was too quick on the draw and pasted the wrong link.

My sincere apologies to the original poster. This is the correct link:
https://help.ubuntu.com/community/BinaryDriverHowto/ATI
I note that the tutorial in the link provided is mainly talking about AMD graphics. As my graphics is Intel, do I still follow it step by step or is it just Step 4 which is enabling video hardware acceleration?
AlbertP wrote:The inxi output is telling me that this person doesn't have Optimus or other hybrid graphics at all - just Intel only. It makes no sense to try vga_switcheroo or Bumblebee here!

With "nomodeset" you're effectively disabling Intel drivers, hence no acceleration.

It might be worth installing libva-intel-vaapi-driver from the repository if you got the Intel driver working properly without nomodeset.
What does it mean to install from the repository? Is it the same as the Synaptic Software Manager or is it something different? Once I have installed the driver, I need to remove the "nomodeset" from the GRUB and reboot to see if everything is ok. Is my assumption of this process correct?

Many thanks again for the advice and guidance.

AlbertP
Level 16
Level 16
Posts: 6719
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: How do I enable Video Hardware Acceleration

Post by AlbertP »

I'm concluding from this topic that your computer will not boot properly if you remove nomodeset by editing Linux Mint in Grub with the E key? You can try it in Grub first before making permanent changes in /etc/default/grub.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

mint_values
Level 1
Level 1
Posts: 16
Joined: Sun Jun 02, 2013 2:56 am

Re: How do I enable Video Hardware Acceleration

Post by mint_values »

hi Albert (and others),

Thanks for the advice about changing the grub page. I ran the suggested code and received this output:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

I don't see anything about nomodeset. The closest thing I can see there relating to anything about "mode" is the GRUB_GFXMODE=640x480 line, though I am reluctant to start making changes based on guess work. Any advice now?

Thanks.

User avatar
eanfrid
Level 7
Level 7
Posts: 1859
Joined: Mon Apr 30, 2012 2:49 am
Location: FR

Re: How do I enable Video Hardware Acceleration

Post by eanfrid »

If "nomodeset" were present, it would be inserted on this line:

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
BTW we still don't know if you have hybrid graphics on your machine... What gives:

Code: Select all

inxi -SGx
Main desktop: Debian GNU/Linux Jessie 64bit - MATE
(i5 2400@3.7GHz - 16GB DDR3 - HD6770 w/radeon driver - SSD+RAID1)
Safer than Dropbox

AlbertP
Level 16
Level 16
Posts: 6719
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: How do I enable Video Hardware Acceleration

Post by AlbertP »

@ eanfrid: The inxi output of leobenlee is already at the top, and there it's shown that his computer has Intel only, no hybrid.

@ mint_values: Please open a new topic, this one is about leobenlee's problem. You're not using nomodeset anyway.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

User avatar
eanfrid
Level 7
Level 7
Posts: 1859
Joined: Mon Apr 30, 2012 2:49 am
Location: FR

Re: How do I enable Video Hardware Acceleration

Post by eanfrid »

Yep I was replying to mint_values. I was waiting for a moderator to split this topic for better understanding since mint_values hijacked it...
Main desktop: Debian GNU/Linux Jessie 64bit - MATE
(i5 2400@3.7GHz - 16GB DDR3 - HD6770 w/radeon driver - SSD+RAID1)
Safer than Dropbox

mint_values
Level 1
Level 1
Posts: 16
Joined: Sun Jun 02, 2013 2:56 am

Re: How do I enable Video Hardware Acceleration

Post by mint_values »

Hello again. I've been traveling so I've not had much access to wifi.

I thought the topic was about graphics acceleration and not specifically "nomodeset". I'm getting (what I think is) the same notification leoben described. I read through the output leo posted and mine was very similar so I didn't bother to post my own, thinking the answer for leoben would be suitable for me as well. Sorry for that assumption.

This is my output:

System: Host: potato Kernel: 3.8.0-19-generic i686 (32 bit, gcc: 4.7.3) Desktop: Gnome Distro: Linux Mint 15 Olivia
Graphics: Card: Intel Atom Processor D2xxx/N2xxx Integrated Graphics Controller bus-ID: 00:02.0
X.Org: 1.13.3 drivers: vesa (unloaded: fbdev) Resolution: 1024x600@60.0hz
GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.2, 128 bits) GLX Version: 2.1 Mesa 9.1.1 Direct Rendering: Yes

I also downloaded the libva-intel-vaapi-driver through the respositories (though it did not make the notification go away).

Although it appears the "nomodeset" option is not an issue for me, do people still feel I should start a new thread on this topic?

Thanks again.

AlbertP
Level 16
Level 16
Posts: 6719
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: How do I enable Video Hardware Acceleration

Post by AlbertP »

Yes please start a new topic on this. It's also in the forum rules that you should start a new topic even if the problem looks similar.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

Post Reply

Return to “Hardware Support”