Mint 15 is putting my monitors to sleep...

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Booster
Level 1
Level 1
Posts: 14
Joined: Tue Jan 29, 2013 10:54 pm

Mint 15 is putting my monitors to sleep...

Post by Booster »

Under Preferences>All Settings>Brightness & Lock I have the inactive screen option set to "Never" however when I lock the system and walk away, 15 minutes later my monitors are in sleep mode. I know this is not the monitor as I use the montiors under Windows with the same option and they never sleep.

I need the system to keep the monitors on - even if it's just the lock screen and never put them to sleep.

Options?

Thanks,
Booster
Level 1
Level 1
Posts: 14
Joined: Tue Jan 29, 2013 10:54 pm

Re: Mint 15 is putting my monitors to sleep...

Post by Booster »

Well I've beem searching all morning and couldn't find anything.

Ideas?
Adelante
Level 4
Level 4
Posts: 336
Joined: Mon Mar 14, 2011 8:16 pm

Re: Mint 15 is putting my monitors to sleep...

Post by Adelante »

Try Power Manager, On AC; change Monitor Actions to "Never."
Linux Mint 17.1 Cinnamon
Linux Mint 17.1 Xfce
Booster
Level 1
Level 1
Posts: 14
Joined: Tue Jan 29, 2013 10:54 pm

Re: Mint 15 is putting my monitors to sleep...

Post by Booster »

When I look under "System Settings" and "Power Management" the only thing listed is:

"Suspend when inactive for: [Drop Down Box] Don't suspend"

is there some other power management?

Using Cinnamon on Mint 64 if it matters.

Is there a CLI command to change this?
Adelante
Level 4
Level 4
Posts: 336
Joined: Mon Mar 14, 2011 8:16 pm

Re: Mint 15 is putting my monitors to sleep...

Post by Adelante »

Sorry. What I told you is for Xfce. I'm on Cinnamon now. It looks like my power settings are the same as yours. In your screensaver setting where it says "Turn screen off when inactive for:" do you have it set to Never?

I'm not one of the experts here. I hope one comes in to help you better than I can.
Linux Mint 17.1 Cinnamon
Linux Mint 17.1 Xfce
Optiker
Level 2
Level 2
Posts: 60
Joined: Fri Dec 14, 2012 4:05 pm

Re: Mint 15 is putting my monitors to sleep...

Post by Optiker »

I'm running Mint 14 but had the same problem - real pain when streaming movies! In Power Management/Energy Saving/On AC Power, There are six check boxes. I unchecked "Dim Display", "Screen Energy Saving" and Suspend Session" since I don't know enough to make a smarter choice, and it worked.

Hope that helps.
Booster
Level 1
Level 1
Posts: 14
Joined: Tue Jan 29, 2013 10:54 pm

Re: Mint 15 is putting my monitors to sleep...

Post by Booster »

Appreciate the replies.

I don't seem to have any of those options in my Power Management. I should say this is on a Dell T5500 professional workstation - this is my general use desktop at work.

I went through the bios this morning to make sure PM was enabled for the OS to manage and it is.
slashdeaf
Level 1
Level 1
Posts: 9
Joined: Tue Jul 09, 2013 6:46 am
Location: the Netherlands

Re: Mint 15 is putting my monitors to sleep...

Post by slashdeaf »

Hi,

I had the same problem with my Mint 15 Mate... Solved it by adding this to my /etc/X11/xorg.conf file:

Section "ServerFlags"
Option "BlankTime" "0"
Option "StandbyTime" "0"
Option "SuspendTime" "0"
Option "OffTime" "0"
Option "DontZap" "false"
EndSection

Then logout and login again and the blanking should be history :-)

Hope it helps...
Booster
Level 1
Level 1
Posts: 14
Joined: Tue Jan 29, 2013 10:54 pm

Re: Mint 15 is putting my monitors to sleep...

Post by Booster »

I don't even have that file in /etc/X11

I will create it and add those options.
Booster
Level 1
Level 1
Posts: 14
Joined: Tue Jan 29, 2013 10:54 pm

Re: Mint 15 is putting my monitors to sleep...

Post by Booster »

Well that didn't seem to do it. The monitors are still going to sleep. I am going to time it today.
slashdeaf
Level 1
Level 1
Posts: 9
Joined: Tue Jul 09, 2013 6:46 am
Location: the Netherlands

Re: Mint 15 is putting my monitors to sleep...

Post by slashdeaf »

Strange....in my case the file was already there...I just had to add the lines.

I did some searching for you and found this posting:
corcaigher wrote:I believe that this problem has resolved itself after I disabled power management and removed and then re-installed the power management software packages. Does anyone know why this is happening in the first place? This had not been a problem until I installed Maya.
I my setup I also went to the startmenu -> applications -> all -> services -> acpi support and removed the checkmark.. Maybe that is something to try?
Booster
Level 1
Level 1
Posts: 14
Joined: Tue Jan 29, 2013 10:54 pm

Re: Mint 15 is putting my monitors to sleep...

Post by Booster »

Thanks for digging for me. Cinnamon doesn't have that directory structure in the start menu though.

I am looking for a way to disable ACPI.

I did uninstall/resinstall the power management software packages and this didn't seem to help.

Some sidebar: I have 4 of the same model screen on my desk. Two are connected to a Windows laptop through a dock, the other two are connected to my Mint desktop. All have the same settings configured in their OSD. I have jockeyed the monitors around multiple times and the monitors on Mint continue to sleep, it doesn't matter which of the 4 I use.
dturne25
Level 1
Level 1
Posts: 3
Joined: Sat Nov 09, 2013 12:03 pm

Re: Mint 15 is putting my monitors to sleep...

Post by dturne25 »

Keeps screen on and unlocked.png
I just had the same problem with the screen goig to sleep and nothing that I read on this page worked. But then I noticed that no one said anything about the Screen saver. So I wentt to Preferences/Screensaver and un-ticked Activate screensaver when computer is idle, and my screen stayed on. Well... That's my 2 cents. Thanks for listening. 8) [img]file:///home/dad/Pictures/Keeps%20screen%20on%20and%20unlocked.png
[/img]
olle
Level 3
Level 3
Posts: 131
Joined: Thu Oct 08, 2009 12:03 pm
Location: Helsinki, Finland

Re: Mint 15 is putting my monitors to sleep...

Post by olle »

dturne25
Level 1
Level 1
Posts: 3
Joined: Sat Nov 09, 2013 12:03 pm

Re: Mint 15 is putting my monitors to sleep...

Post by dturne25 »

8) I'm good (That means I'm okay and got the situation handled). Didn't need that code. Just "un-tick" the box next to"activate screensaver when idle" in the screensaver preferences and all should be fine.
Konki
Level 1
Level 1
Posts: 7
Joined: Mon May 27, 2013 4:58 am

Re: Mint 15 is putting my monitors to sleep...

Post by Konki »

This was my problem as well. I've changed power managment, but forgotten about screen saver.
After change on Screen Saver - everything is fine.

Thanks
Post Reply

Return to “Hardware Support”