[SOLVED] Touchpad cursor too sensitive

Questions about hardware, drivers and peripherals
Forum rules
Before you post please read how to get help
ssvt
Level 1
Level 1
Posts: 5
Joined: Tue Jul 05, 2011 7:19 pm

[SOLVED] Touchpad cursor too sensitive

Post by ssvt »

Hello,

Running Linux Mint 15 on a Dell Latitude 5520. Everything works fine but the touchpad cursor is too sensitive. i can move the cursor by hovering my finger 1/4 inch over the touchpad without actually touching it.

I've reinstalled the drivers and tried gpoingting but nothing has helped. The cursor is rock steady if I use an external mouse.

Any suggestions? Thanks.
Last edited by ssvt on Wed Sep 18, 2013 10:21 pm, edited 2 times in total.
ThePadre
Level 1
Level 1
Posts: 2
Joined: Tue Sep 17, 2013 9:04 am

Re: Touchpad cursor too sensitive

Post by ThePadre »

I'm using a Dell Latitude e6320 and have a similar, but not identical problem. This machine uses an Alps trackpad, I believe.

Namely, the trackpad is just too sensitive. Lifting my finger from the trackpad causes the pointer to move, as does the initial touch on the trackpad. It makes tasks like selecting checkboxes on a webform, or clicking a text link, a bit of a challenge, as the pointer is always jumping away from where I want it. (I'll add that I prefer "tap to click" over the dedicated buttons, after several years of using a MacBook.) Photo editing with Gimp or Darktable is clumsy and slow, too, as a result.

I've played with the sensitivity setting in the mouse/trackpad control panel, where, quite oddly, sliding the pointer to "high sensitivity" improves the problem. (This is just the opposite of what I'd expect.)

Windows 7 on this machine has no such problem at all. The trackpad behaves perfectly.

Ideas? Or is code going to need to be examined?

The Padre
El Zoido
Level 2
Level 2
Posts: 73
Joined: Tue Nov 27, 2012 12:18 pm

Re: Touchpad cursor too sensitive

Post by El Zoido »

The problem isn't so uncommon it seems and happens even in Windows.
My Lenovo E330 also had issues with a jumping cursor when lifting the finger.
I found a solution more by accident, but unfortunately can't find it again at the moment.
Here's another one that does pretty much the same as far as I can tell, but is probably for synaptics only:

I have the same problem on Lenovo Thinkpad Edge 530 and Ubuntu 13.04
The settings from comment #5 did not satisfy me since the cursor speed is pretty much affected (reduced) and increasing the VelocityScale returns back the problem.

After reading the Synaptics manpage I experimented a better configuration, that doesn't affect the speed: there is a
nice feature called NoiseCancellation.

I have created the following config file in /usr/share/X11/xorg.conf.d/50-thinkpad-touchpad.conf:

Section "InputClass"
Identifier "touchpad"
MatchProduct "SynPS/2 Synaptics TouchPad"
Driver "synaptics"
# fix touchpad resolution
Option "VertResolution" "100"
Option "HorizResolution" "65"
# increment noise cancellation factor
Option "HorizHysteresis" "50"
Option "VertHysteresis" "50"
EndSection

You can increase the Horiz-/VertHysteresis even more if you experience still some jumping.
ThePadre
Level 1
Level 1
Posts: 2
Joined: Tue Sep 17, 2013 9:04 am

Re: Touchpad cursor too sensitive

Post by ThePadre »

Thanks for this. I'm new to this kind of manual configuration for a pointing device.

My questions:
1. is "synaptics" the driver to use for an Alps trackpad? (I did modprobe, and found nothing that looked like Alps, but several for synaptics.)
2. To test it, can I use xinput set-atom-prop <dev#> HorizHysteresis 50 (and similar for VertHysteresis)? Does that take effect immediately? If not, what do I need to do?
El Zoido
Level 2
Level 2
Posts: 73
Joined: Tue Nov 27, 2012 12:18 pm

Re: Touchpad cursor too sensitive

Post by El Zoido »

I don't really know!

1. Unless you find something telling you otherwise via Google/Yahoo/whatever, let's assume that the synaptics driver is also used for the Alps touchpad. In any case you could test that solution I posted. If it doesn't work after reboot, just delete the file again.

2. Try it. I would assume that it works right away, but again, I'm not sure. I never had much reason to spend time on that stuff and only applied the above solution on my (new) laptop.
User avatar
roblm
Level 15
Level 15
Posts: 5501
Joined: Sun Feb 24, 2013 2:41 pm

Re: Touchpad cursor too sensitive

Post by roblm »

ssvt,

I assume you've already tried adjusting the settings in System Settings > Mouse and Touchpad.
If you haven't found a solution then would you type this command in the Terminal: xinput
Get the id number of the touchpad.

Then run this command: xinput list-props X
where X is the id number you just obtained.

Then post the output in the reply window by selecting “code” in the menu and pasting it between the two code words:
Last edited by roblm on Wed Sep 18, 2013 10:47 am, edited 1 time in total.
ssvt
Level 1
Level 1
Posts: 5
Joined: Tue Jul 05, 2011 7:19 pm

Re: Touchpad cursor too sensitive

Post by ssvt »

I've tried the suggestions listed with no luck, thanks. I appreciate the help. Below is the xinput results:

Code: Select all

Device 'AlpsPS/2 ALPS DualPoint TouchPad':
	Device Enabled (133):	1
	Coordinate Transformation Matrix (135):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	Device Accel Profile (254):	1
	Device Accel Constant Deceleration (255):	2.500000
	Device Accel Adaptive Deceleration (256):	1.000000
	Device Accel Velocity Scaling (257):	12.500000
	Synaptics Edges (277):	300, 1700, 210, 1190
	Synaptics Finger (278):	12, 15, 128
	Synaptics Tap Time (279):	180
	Synaptics Tap Move (280):	107
	Synaptics Tap Durations (281):	180, 180, 100
	Synaptics ClickPad (282):	0
	Synaptics Tap FastTap (283):	0
	Synaptics Middle Button Timeout (284):	75
	Synaptics Two-Finger Pressure (285):	141
	Synaptics Two-Finger Width (286):	7
	Synaptics Scrolling Distance (287):	48, 48
	Synaptics Edge Scrolling (288):	1, 0, 0
	Synaptics Two-Finger Scrolling (289):	0, 0
	Synaptics Move Speed (290):	1.000000, 1.750000, 0.081934, 40.000000
	Synaptics Edge Motion Pressure (291):	15, 80
	Synaptics Edge Motion Speed (292):	1, 195
	Synaptics Edge Motion Always (293):	0
	Synaptics Off (294):	0
	Synaptics Locked Drags (295):	0
	Synaptics Locked Drags Timeout (296):	5000
	Synaptics Tap Action (297):	0, 0, 0, 0, 0, 0, 0
	Synaptics Click Action (298):	1, 1, 0
	Synaptics Circular Scrolling (299):	0
	Synaptics Circular Scrolling Distance (300):	0.100000
	Synaptics Circular Scrolling Trigger (301):	0
	Synaptics Circular Pad (302):	0
	Synaptics Palm Detection (303):	0
	Synaptics Palm Dimensions (304):	10, 100
	Synaptics Coasting Speed (305):	20.000000, 50.000000
	Synaptics Pressure Motion (306):	15, 80
	Synaptics Pressure Motion Factor (307):	1.000000, 1.000000
	Synaptics Resolution Detect (308):	1
	Synaptics Grab Event Device (309):	1
	Synaptics Gestures (310):	1
	Synaptics Capabilities (311):	1, 1, 1, 1, 1, 1, 0
	Synaptics Pad Resolution (312):	100, 65
	Synaptics Area (313):	0, 0, 0, 0
	Synaptics Noise Cancellation (314):	50, 50
	Device Product ID (250):	2, 8
	Device Node (251):	"/dev/input/event13"
User avatar
roblm
Level 15
Level 15
Posts: 5501
Joined: Sun Feb 24, 2013 2:41 pm

Re: Touchpad cursor too sensitive

Post by roblm »

ssvt,

The property "Synaptics Finger" can affect the touchpad sensitivity. If you look at your values:
Synaptics Finger (278): 12, 15, 128

The 278 is the id # of the property and the three numbers after it are the values for FingerLow, FingerHigh, and FingerPress.
You can read about these properties in the link below:
http://www.x.org/archive/X11R7.5/doc/man/man4/synaptics.4.html

FingerHigh must always be higher than FingerLow. Start by increasing the values of FingerLow and FingerHigh two points at a
time with this command:
xinput --set-prop "AlpsPS/2 ALPS DualPoint TouchPad" 278 14 17 128

Sometimes using the name of the touchpad doesn't work in the command, so the id # number you previously obtained must be used,
substituting it for the X below:
xinput --set-prop X 278 14 17 128

The command should go into effect immediately, so you can test the touchpad.
Then try: xinput --set-prop X 278 16 19 128
and continue increasing the values of FingerLow and FingerHigh until the problem is resolved, but once you get to around 35 to 40, then
going any highter probably won't help. For a Synaptics touchpad you may be able to go higher. If you go too high then some other
function of the toughpad may not work. Any changes made will only last for one session but right now we're just trying to see if this method
works.
ssvt
Level 1
Level 1
Posts: 5
Joined: Tue Jul 05, 2011 7:19 pm

Re: Touchpad cursor too sensitive [SOLVED]

Post by ssvt »

robim,

Success! Thank you so much! This is one of those vexing problems I've looked at off and on for a few years and have not been able to find a satisfactory answer til now.

This should be made a sticky somewhere since I have seen many similar posts about this issue.

Thanks again!
User avatar
roblm
Level 15
Level 15
Posts: 5501
Joined: Sun Feb 24, 2013 2:41 pm

Re: Touchpad cursor too sensitive [SOLVED]

Post by roblm »

ssvt,

What values did you need to use for FingerLow and FingerHigh?

To make the changes permanent, first open the file "50-synaptics.conf" with this command in the Terminal:
gksudo gedit /usr/share/X11/xorg.conf.d/50-synaptics.conf

Add the following two lines to the first section named: Section "InputClass"
Replace the "Y" and "Z" in the lines with the values you got from testing:
Option "FingerLow" "Y"
Option "FingerHigh" "Z"

The example below is from my system, but yours may be a little different:

Code: Select all

Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
        MatchDevicePath "/dev/input/event*"
        Option "FingerLow" "Y" 
        Option "FingerHigh" "Z"
EndSection
Save the file.
ssvt
Level 1
Level 1
Posts: 5
Joined: Tue Jul 05, 2011 7:19 pm

Re: [SOLVED] Touchpad cursor too sensitive

Post by ssvt »

robim,

I used xinput --set-prop 12 278 30 33 128 - that worked well. And I had already updated the 50-synaptics.conf (once you pointed out the parameters it finally "clicked" with me what that meant).

Thanks again!
suicida
Level 1
Level 1
Posts: 8
Joined: Fri Sep 27, 2013 12:53 pm

Re: [SOLVED] Touchpad cursor too sensitive

Post by suicida »

Thank you so much for this thread, the touchpad on my new HP ultrabook was driving me insane.
HP Spectre XT 13-2100ea i5-3317U 4GB 128SSD LM15 Cinnamon
goog64
Level 4
Level 4
Posts: 250
Joined: Fri Dec 21, 2012 12:45 am

Re: [SOLVED] Touchpad cursor too sensitive

Post by goog64 »

I've tried every pair of numbers up to 39 42 with unfortunately no change to my super-sensitive pad.
But I am running Mint from a CD. Would that make a difference?

EDIT: I finally managed to desensitise it - I had to go up to 97 100 to notice any difference.
However, it is still super sensitive to tapping pressure - I have changed that third number all the way up to 70000!! and it still registers the slightest feather taps.
mint@mint ~ $ xinput --set-prop 14 289 97 100 70000

Can anybody please help?
User avatar
roblm
Level 15
Level 15
Posts: 5501
Joined: Sun Feb 24, 2013 2:41 pm

Re: [SOLVED] Touchpad cursor too sensitive

Post by roblm »

goog64 wrote:I've tried every pair of numbers up to 39 42 with unfortunately no change to my super-sensitive pad.
But I am running Mint from a CD. Would that make a difference?
From what I've read in the forums, for most of the time, how devices function using the live installation disk is the same after installation,
however, I often read in the forums where everything worked fine using the live disk but something doesn't work after installation.

I'm surprised that your touchpad clicking or tapping functions are working with the high values you've set for "FingerLow" and "FingerHigh".
Are you still testing from the installation disk?

For you touchpad's super sensitivity to tapping pressure, try adjusting the value of the "Synaptics Pressure Motion" property. Look at ssvt's
second post in this topic and look at the line:
Synaptics Pressure Motion (306): 15, 80

The first number (15) refers to "PressureMotionMinZ" and the second refers to "PressureMotionMaxZ"
Try increasing the value of the first number by 5 at a time. So your command would be:

xinput --set-prop 14 X 20 80
assuming 14 is the id # of your touchpad and X is the property number of "Synaptics Pressure Motion"

If that works then add the line:
Option "PressureMotionMinZ" "Y"
where "Y" is the value you get from testing, to the "50-synaptics.conf" file as shown in a previous post.
goog64
Level 4
Level 4
Posts: 250
Joined: Fri Dec 21, 2012 12:45 am

Re: [SOLVED] Touchpad cursor too sensitive

Post by goog64 »

Thanks Robin, I will try that.
prenger745
Level 1
Level 1
Posts: 1
Joined: Mon Feb 24, 2014 9:25 pm

Re: [SOLVED] Touchpad cursor too sensitive

Post by prenger745 »

Had to give my thanks as well. I got so frustrated by this that I hadn't turned on my laptop for months. It works great now!

Dan
goog64
Level 4
Level 4
Posts: 250
Joined: Fri Dec 21, 2012 12:45 am

Re: [SOLVED] Touchpad cursor too sensitive

Post by goog64 »

For any newbies (like me) reading this in future - I just upgraded to Mint 17 and with these commands in this thread I couldn't get my touchpad the way I had it in 15 using these same commands.
Then I realised that all the property numbers for my touchpad had changed, so I had to do the xinput list-props 14 thing again to find out the correct numbers for the properties. (And maybe I was just lucky that the "14" still referred to the touchpad.)
mcganical
Level 1
Level 1
Posts: 30
Joined: Thu Oct 30, 2014 12:04 pm

Re: [SOLVED] Touchpad cursor too sensitive

Post by mcganical »

Oddly, when I do xinput list-props 11 (it's 11 on my macbook pro), I get:

Code: Select all

Device 'Apple Inc. Apple Internal Keyboard / Trackpad':
	Device Enabled (141):	1
	Coordinate Transformation Matrix (143):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	Device Product ID (259):	1452, 610
	Device Node (260):	"/dev/input/event5"
So it's not listing Synaptics Finger and all that. But I guess I can still add FingerHigh and FingerLow to the conf file, right?

Dumb question - but should I be seeing my changes take effect the moment I save the conf file? Or do I need to restart?

Thanks!
mcganical
Level 1
Level 1
Posts: 30
Joined: Thu Oct 30, 2014 12:04 pm

Re: [SOLVED] Touchpad cursor too sensitive

Post by mcganical »

Replying to myself.

1. Yes, seems you need to logout then back in to see the changes take effect. If I didn't, then synclient -l would not display the updated values.

2. On Mint 17, and my macbook pro, I created a file called 60-synaptics.conf in /etc/X11/xorg.conf.d (I had to create that folder). In that file, I copied the contents from /usr/share/X11/xorg.conf.d/50-synaptics.conf

And then added

Code: Select all

Section "InputClass"
  Identifier "touchpad"
  Driver "synaptics"
  MatchIsTouchpad "on"
  MatchDevicePath "/dev/input/event*"
  Option "FingerHigh" "35"
  Option "FingerLow" "30"
EndSection
And other settings that I'm still toying with. 35 and 30 aren't perfect - too stiff - but at least the jitteryness when I click is gone. So I'm on the right track. Thanks for your help.
reeby
Level 1
Level 1
Posts: 23
Joined: Sat Nov 08, 2014 2:44 pm

Re: [SOLVED] Touchpad cursor too sensitive

Post by reeby »

Strange but nothing works for me.
I've got HP Envy 14. And all the tweaks mentioned here do maybe just a little difference in my otherwise total crazy cursor jumps (mostly when i take the finger off the touch pad - that's where i loose it 'cause it positions itself a millimetre below the point i put it originaly). I've tried to play with a few other parameters as well besides Finger High and Low - it's all the same - nothing.
Unfortunate thing is that UBUNTY had the same and that was the main reason i had to delete it. Now seems like Mint is something i will have to abandon for the same reason. Very unfortunate.

upd:
El Zoido,
thanks a lot! the resolution fix you provided seems to do the job!
El Zoido wrote:The problem isn't so uncommon it seems and happens even in Windows.
My Lenovo E330 also had issues with a jumping cursor when lifting the finger.
I found a solution more by accident, but unfortunately can't find it again at the moment.
Here's another one that does pretty much the same as far as I can tell, but is probably for synaptics only:

I have the same problem on Lenovo Thinkpad Edge 530 and Ubuntu 13.04
The settings from comment #5 did not satisfy me since the cursor speed is pretty much affected (reduced) and increasing the VelocityScale returns back the problem.

After reading the Synaptics manpage I experimented a better configuration, that doesn't affect the speed: there is a
nice feature called NoiseCancellation.

I have created the following config file in /usr/share/X11/xorg.conf.d/50-thinkpad-touchpad.conf:

Section "InputClass"
Identifier "touchpad"
MatchProduct "SynPS/2 Synaptics TouchPad"
Driver "synaptics"
# fix touchpad resolution
Option "VertResolution" "100"
Option "HorizResolution" "65"
# increment noise cancellation factor
Option "HorizHysteresis" "50"
Option "VertHysteresis" "50"
EndSection

You can increase the Horiz-/VertHysteresis even more if you experience still some jumping.
Locked

Return to “Hardware Support”