Page 1 of 1

(SOLVED) Toshiba Satellite keyboard/touchpad suspend issue

Posted: Fri Dec 06, 2013 6:09 pm
by cosners
Edited for better readability.

Laptop Model: Toshiba Satellite P55-A5200
Linux Flavor: Mint 16 with Cinammon
Issue: The keyboard and touchpad will refuse to work after waking up from suspend.

Relevant Info
  • Had the same issue on Ubuntu 13.10
    Happens less if there is a shorter amount of time between suspends
    Pretty much guaranteed to happen after a couple hours of continuous use
    Regular USB mouse will still work
    Unrelated to temperature, since it still happened after I cooled my laptop with a fan

    Output of xinput list:
    ⎡ Virtual core pointer id=2 [master pointer (3)]
    ⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
    ⎜ ↳ SynPS/2 Synaptics TouchPad id=11 [slave pointer (2)]
    ⎜ ↳ Logitech Unifying Device. Wireless PID:1025 id=12 [slave pointer (2)]
    ⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ TOSHIBA Web Camera - HD id=9 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=10 [slave keyboard (3)]
Have Already Tried
  • Editing /etc/default/grub to say atkbd.reset after quiet splash

Please let me know if you guys need more info. I'm new-ish at using Linux so there's probably a lot of info that's needed but that I didn't post.

Re: Toshiba Satellite keyboard/touchpad won't work after sus

Posted: Sun Dec 08, 2013 3:25 am
by cosners
I think I'm getting closer to the answer. I found this howto on the Ubuntu forums:
It talked about a problem with the i8042 controller that causes this exact same issue. However, lshal doesn't exist and can't be installed. When I tried installing the suggested program, hal, it said
Package hal is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
I don't want to run any scripts without first determining that my problem comes from i8042.

Is there any way of determining if I have the i8042 controller on my system?

I already have an idea of how to fix my problem if I do happen to find it.

Re: Toshiba Satellite keyboard/touchpad won't work after sus

Posted: Sun Dec 08, 2013 4:21 am
by cosners
I think I may have fixed the problem.

I looked under /sys/bus/platform/drivers/ and found a directory called i8042, so I decided that it was the problem and took the jump.

Solution, for future people with the same problem:
  • In /etc/default/grub, edited the line with GRUB_CMDLINE_LINUX_DEFAULT to say atkbd.reset i8042.nomux in addition to quiet splash which was already there before
    Ran sudo update-grub and rebooted
After I did that, my laptop worked just fine after suspension.
As I said before, the problem was much more likely to happen when the computer was on for a long period of time, so I'm not going to mark this as fixed until at least a day passes without any issues.

Re: (SOLVED) Toshiba Satellite keyboard/touchpad suspend iss

Posted: Tue Oct 14, 2014 11:42 pm
by ehermanson
Thank you! This is an issues for the entire linux community. (suspend/resume) Either that or I got really lucky because this work perfectly on my Sony Vaio Fit 13A Flipbook with Linux Mint 17 Qiana. Thanks for researching this. We should post this in other boards. I wonder how widespread this exact fix would be in terms of fixing other linux suspend/ resume issues.

Edward Hermanson

Re: (SOLVED) Toshiba Satellite keyboard/touchpad suspend iss

Posted: Fri Oct 17, 2014 11:35 pm
by ehermanson
Follow up...

The above worked great if my laptop suspended on its own, but I had to add a few extra flags I tracked down so it would also resume successfully when closing the lid caused it to suspend. My final line was;

GRUB_CMDLINE_LINUX="atkbd.reset=1 i8042.nomux=1 i8042.reset=1 i8042.nopnp=1 i8042.dumbkbd=1"

The last 3 are new. It is possible that all 3 are not needed. I have not tested each one yet. Now it suspends and resumes as expected with or without the screensaver.

Once again I am running Linux Mint 17 KDE on a Sony Vaio Fit 13A FlipBook.