Which LM is best for oldish laptop: 13 LTS or 16? [Cinnamon]

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Rehdon
Level 3
Level 3
Posts: 161
Joined: Tue Nov 29, 2011 9:18 am

Which LM is best for oldish laptop: 13 LTS or 16? [Cinnamon]

Post by Rehdon »

Hi all,
I have an oldish Sony VAIO with an AMD Mobile HD3450 graphic card: it seems that the standard AMD proprietary driver doesn't support this card anymore, there's an AMD legacy driver but it's limited to an older, specific version of X Window. I've installed LM 14 Cinnamonon it some time ago, and while being happy enough with it, using the free software driver means having the fan going at full speed almost all the time because the card overheats, and of course I can't do anything 3D related.

So my question is: should I revert to LM 13 LTS (Cinnamon edition) which is going to have Cinnamon 2.0 backported, or should I install LM 16 hoping that either the proprietary legacy driver is updated to work with the current X Window version and/or the free one improves enough to work with 3D?

Thanks in advance,

Rehdon

User avatar
catweazel
Level 19
Level 19
Posts: 9895
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Which LM is best for oldish laptop: 13 LTS or 16? [Cinna

Post by catweazel »

13 LTS, no contest for older kit.
"There is, ultimately, only one truth -- cogito, ergo sum -- everything else is an assumption." - Me, my swansong.

Rehdon
Level 3
Level 3
Posts: 161
Joined: Tue Nov 29, 2011 9:18 am

Re: Which LM is best for oldish laptop: 13 LTS or 16? [Cinna

Post by Rehdon »

Thanks, installed LM 13 and everything seems to work fine so far :)

Rehdon

bobafetthotmail
Level 4
Level 4
Posts: 361
Joined: Sat Aug 10, 2013 8:20 am

Re: Which LM is best for oldish laptop: 13 LTS or 16? [Cinna

Post by bobafetthotmail »

Actually, 16 isn't particularly more heavy than 13 (it's supposed to be lighter).

The main issue is that the hardware support for that card sucks in 16, BUT, thing should change in the future as they are adding support for GPU power management in the newer major kernel release (3.13), so it's very likely that by the times it comes out you can install whatever latest Mint, update manually the kernel if needed, and run everything with the opensource radeon driver without heat/fan noise.

As for 3D acceleration, they say it's already "good" for your card on the opensource driver, which it's promising although a bit generic. https://help.ubuntu.com/community/RadeonDriver

Just a heads up.

Rehdon
Level 3
Level 3
Posts: 161
Joined: Tue Nov 29, 2011 9:18 am

Re: Which LM is best for oldish laptop: 13 LTS or 16? [Cinna

Post by Rehdon »

Thanks for the heads up :) I must say the radeon driver is not yet up to task, at least for the stuff I need (loading of 3D models in OpenGL and a MMORPG game), good to know they're working on it.

Do you think I should install the fglrx-legacy-driver instead of the current fglrx one? the latter is showing some tearing and other glitches on my Cinnamon desktop.

Rehdon

bobafetthotmail
Level 4
Level 4
Posts: 361
Joined: Sat Aug 10, 2013 8:20 am

Re: Which LM is best for oldish laptop: 13 LTS or 16? [Cinna

Post by bobafetthotmail »

I must say the radeon driver is not yet up to task, at least for the stuff I need
that driver is integrated in the kernel and is updated with it, what kernel version/Mint number you tried? the latest is 3.12.5
Since you can't change kernel without breaking the catalyst driver.... only way is through another partition or a live-cd.

As it is now it only lacks power management and cards run always at full throttle, but as I said it should change.

If you make some tests with another partition, adding the boot parameter radeon.dpm=1 enables that power management, although it's not fully tested. As described here:
https://help.ubuntu.com/community/Radeo ... _and_Later
In case you want to test, here is how to update to latest kernel http://ubuntuhandbook.org/index.php/201 ... ntu-linux/ Again, this will break the Catalyst driver, so don't do it in your current rig.
Do you think I should install the fglrx-legacy-driver
yeah it should use legacy drivers, according to the official site here http://support.amd.com/en-us/download

Check that your Xorg/Xserver is between Xorg 6.9 and Xserver 1.12 and that your kernel is not above version 3.4 or it won't work, as they say.

Rehdon
Level 3
Level 3
Posts: 161
Joined: Tue Nov 29, 2011 9:18 am

Re: Which LM is best for oldish laptop: 13 LTS or 16? [Cinna

Post by Rehdon »

Thanks for all the info! Will definitely look into it :)

Rehdon

Post Reply

Return to “Hardware Support”