ASROCK Z87 Extrem4/TB4 Bad Shutdown/Suspend

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Random12
Level 1
Level 1
Posts: 17
Joined: Mon May 28, 2012 3:44 pm

ASROCK Z87 Extrem4/TB4 Bad Shutdown/Suspend

Post by Random12 »

I installed 64 bit Linux Mint 16 Mate Edition on an ASROCK Z87 Extreme4/TB4 Motherboard with an i7-4770K,and 8GB of RAM using the onboard HD 4600 graphics.

The machine boots and runs the first time after installation (except for a minor sound issue that I'll post about elsewhere).

When I shutdown though, the machine shuts down, seems to power off, but then reboots.
When I suspend, the machine seems to go into a suspend state. However, on hitting a key to wake it, it reboots rather than resuming.

What's worse, after either a shutdown or suspend , rebooting doesn't work properly. In particular, the ethernet driver isn't loaded, and I can't get any network connectivity. Even a total shutdown and removal of the power cord doesn't help. Only opening my case and hitting the Clear CMOS button allows me to reboot properly. I can see some differences in dmesg output between a good boot and a bad one. IRQ's and memory seems to be assigned a differently. I tried uploading dmesg output here, but this forums system complains that the file has an extension that isn't allowed, not matter what extension I use.

I also tried Linux Mint 13 and Fedora 20RC1 and found the same behavior. I also tried installing Mint with both BIOS/MBR and UEFI boot and found no difference. Updating the ASROCK motherboard to the latest UEFI firmware didn't fix anything.

I imagine it's an upstream kernel/UEFI bug/interaction problem, but I'm not sure where to email or post to get help, or what other diagnostics might be helpful.

Help! Please someone.

Thanks,
Aaron
Herby Pepper
Level 1
Level 1
Posts: 25
Joined: Thu Aug 08, 2013 7:03 am

Re: ASROCK Z87 Extrem4/TB4 Bad Shutdown/Suspend

Post by Herby Pepper »

Here is similar problem and solution by naughty_bit that is working for some:
http://forums.linuxmint.com/viewtopic.p ... 45#p633743
Hitchhiker
Level 1
Level 1
Posts: 28
Joined: Thu Nov 21, 2013 7:36 am

Re: ASROCK Z87 Extrem4/TB4 Bad Shutdown/Suspend

Post by Hitchhiker »

I think you may have posted earlier that you already tried this, but if not, what worked for my Gigabyte Z87 to shut down properly was to disable Wake on LAN in the BIOS.

The ASROCK Z87 boards use the absolute latest and most powerful Realtek ALC1150 Audio Codec. This is suppose to be better than older ones but it may not be completely supported in Linux yet as it is new hardware. My Gigabyte board has the older ALC892 audio codec.

Is the power supply Haswell certified?
Post Reply

Return to “Hardware Support”