Brightness Controls, LM16 on Acer Aspire S3

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
johnreads
Level 1
Level 1
Posts: 3
Joined: Mon Dec 23, 2013 5:01 pm

Brightness Controls, LM16 on Acer Aspire S3

Post by johnreads » Mon Dec 23, 2013 5:07 pm

I have been trying to fix this for hours but all of the solutions seem to be for LM15 and none of them have worked so far. My display brightness is set to maximum and I cannot change it. The brightness control keys actually bring up the brightness applet and make the bar increase and decrease but nothing happens. I have messed about with grub but nothing works so far. Help please.

User avatar
roblm
Level 10
Level 10
Posts: 3269
Joined: Sun Feb 24, 2013 2:41 pm

Re: Brightness Controls, LM16 on Acer Aspire S3

Post by roblm » Thu Dec 26, 2013 3:52 pm

You said that you already worked with the GRUB boot file, so you already tried adding all these kernel parameters?:
acpi_osi=Linux
acpi_backlight=vendor
acpi_osi=Linux acpi_backlight=vendor
acpi_osi='!Windows 2012'
acpi_osi=

Try installing xbacklight in the Synaptic Package Manager. Then open the Terminal and type:
xbacklight -set 60
and see if the backlight decreases.

If not would you do the following procedure to see if any scancodes are generated: EDITED 12-27-13: THIS NO
LONGER WORKS IN MINT 16, AS IT DID IN MINT 14 & 15


Press Ctrl+Alt+F1 to enter the virtual console tty1 and type: /lib/udev/findkeyboards
Get the input/event number of the AT keyboard.

Then type: sudo /lib/udev/keymap -i input/eventX
where X is the number you found in the previous step.

Press the Fn+key combinations that increase and decrease the screen brightness.
Press the Escape key.
Type this command to get a screenshot:
sudo screendump 1 > screenoutput.txt

Press Ctrl+Alt+F8 to exit tty1. If this fails then try Ctrl+Alt+F7.
The file "screenoutput.txt" will be found in your "/home/user-name" directory. Post the result.

Type this command in the Terminal and post the output:
cat /sys/class/backlight/acpi_video0/max_brightness

You should get a number, but if you don't then type this command:
ls /sys/class/backlight/*/*
Last edited by roblm on Fri Dec 27, 2013 9:38 pm, edited 1 time in total.

supertallrich
Level 1
Level 1
Posts: 10
Joined: Mon Dec 23, 2013 4:23 pm

Re: Brightness Controls, LM16 on Acer Aspire S3

Post by supertallrich » Thu Dec 26, 2013 3:59 pm

This workaround using xbacklight works for me on the Aspire S3:

http://delightlylinux.wordpress.com/201 ... -ultrabook

The brightness function keys don't do squat for me on LM16 KDE.

johnreads
Level 1
Level 1
Posts: 3
Joined: Mon Dec 23, 2013 5:01 pm

Re: Brightness Controls, LM16 on Acer Aspire S3

Post by johnreads » Fri Dec 27, 2013 1:22 pm

Thanks for taking the time to reply to me, I really appreciate it. Unfortunately none of the things you suggested work. I have worked through all of the acpi_osi parameters you suggested and they have not worked. The most that has happened is that some of those options render the brightness function keys completely ineffective (at the moment they bring up the brightness applet and show the bar increasing and decreasing while making no actual changes to the backlight). I installed xbacklight, but it does nothing. I tried to follow your instructions for the virtual console but I have no /lib/udev/findkeyboards or /lib/udev/keymap.

The only way I have been able to increase or decrease the brightness of my backlight is by entering the following into the terminal:

Code: Select all

echo X | sudo tee /sys/class/backlight/intel_backlight/brightness
Where X is a number between minimum and maximum brightness.

Is there a better version of Linux I can install on my laptop? I'm new to Mint and it just doesn't seem to be working out.
roblm wrote:You said that you already worked with the GRUB boot file, so you already tried adding all these kernel parameters?:
acpi_osi=Linux
acpi_backlight=vendor
acpi_osi=Linux acpi_backlight=vendor
acpi_osi='!Windows 2012'
acpi_osi=

Try installing xbacklight in the Synaptic Package Manager. Then open the Terminal and type:
xbacklight -set 60
and see if the backlight decreases.

If not would you do the following procedure to see if any scancodes are generated:

Press Ctrl+Alt+F1 to enter the virtual console tty1 and type: /lib/udev/findkeyboards
Get the input/event number of the AT keyboard.

Then type: sudo /lib/udev/keymap -i input/eventX
where X is the number you found in the previous step.

Press the Fn+key combinations that increase and decrease the screen brightness.
Press the Escape key.
Type this command to get a screenshot:
sudo screendump 1 > screenoutput.txt

Press Ctrl+Alt+F8 to exit tty1. If this fails then try Ctrl+Alt+F7.
The file "screenoutput.txt" will be found in your "/home/user-name" directory. Post the result.

Type this command in the Terminal and post the output:
cat /sys/class/backlight/acpi_video0/max_brightness

You should get a number, but if you don't then type this command:
ls /sys/class/backlight/*/*

johnreads
Level 1
Level 1
Posts: 3
Joined: Mon Dec 23, 2013 5:01 pm

Re: Brightness Controls, LM16 on Acer Aspire S3

Post by johnreads » Fri Dec 27, 2013 1:37 pm

supertallrich wrote:This workaround using xbacklight works for me on the Aspire S3:

http://delightlylinux.wordpress.com/201 ... -ultrabook

The brightness function keys don't do squat for me on LM16 KDE.
Thank you! Finally I have control over my backlight! It's not perfect (I liked the little applet and it would be nice if the Fn keys worked) but it'll do. Thanks!

supertallrich
Level 1
Level 1
Posts: 10
Joined: Mon Dec 23, 2013 4:23 pm

Re: Brightness Controls, LM16 on Acer Aspire S3

Post by supertallrich » Fri Dec 27, 2013 8:20 pm

You're welcome!

Post Reply

Return to “Hardware Support”