No Sound through speakers and no solution

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
ghislaindebondt
Level 1
Level 1
Posts: 14
Joined: Sat Dec 28, 2013 8:31 am

No Sound through speakers and no solution

Post by ghislaindebondt »

installed linux mint on a friends Lenovo Thinkpad edge e 135 for his daughter. Everything works out of the box ... excecpt ...aaarggg ... no sound through speakers. I googled around like nuts ans tried many solutions for different hours (I rebooted over 50 times or so:-). But ... still no solution.
I tried the pavucontrol, also added the following line "options snd-hda-intel model=thinkpad" (and replaced "thinkpad" by basic, auto, generic, laptop, laptop-amic, .... ) to the /etc/modprobe.d/alsa-base.conf. Still no solution. I'm getting real desperate over here
I've tried to install Lubuntu and Peppermint OS but came back to Linux Mint. As you can see ... many hours of trying and still no solution.
Is there anyone out there that can help me during this "period of Christmas and peace ????
Herby Pepper
Level 1
Level 1
Posts: 24
Joined: Thu Aug 08, 2013 7:03 am

Re: No Sound through speakers and no solution

Post by Herby Pepper »

Did you look at alsamixer if sound is not muted ?
(type in terminal: alsamixer)
User avatar
gold_finger
Level 9
Level 9
Posts: 2885
Joined: Mon Mar 11, 2013 11:39 pm

Re: No Sound through speakers and no solution

Post by gold_finger »

No idea if this is the case for you, but believe it or not many times that problem turns out to simply be that the laptop has a physical switch/dial/button for sound level that just happens to be set to very low volume or mute. Look all over the laptop (around all edges and in the area of the function keys) for anything that looks like it might control the volume and make sure that this is not the case.
Please add [SOLVED] to your thread if a solution is found. Go to your first post in the thread, hit "Edit" button and add [SOLVED] to the title of the post.

How To Format Your Forum Posts.

Try Linux Beginner Search Engine for Linux questions.
ghislaindebondt
Level 1
Level 1
Posts: 14
Joined: Sat Dec 28, 2013 8:31 am

Re: No Sound through speakers and no solution

Post by ghislaindebondt »

Thanks for the replies. Still no solution, but it feels good to know that others are searching for you.

@ herby: About Alsamixer (see pic). I have a few options while clicking on F6.
Default: no possibility to change anything
Card 0: same here
Card 2: Evrything is on maximum
Card 4: also no items to check

@gold-finger: (my name is Bond :-) no hardware buttons, except keyboard, but there it is set to max output.

Anyone else who has an idea?
ghislaindebondt
Level 1
Level 1
Posts: 14
Joined: Sat Dec 28, 2013 8:31 am

Re: No Sound through speakers and no solution

Post by ghislaindebondt »

forgot the pics.
ghislaindebondt
Level 1
Level 1
Posts: 14
Joined: Sat Dec 28, 2013 8:31 am

Re: No Sound through speakers and no solution

Post by ghislaindebondt »

Found this in logfiles .... maybe helpfull
autoconfig: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
Dec 27 19:43:33 frouke-ThinkPad-Edge-E135 kernel: [ 12.295890] speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
Dec 27 19:43:33 frouke-ThinkPad-Edge-E135 kernel: [ 12.295893] hp_outs=1 (0x15/0x0/0x0/0x0/0x0)
Dec 27 19:43:33 frouke-ThinkPad-Edge-E135 kernel: [ 12.295899] mono: mono_out=0x0
Dec 27 19:43:33 frouke-ThinkPad-Edge-E135 kernel: [ 12.295901] inputs:
Dec 27 19:43:33 frouke-ThinkPad-Edge-E135 kernel: [ 12.295905] Mic=0x18
Dec 27 19:43:33 frouke-ThinkPad-Edge-E135 kernel: [ 12.295907] Internal Mic=0x12
ghislaindebondt
Level 1
Level 1
Posts: 14
Joined: Sat Dec 28, 2013 8:31 am

Re: No Sound through speakers and no solution

Post by ghislaindebondt »

I have tested a bluetooth speaker ... works fine. So if I got the laptop-speakers working, then I am the gladdest person on earth!!
ghislaindebondt
Level 1
Level 1
Posts: 14
Joined: Sat Dec 28, 2013 8:31 am

Re: No Sound through speakers and no solution

Post by ghislaindebondt »

My alsa-base.conf

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
#added by myself because of what I found on Google but it doesn't work
options snd-hda-intel model=generic
Herby Pepper
Level 1
Level 1
Posts: 24
Joined: Thu Aug 08, 2013 7:03 am

Re: No Sound through speakers and no solution

Post by Herby Pepper »

On the first picture that you post of AlsaMixer, on the right side of the frame, there are small arrows. It looks like there are more options that we cannot see. Try to press right arrow on the keyboard to get to these options.
What I suspect is that there will be "auto-mute" that is enabled. You need to disable it.
ghislaindebondt
Level 1
Level 1
Posts: 14
Joined: Sat Dec 28, 2013 8:31 am

Re: No Sound through speakers and no solution

Post by ghislaindebondt »

@Herby
Thanks a lot ... serious ... I'm getting closer to a solution.

1. I disabled "auto-mute" and my speakers are working now. But only if I -afterwards- select speakers in pavucontrol in the output devices tab.
2. When the sound comes through the speakers and I put in the headphone ... the speakers keep on playing ... so I have to switch on to headphone in pavucontrol again.

Isn't there a way to do this automatticly as it should? Because I don't think it's easy for a little girl to always startup pavucontrol to switch manually from speakers to headphone and vice versa?

Anyone?
Herby Pepper
Level 1
Level 1
Posts: 24
Joined: Thu Aug 08, 2013 7:03 am

Re: No Sound through speakers and no solution

Post by Herby Pepper »

I know you tried modifying alsa-base.conf already but I think it would be solution for the problem with switching sound from speakers to headphones and back.
Here are 3 different options, one of them might work for you:

1.
options snd-hda-intel model=laptop
options snd-hda-intel position_fix=1 enable=yes
2.
options snd-hda-intel model=auto
3.
options snd-hda-intel model=hippo
ghislaindebondt
Level 1
Level 1
Posts: 14
Joined: Sat Dec 28, 2013 8:31 am

Re: No Sound through speakers and no solution

Post by ghislaindebondt »

Hi Herbert,

I tried them all, but no luck. The pitty is that the headphone is default. So if I play music, I always have to change the output device. So it will be a help if I could be able to set the speakers as default. Would that be possible?
Herby Pepper
Level 1
Level 1
Posts: 24
Joined: Thu Aug 08, 2013 7:03 am

Re: No Sound through speakers and no solution

Post by Herby Pepper »

Another two suggestions from me :

1.
There are fixing to "pavucontrol changes permanent" here:
http://askubuntu.com/questions/166953/h ... -permanent

2.
try add line:
load-module module-switch-on-connect
to /etc/pulse/default.pa
ghislaindebondt
Level 1
Level 1
Posts: 14
Joined: Sat Dec 28, 2013 8:31 am

Re: No Sound through speakers and no solution

Post by ghislaindebondt »

Hmmm did not work for me.
See below you'll find a picture where you can see that (analogue headphone) is default and there I can select speakers (luidsprekers). How can I make shure that the speakers are default instead of the headphone.
User avatar
edwardr
Level 4
Level 4
Posts: 248
Joined: Thu Jun 03, 2010 1:09 pm
Location: USA - Texas

Re: No Sound through speakers and no solution

Post by edwardr »

In pavucontrol, under the Configuration tab (which I guess is Configuratie for you), have you tried selecting different profiles from the Built-in Audio selections? That has fixed the problem of no sound for me before in Mint xfce.
The optimist proclaims that we live in the best of all possible worlds; and the pessimist fears this is true
ghislaindebondt
Level 1
Level 1
Posts: 14
Joined: Sat Dec 28, 2013 8:31 am

Re: No Sound through speakers and no solution

Post by ghislaindebondt »

@ edwardr
I tried indeed different settings in pavucontrol/configuration. But I do non have much choice. Just
- stereo duplex
- stereo output
- stereo input
- off

Strange that if I choose speakers, that by a restart headphone is always default. I lost hours for a solution. Pffff.
ghislaindebondt
Level 1
Level 1
Posts: 14
Joined: Sat Dec 28, 2013 8:31 am

Re: No Sound through speakers and no solution

Post by ghislaindebondt »

Want to keep this alive, because we are so close to a solution ..... Anyone who can tell me how I can set the speakers default?
Post Reply

Return to “Hardware Support”