Touchpad not active on my Terra Laptop

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
krissam44
Level 1
Level 1
Posts: 5
Joined: Sun Jan 19, 2014 6:36 am

Touchpad not active on my Terra Laptop

Post by krissam44 »

Hye,

Someone could help me.
I have a Terra UltraBook 1450II.
I'm not able to activate the touchpad.
An USB Logitech Mouse and keyboard are working fine.

Thanks for your help.

Regards
_tab
Level 2
Level 2
Posts: 65
Joined: Sat Jan 18, 2014 4:01 pm

Re: Touchpad not active on my Terra Laptop

Post by _tab »

Have you tried going into the Touchpad settings and checking the status?

When I installed Mint using a mouse I found the Touchpad had been disabled.
krissam44
Level 1
Level 1
Posts: 5
Joined: Sun Jan 19, 2014 6:36 am

Re: Touchpad not active on my Terra Laptop

Post by krissam44 »

Yes my touchpad is active as you can see in the attached file.
Any other idea.
Please, I need some help.

Regards
Attachments
Capture.png
Hutch
Level 1
Level 1
Posts: 18
Joined: Sat Mar 14, 2009 6:25 pm

Re: Touchpad not active on my Terra Laptop

Post by Hutch »

I tried all the suggestions I could find in the forums (Mint/Ubuntu/Arch/openSUSE) I was just about to try another distro which needed me to switch the bios boot from efi to csm :idea: when I noticed the 'internal pointing...' was set to DISABLED. :shock: I must have done that when I was testing a live cd earlier... :oops: Pity I didn't notice before I had done a fresh install :roll: but at least I backed up and now have a fresh mint installation. :P
_tab
Level 2
Level 2
Posts: 65
Joined: Sat Jan 18, 2014 4:01 pm

Re: Touchpad not active on my Terra Laptop

Post by _tab »

It looks as though it needs a bit of tweeking -


The hardware is automatically supported by Linux, except for the touchpad, which needs additional configuration


http://www.linux-hardware-guide.com/201 ... -120gb-ssd
krissam44
Level 1
Level 1
Posts: 5
Joined: Sun Jan 19, 2014 6:36 am

Re: Touchpad not active on my Terra Laptop

Post by krissam44 »

Hy,

I've modified grub as explained in the Wortmann forum and it doesn't work.
I think my laptop is not fully compatible with linux.
User avatar
Marcus Law
Level 1
Level 1
Posts: 10
Joined: Thu Jan 23, 2014 6:50 pm
Location: United States
Contact:

Re: Touchpad not active on my Terra Laptop

Post by Marcus Law »

1. Run the following command in terminal:
sudo gedit /etc/default/grub

2. The GRUB configuration file should open. Locate the following line:
GRUB_CMDLINE_LINUX=" "

3. Add this into the parameters:
i8042.nomux=1 locale=fr_FR i8042.reset

4. The final line should look like this:
GRUB_CMDLINE_LINUX="i8042.nomux=1 locale=fr_FR i8042.reset"

5. Save the file and exit gedit.

6. Run the following command in terminal:
sudo update-grub

7. Let the grub.conf file get recreated, and then restart.


This is a bug that spans across several Linux distros if not all and is present on laptops (not sure of desktops). From whatever I could gather it is experienced in the Toshiba Satellite L775D-S7135, and many of Compaq and Lenovo laptop models. I really hope it can get fixed so that all this circus is not needed.

Credit: viewtopic.php?f=46&t=41200
krissam44
Level 1
Level 1
Posts: 5
Joined: Sun Jan 19, 2014 6:36 am

Re: Touchpad not active on my Terra Laptop

Post by krissam44 »

Thank you Marcus for your help but it doesn't work.

I've tried different combinations like :
"i8042.nomux=1 locale=fr_FR i8042.noloop=1 i8042.reset=1"
or
"i8042.nomux=1 i8042.noloop=1 i8042.reset=1"
or
"i8042.nomux=1 i8042.reset=1"
even this one
""i8042.nomux i8042.noloop i8042.npnp i8042.reset"

Nothing is working. I don't try with different orders of i8042.xxxx may be the order is important.

If anybody has an idea. My laptop is a Workmann Terra Ultrabook 1450II.
whiteEagle
Level 2
Level 2
Posts: 60
Joined: Thu Aug 30, 2012 4:35 pm

Re: Touchpad not active on my Terra Laptop

Post by whiteEagle »

I'm having a similar problem on my Toshiba Satellite L775D-S7206 (Mint 16 Cinnamon, kernel 3.11.0-12.19)

Review the kernel parameters list for the meaning of i8042 options.

Code: Select all

i8042.debug	[HW] Toggle i8042 debug mode
i8042.direct	[HW] Put keyboard port into non-translated mode
i8042.dumbkbd	[HW] Pretend that controller can only read data from keyboard and cannot control its state (Don't attempt to blink the leds)
i8042.noaux	[HW] Don't check for auxiliary (== mouse) port
i8042.nokbd	[HW] Don't check/create keyboard port
i8042.noloop	[HW] Disable the AUX Loopback command while probing for the AUX port
i8042.nomux	[HW] Don't check presence of an active multiplexing controller
i8042.nopnp	[HW] Don't use ACPIPnP / PnPBIOS to discover KBD/AUX controllers
i8042.notimeout	[HW] Ignore timeout condition signalled by controller
i8042.reset	[HW] Reset the controller during init and cleanup
i8042.unlock	[HW] Unlock (ignore) the keylock
I have tried the combinations suggested but none have resolved the problem. I suspect it requires one specific command (or two) In my case, I could not use the 'Touch Pad' during or after installing Linux Mint 16 until I enabled it in 'All Settings' It's worked for 1 month. It seems to be an issue in Cinnamon or X
whiteEagle
Level 2
Level 2
Posts: 60
Joined: Thu Aug 30, 2012 4:35 pm

Re: Touchpad not active on my Terra Laptop

Post by whiteEagle »

IF you want to "see" what's happening with your hardware at boot, try 'dmesg' -- [WARNING: It's long so pipe it to 'more'!]

Here are snippets from my "display message" or "driver message" output:

Code: Select all

sudo dmesg | more
. . . . . . . .
[    0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.11.0-12-generic root=UUID=1a016925-e27d-44d3-aa62-b754d46427fb ro i8042.nomux=1 i8042.reset quiet splash vt.handoff=7
. . . . . . . .
[    1.099823] i8042: PNP: PS/2 Controller [PNP0303:PS2K,PNP0f13:PS2M] at 0x60,0x64 irq 1,12
[    1.102117] serio: i8042 KBD port at 0x60,0x64 irq 1
[    1.102123] serio: i8042 AUX port at 0x60,0x64 irq 12
[    1.102238] mousedev: PS/2 mouse device common for all mice
As you can see, I have 'i8042.nomux=1 i8042.reset' in my command line settings. As you can also see, I have only two i8042 ports: KBD and AUX (USB mouse)

'i8042.nomux=1' means "Don't check presence of an active multiplexing controller" which I believe you'd actually WANT to do! And, 'i8042.reset' means "Reset the controller during init and cleanup" which might allow X or Cinnamon to reset the controller once the kernel has loaded the PS/2 driver. That's more logical.

From this exercise, I'm seeing that my 'Touch Pad' is not appearing in the loaded drivers.

However, there's another way of "seeing" what your kernel sees:

Code: Select all

sudo dmidecode | more
. . . . . . . .
Handle 0x004A, DMI type 21, 7 bytes
Built-in Pointing Device
	Type: Touch Pad
	Interface: PS/2
	Buttons: 2
Here I find that my Toshiba "sees" the 'Touch Pad' which tells me the hardware is working properly.

I'm thinking 'i8042.reset' alone will work or 'i8042.noaux' which will disable the auxillary USB port I'm using for the mouse.

THAT'S NOT THE ANSWER! Running 'i8042.reset' alone put me in the unenviable position of having NO mouse or keyboard. I had to use 'Recovery Mode' to edit '/etc/default/grub' before I could boot into 'Software Rendering' mode.

Back to the drawing board!
whiteEagle
Level 2
Level 2
Posts: 60
Joined: Thu Aug 30, 2012 4:35 pm

Re: Touchpad not active on my Terra Laptop

Post by whiteEagle »

Running with NO CHANGES to '/etc/default/grub' -- i.e., GRUB_CMDLINE_LINUX="" produces the following:

Code: Select all

[    1.099930] i8042: PNP: PS/2 Controller [PNP0303:PS2K,PNP0f13:PS2M] at 0x60,0x64 irq 1,12
[    1.101299] i8042: Detected active multiplexing controller, rev 1.1
[    1.102322] serio: i8042 KBD port at 0x60,0x64 irq 1
[    1.102327] serio: i8042 AUX0 port at 0x60,0x64 irq 12
[    1.102347] serio: i8042 AUX1 port at 0x60,0x64 irq 12
[    1.102363] serio: i8042 AUX2 port at 0x60,0x64 irq 12
[    1.102379] serio: i8042 AUX3 port at 0x60,0x64 irq 12
[    1.102470] mousedev: PS/2 mouse device common for all mice
That's telling me that it "sees" ALL the 'i8042' ports, and it's loading the 'PS/2 mouse driver' for all of them.

The problem lies in the 'Synaptics Touch Pad' driver (apparently) That's controlled by X and/or Cinnamon. More research needed.

Code: Select all

sudo dmidecode | more
. . . . . . . .
Handle 0x0008, DMI type 8, 9 bytes
Port Connector Information
	Internal Reference Designator: J1A1
	Internal Connector Type: None
	External Reference Designator: PS2Mouse
	External Connector Type: PS/2
	Port Type: Mouse Port

Handle 0x0009, DMI type 8, 9 bytes
Port Connector Information
	Internal Reference Designator: J1A1
	Internal Connector Type: None
	External Reference Designator: Keyboard
	External Connector Type: PS/2
	Port Type: Keyboard Port
. . . . . . . .
Handle 0x004A, DMI type 21, 7 bytes
Built-in Pointing Device
	Type: Touch Pad
	Interface: PS/2
	Buttons: 2
Both BIOS and the kernel "sees" the 'Touch Pad' (and other PS/2 devices), so I doubt it's non-working hardware. It's a driver issue in X (IMO)
whiteEagle
Level 2
Level 2
Posts: 60
Joined: Thu Aug 30, 2012 4:35 pm

Re: Touchpad not active on my Terra Laptop

Post by whiteEagle »

There's another thread that seems relevant . . .

http://forums.linuxmint.com/viewtopic.p ... ad#p812360

Haven't resolved my problem yet (and will be gone for awhile) but I'll be looking into this suggestion.
whiteEagle
Level 2
Level 2
Posts: 60
Joined: Thu Aug 30, 2012 4:35 pm

Re: Touchpad not active on my Terra Laptop

Post by whiteEagle »

Here are a couple more ways to get at the hardware/software settings . . .

Code: Select all

xinput list
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad              	id=12	[slave  pointer  (2)]
⎜   ↳ B16_b_02 USB-PS/2 Optical Mouse         	id=10	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Power Button                            	id=8	[slave  keyboard (3)]
    ↳ CNF9055                                 	id=9	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=11	[slave  keyboard (3)]
As you can see, both my keyboard and touchpad are being correctly identified by X

Now looking at the properties of 'SynPS/2 Synaptics TouchPad' use 'id=12' . . .

Code: Select all

xinput list-props 12
Device 'SynPS/2 Synaptics TouchPad':
	Device Enabled (134):	1
	Coordinate Transformation Matrix (136):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	Device Accel Profile (257):	1
	Device Accel Constant Deceleration (258):	2.500000
	Device Accel Adaptive Deceleration (259):	1.000000
	Device Accel Velocity Scaling (260):	12.500000
	Synaptics Edges (280):	1767, 5397, 1637, 4451
	Synaptics Finger (281):	25, 30, 0
	Synaptics Tap Time (282):	180
	Synaptics Tap Move (283):	234
	Synaptics Tap Durations (284):	180, 180, 100
	Synaptics ClickPad (285):	0
	Synaptics Middle Button Timeout (286):	75
	Synaptics Two-Finger Pressure (287):	282
	Synaptics Two-Finger Width (288):	7
	Synaptics Scrolling Distance (289):	106, 106
	Synaptics Edge Scrolling (290):	1, 0, 0
	Synaptics Two-Finger Scrolling (291):	0, 0
	Synaptics Move Speed (292):	1.000000, 1.750000, 0.037460, 0.000000
	Synaptics Off (293):	0
	Synaptics Locked Drags (294):	0
	Synaptics Locked Drags Timeout (295):	5000
	Synaptics Tap Action (296):	2, 3, 0, 0, 1, 3, 0
	Synaptics Click Action (297):	1, 1, 0
	Synaptics Circular Scrolling (298):	0
	Synaptics Circular Scrolling Distance (299):	0.100000
	Synaptics Circular Scrolling Trigger (300):	0
	Synaptics Palm Detection (301):	0
	Synaptics Palm Dimensions (302):	10, 200
	Synaptics Coasting Speed (303):	20.000000, 50.000000
	Synaptics Pressure Motion (304):	30, 160
	Synaptics Pressure Motion Factor (305):	1.000000, 1.000000
	Synaptics Resolution Detect (306):	1
	Synaptics Grab Event Device (307):	1
	Synaptics Gestures (308):	1
	Synaptics Capabilities (309):	1, 0, 1, 1, 1, 1, 1
	Synaptics Pad Resolution (310):	102, 66
	Synaptics Area (311):	0, 0, 0, 0
	Synaptics Noise Cancellation (312):	26, 26
	Device Product ID (251):	2, 7
	Device Node (252):	"/dev/input/event10"
Again, as you can see, my touchpad is 'Enabled' BUT it's still not working!

. . . working on the theory of re-initializing it during X initialization described above . . .
krissam44
Level 1
Level 1
Posts: 5
Joined: Sun Jan 19, 2014 6:36 am

Re: Touchpad not active on my Terra Laptop

Post by krissam44 »

Thank you whiteEagle,

Here is that I found, so it seems my touchpad is not correctly identified by X.

Code: Select all

xinput list
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ Liteon Microsoft® Wireless Receiver 700 v2.0	id=11	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Power Button                            	id=8	[slave  keyboard (3)]
    ↳ Sleep Button                            	id=9	[slave  keyboard (3)]
    ↳ Liteon Microsoft® Wireless Receiver 700 v2.0	id=10	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=12	[slave  keyboard (3)]
I need some more help.
whiteEagle
Level 2
Level 2
Posts: 60
Joined: Thu Aug 30, 2012 4:35 pm

Re: Touchpad not active on my Terra Laptop

Post by whiteEagle »

We BOTH need some more help!

In my opinion, the fact 'xinput' is not showing the touchpad is bad news.

IF it's not shown in any of the other hardware queries (i.e., 'lshw,' 'dmesg' or 'dmidecode'), I'd say, "It's not working!" Either BIOS is not "seeing" it or the hardware itself is unplugged or failed! 'dmesg' in particular should show you that the kernel loaded it, and 'lshw' should show that it's loaded after boot.

IF not, it's a problem that 'synclient' and 'xinput' cannot fix. Check 'lshw' and 'dmesg' before you panic . . .

What are the circumstances? Is this just after a "fresh" installation, or is it after using it for some time?
whiteEagle
Level 2
Level 2
Posts: 60
Joined: Thu Aug 30, 2012 4:35 pm

Re: Touchpad not active on my Terra Laptop

Post by whiteEagle »

I've tried everything that's been suggested to get my Synaptics Touchpad working to no avail.

Pursuant to a comment on the Arch-Wiki, I looked at 'Xorg.0.log' . . .

Code: Select all

[    22.118] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event10)
[    22.118] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[    22.118] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[    22.118] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "Default clickpad buttons"
[    22.118] (II) LoadModule: "synaptics"
[    22.118] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[    22.118] (II) Module synaptics: vendor="X.Org Foundation"
[    22.118] 	compiled for 1.14.2, module version = 1.7.1
[    22.118] 	Module class: X.Org XInput Driver
[    22.118] 	ABI class: X.Org XInput driver, version 19.1
[    22.118] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[    22.118] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    22.118] (**) Option "Device" "/dev/input/event10"
[    22.144] (II) synaptics: SynPS/2 Synaptics TouchPad: ignoring touch events for semi-multitouch device
[    22.144] (--) synaptics: SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5692 (res 66)
[    22.144] (--) synaptics: SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4680 (res 102)
[    22.144] (--) synaptics: SynPS/2 Synaptics TouchPad: pressure range 0 - 255
[    22.144] (--) synaptics: SynPS/2 Synaptics TouchPad: finger width range 0 - 15
[    22.144] (--) synaptics: SynPS/2 Synaptics TouchPad: buttons: left right double triple
[    22.144] (--) synaptics: SynPS/2 Synaptics TouchPad: Vendor 0x2 Product 0x7
[    22.144] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[    22.144] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    22.156] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio2/input/input10/event10"
[    22.156] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD, id 12)
[    22.156] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[    22.156] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MaxSpeed is now 1.75
[    22.156] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) AccelFactor is now 0.037
[    22.156] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[    22.156] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[    22.156] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[    22.156] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[    22.156] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[    22.156] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse1)
[    22.156] (**) SynPS/2 Synaptics TouchPad: Ignoring device from InputClass "touchpad ignore duplicates"
I was most interested in . . .

Code: Select all

[    22.118] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event10)
[    22.118] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[    22.118] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
. . . which the Arch-Wiki says "In some cases, this causes the touchpad to become nonfunctional."

However, when I query '/usr/share/X11/xorg.conf.d/50-synaptics.conf,' I find the resolution is already added . . .

Code: Select all

Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
      MatchDevicePath "/dev/input/event*"
EndSection
It's the last line MatchDevicePath "/dev/input/event*" that's required, and it's already added!

So, there may still be a duplicate loading of the touchpad driver . . .

Check http://who-t.blogspot.com/2010/11/how-t ... rrors.html . . .
In both cases, you'll notice that the device gets added twice. Once with a /dev/input/eventX device path, and once with a /dev/input/mouseX path. The first one succeeds and that results in your device being added to the X server's device list. The second one fails because both evdev and synaptics try to use an ioctl that is only available on event devices. The errors do not indicate a driver bug but a misconfiguration. The local configuration needs to be adjusted to avoid non-event devices being assigned to evdev or synaptics.

Look at the synaptics xorg.conf.d snippet we ship in Fedora:


Section "InputClass"
Identifier "touchpad catchall"
Driver "synaptics"
MatchIsTouchpad "on"
MatchDevicePath "/dev/input/event*"
EndSection



That last line is important. It only tries to assign the synaptics driver to event devices, not to mouse devices. Once you've added that line (or poked your distro maintainer to do it for you), the errors will go away. Alternatively, you could just ignore the errors and not file a bug for it :)
Where do we go from here? The suggestion to add 'Synclient' commands to 'Startup Programs' has not worked for me (nor the 'grub-update' suggestion)
Post Reply

Return to “Hardware Support”