DMESG Entries - Various Errors inc ACPI.?

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Wirezfree
Level 1
Level 1
Posts: 33
Joined: Mon Jan 06, 2014 7:30 pm

DMESG Entries - Various Errors inc ACPI.?

Postby Wirezfree » Sun Feb 02, 2014 8:36 am

Hello All,

Hope this is the correct section,an old newb here. I'm working through setting up my HP i5 Laptop with LM16 - Cinnamon.
I have spent quite a lot of time googling to find answers, but have not been successful.
> I have looked on HP website for drivers, nothing other than Windows drivers
> Found references to Intel microcode updates, they are are in synaptic download, but I'm not sure how to update
> lshw shows CPU & Firmware capabilities for "acpi" support.
> Grub line currently set: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=linux acpi_backlight=vendor"
( acpi_backlight=vendor this resolved Black screen when first installed, the acpi_osi=linux seemed to be often recommended?)

The dmesg file is quite big, being new, some of these maybe normal.?
I have copied the sections which appear to have some kind of errors/warnings/failures or unusual messages = invalid/bailing/killed/tainting.?
(I can post all if required.)

Code: Select all

[    0.000000] Checking aperture...
[    0.000000] No AGP bridge found
[    0.000000] Calgary: detecting Calgary via BIOS EBDA area
[    0.000000] Calgary: Unable to locate Rio Grande table in EBDA - bailing!
[    0.000000] Memory: 16176400K/16546096K available (7141K kernel code, 1082K rwdata, 3260K rodata, 1364K init, 1420K bss, 369696K reserved)
[    0.000000] SLUB: HWalign=64, Order=0-3, MinObjects=0, CPUs=8, Nodes=1
[    0.000000] Hierarchical RCU implementation.
[    0.000000]    RCU dyntick-idle grace-period acceleration is enabled.
[    0.000000]    RCU restricting CPUs from NR_CPUS=256 to nr_cpu_ids=8.
[    0.000000]    Offload RCU callbacks from all CPUs
[    0.000000]    Offload RCU callbacks from CPUs: 0-255.
[    0.000000] NR_IRQS:16640 nr_irqs:1016 16
[    0.000000] Console: colour dummy device 80x25
[    0.000000] console [tty0] enabled
[    0.000000] allocated 66584576 bytes of page_cgroup
[    0.000000] please try 'cgroup_disable=memory' option if you don't want memory cgroups
[    0.000000] hpet clockevent registered

[    7.274145] ACPI: Interpreter enabled
[    7.274157] ACPI Exception: AE_NOT_FOUND, While evaluating Sleep State [\_S1_] (20130517/hwxface-571)
[    7.274166] ACPI Exception: AE_NOT_FOUND, While evaluating Sleep State [\_S2_] (20130517/hwxface-571)
[    7.274193] ACPI: (supports S0 S3 S4 S5)

[    7.274195] ACPI: Using IOAPIC for interrupt routing
[    7.274236] PCI: Using host bridge windows from ACPI; if necessary, use "pci=nocrs" and report a bug
[    7.274378] ACPI: No dock devices found.
[    7.284375] ACPI: PCI Root Bridge [PCI0] (domain 0000 [bus 00-fe])
[    7.284476] \_SB_.PCI0:_OSC invalid UUID
[    7.284478] _OSC request data:1 8 0
[    7.284541] \_SB_.PCI0:_OSC invalid UUID
[    7.284542] _OSC request data:1 1f 0
[    7.284547] acpi PNP0A08:00: ACPI _OSC support notification failed, disabling PCIe ASPM
[    7.284549] acpi PNP0A08:00: Unable to request _OSC control (_OSC support mask: 0x08)

[    8.005141] ACPI: Power Button [PWRB]
[    8.005187] input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input2
[    8.005190] ACPI: Power Button [PWRF]
[    8.005265] ACPI: Requesting acpi_cpufreq
[    8.006458] [Firmware Bug]: Invalid critical threshold (0)
[    8.008009] thermal LNXTHERM:00: registered as thermal_zone0
[    8.008012] ACPI: Thermal Zone [TZ01] (40 C)
[    8.008041] GHES: HEST is not enabled!

[    8.550903] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[    8.550906] EDD information not available.
[    8.561634] ACPI: Battery Slot [BAT0] (battery present)

[    8.581028] systemd-udevd[124]: starting version 204
[    8.593235] video: module verification failed: signature and/or required key missing - tainting kernel
[    8.596820] [drm] Initialized drm 1.1.0 20060810

[    8.602549] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
[    8.602559] r8169 0000:09:00.0: can't disable ASPM; OS doesn't have ASPM control
[    8.607975] r8169 0000:09:00.0: irq 58 for MSI/MSI-X
[    8.608167] r8169 0000:09:00.0 eth0: RTL8106e at 0xffffc90001858000, a0:48:1c:20:8a:81, XID 10900800 IRQ 58

[   10.346636] Console: switching to colour frame buffer device 170x48
[   10.351175] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[   10.351177] i915 0000:00:02.0: registered panic notifier
[   10.353110] ACPI: Video Device [GFX0] (multi-head: yes  rom: no  post: no)
[   10.353171] input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A08:00/LNXVIDEO:00/input/input4

[   20.288883] systemd-udevd[416]: failed to execute '/lib/udev/mtp-probe' 'mtp-probe /sys/devices/pci0000:00/0000:00:14.0/usb2/2-3 2 2': No such file or directory
[   20.296181] ACPI Warning: 0x0000000000001828-0x000000000000182f SystemIO conflicts with Region \PMIO 1 (20130517/utaddress-251)
[   20.296189] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   20.296193] ACPI Warning: 0x0000000000000830-0x000000000000083f SystemIO conflicts with Region \GPRL 1 (20130517/utaddress-251)
[   20.296198] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   20.296199] ACPI Warning: 0x0000000000000800-0x000000000000082f SystemIO conflicts with Region \GPRL 1 (20130517/utaddress-251)
[   20.296203] ACPI Warning: 0x0000000000000800-0x000000000000082f SystemIO conflicts with Region \IO_D 2 (20130517/utaddress-251)
[   20.296207] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   20.296208] lpc_ich: Resource conflict(s) found affecting gpio_ich

[   20.365902] hda_codec: invalid CONNECT_LIST verb 5[1]:0
[   20.365961] hda_codec: invalid CONNECT_LIST verb 6[1]:0
[   20.366026] hda_codec: invalid CONNECT_LIST verb 7[1]:0

[   20.808867] kvm: disabled by bios
[   20.813335] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
[   20.833885] kvm: disabled by bios

[   21.567829] input: PS/2 Generic Mouse as /devices/platform/i8042/serio1/input/input13
[   21.966606] init: failsafe main process (703) killed by TERM signal


Any assistance greatly received.

Thanks... David

User avatar
mank_in
Level 6
Level 6
Posts: 1359
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: DMESG Entries - Various Errors inc ACPI.?

Postby mank_in » Sun Feb 02, 2014 1:08 pm

Is there something incorrectly/not working with your laptop :?:

I look at my 2 PC ( destop and netbook ) and find a few warning about ACPI too.
This one from my desktop ( use LM 14 since december 2012 and didn't have problem)

Code: Select all

dmesg | grep -i warning


Code: Select all

[    0.080061] ACPI Warning: Incorrect checksum in table [TAMG] - 0x99, should be 0x98 (20120320/tbutils-323)
[   12.120531] ACPI Warning: 0x00000460-0x0000047f SystemIO conflicts with Region \TCOI 1 (20120320/utaddress-251)
[   12.120543] ACPI Warning: 0x00000428-0x0000042f SystemIO conflicts with Region \GP2C 1 (20120320/utaddress-251)
Image
Sorry for my bad English , I am Indonesian.

Wirezfree
Level 1
Level 1
Posts: 33
Joined: Mon Jan 06, 2014 7:30 pm

Re: DMESG Entries - Various Errors inc ACPI.?

Postby Wirezfree » Sun Feb 02, 2014 7:07 pm

Hello Mank,

At present I have made my install(Display) work by adding the "acpi=vendor"
When it boots, it is full "Brightness", I adjust brightness with correct keys on keyboard, and the OSD even works.
So I'm not sure if there is a better solution than "acpi=vendor"..?
Maybe having this is what is giving the entries in DMESG, I don't know.?
I have found some possible work arounds with an echo > command, but only works at root, also Xbacklight -set nn

I have seen reference to Intel Microcode and Intel Drivers, but they seem a bit of a challenge for me...
I'm very, very new to Linux, Windows user since 2.1, so I'm just looking for guidance.

Thanks... Davi

Wirezfree
Level 1
Level 1
Posts: 33
Joined: Mon Jan 06, 2014 7:30 pm

Re: DMESG Entries - Various Errors Update + 1 SOLVED Item

Postby Wirezfree » Wed Feb 05, 2014 12:36 pm

UPDATE + 1 SOLVED Item

If my Googling/Reading/understanding is correct the following are all "Bugs" or "To be Expected"

[ 0.000000] ACPI Error: Gpe0Block - 32-bit FADT register is too long (32 bytes, 256 bits) to convert to GAS struct - 255 bits max, truncating (20130517/tbfadt-202)

[ 0.000000] Calgary: Unable to locate Rio Grande table in EBDA - bailing!

[ 7.274157] ACPI Exception: AE_NOT_FOUND, While evaluating Sleep State [\_S1_] (20130517/hwxface-571)
[ 7.274166] ACPI Exception: AE_NOT_FOUND, While evaluating Sleep State [\_S2_] (20130517/hwxface-571)

[ 7.274236] PCI: Using host bridge windows from ACPI; if necessary, use "pci=nocrs" and report a bug
[ 7.284476] \_SB_.PCI0:_OSC invalid UUID
[ 7.284478] _OSC request data:1 8 0
[ 7.284541] \_SB_.PCI0:_OSC invalid UUID
[ 7.284542] _OSC request data:1 1f 0
[ 7.284547] acpi PNP0A08:00: ACPI _OSC support notification failed, disabling PCIe ASPM
[ 7.284549] acpi PNP0A08:00: Unable to request _OSC control (_OSC support mask: 0x08)

[ 8.006458] [Firmware Bug]: Invalid critical threshold (0)

[ 8.593235] video: module verification failed: signature and/or required key missing - tainting kernel

[ 8.602559] r8169 0000:09:00.0: can't disable ASPM; OS doesn't have ASPM control

[ 10.351177] i915 0000:00:02.0: registered panic notifier

[ 20.296181] ACPI Warning: 0x0000000000001828-0x000000000000182f SystemIO conflicts with Region \PMIO 1 (20130517/utaddress-251)
[ 20.296189] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[ 20.296193] ACPI Warning: 0x0000000000000830-0x000000000000083f SystemIO conflicts with Region \GPRL 1 (20130517/utaddress-251)
[ 20.296198] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[ 20.296199] ACPI Warning: 0x0000000000000800-0x000000000000082f SystemIO conflicts with Region \GPRL 1 (20130517/utaddress-251)
[ 20.296203] ACPI Warning: 0x0000000000000800-0x000000000000082f SystemIO conflicts with Region \IO_D 2 (20130517/utaddress-251)
[ 20.296207] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[ 20.296208] lpc_ich: Resource conflict(s) found affecting gpio_ich

[ 20.365902] hda_codec: invalid CONNECT_LIST verb 5[1]:0
[ 20.365961] hda_codec: invalid CONNECT_LIST verb 6[1]:0
[ 20.366026] hda_codec: invalid CONNECT_LIST verb 7[1]:0

[ 21.966606] init: failsafe main process (703) killed by TERM signal

Regarding the following, inc 1 [SOLVED item]:

[ 0.000000] allocated 66584576 bytes of page_cgroup
[ 0.000000] please try 'cgroup_disable=memory' option if you don't want memory cgroups
>> Plenty of references, but I have not found "where" to disable it yet

[ 0.195262] ACPI: SSDT (null) 00119 (v01 PmRef ApCst 00003000 INTL 20121220)
[ 7.274145] ACPI: Interpreter enabled
>> Not been able to figure out this 7 sec gap/delay..??

[ 10.608762] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[ 20.062368] Adding 19999740k swap on /dev/sda2. Priority:-1 extents:1 across:19999740k FS
>> Not been able to figure out this 10+sec gap/delay..??

[ 20.288883] systemd-udevd[416]: failed to execute '/lib/udev/mtp-probe' 'mtp-probe /sys/devices/pci0000:00/0000:00:14.0/usb2/2-3 2 2': No such file or directory
>> SOLVED by installing

Code: Select all

 libmtp-runtime

Apparently a bug in the mtp package dependency list

[ 20.833885] kvm: disabled by bios
>> Apparently this is related to Virtualisation(VT) not being enabled in BIOS
In my BIOS, no option exists to enable it...


Return to “Hardware Support”