Page 1 of 1

Cute But Mute - Seriously Need Help

Posted: Mon Sep 22, 2008 8:24 pm
by garda
I finished installing Elyssa on another PC about eight hours ago, but I have yet seen any pleasing results from everything I've attempted in order to resolve one particular issue since then: not getting sound in Elyssa. I've searched the web, and stumbled upon this extremely long thread in Ubuntu forums: Comprehensive Sound Problem Solutions Guide. But, for what it's worth, reading through a very extensive forum thread doesn't always help (the initial post was made in 2006 while the last post is dated Sep. 23rd, 2008). I spent hours reading through the entire thread and trying out any possible workarounds, still with no luck.

I'm seriously in need of help with this. So, here are the relevant outputs generated by entering some commands:

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: AudioPCI [Ensoniq AudioPCI], device 0: ES1371/1 [ES1371 DAC2/ADC]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: AudioPCI [Ensoniq AudioPCI], device 1: ES1371/2 [ES1371 DAC1]
Subdevices: 1/1
Subdevice #0: subdevice #0

$ lspci -v [Only the lines related to the sound card are posted here]
00:09.0 Multimedia audio controller: Creative Labs Ectiva EV1938
Subsystem: Creative Labs Unknown device 5938
Flags: bus master, slow devsel, latency 32, IRQ 10
I/O ports at d000
I/O ports at d400
Capabilities: <access denied>

The sound card is a Creative Labs Sound Blaster Vibra 128 PCI, detected as Ensoniq ES1371/Ensoniq AudioPCI in Mint.

Any help/advice is greatly appreciated.

Thank you in advance.

Re: Cute But Mute - Seriously Need Help

Posted: Wed Sep 24, 2008 7:09 am
by Husse
I fear it takes a long time for me to search this out but I know there is something odd with the SB128 Ensoniq
I'll mark this as unsolved and come back to you - I think I can get good help with this one

Re: Cute But Mute - Seriously Need Help

Posted: Wed Sep 24, 2008 7:12 am
by garda
I look forward to that. It's been over a day now and I'm desperately at the end of the rope.

EDIT: If I switch to console mode at GDM screen (CTRL+ALT+F1) and enter these commands:

$ sudo modprobe -r snd-ens1371
$ sudo modprobe snd-ens1371

I'd hear a knocking sound (pretty clearly) coming off the speaker. But once logged in, I never get any sound. And I've also made sure that both the Mixer and speaker are not set to mute.



Re: Cute But Mute - Seriously Need Help

Posted: Mon Sep 29, 2008 7:21 am
by Husse
The SB 128 card is a strange card and it can be lots of different things
A chip from Creative or from Ensoniq or several different chips from these two.... Should not create to much problems I thought, but...
Try to add acpi=ht as a boot option - like this

Code: Select all

kernel		/boot/vmlinuz-2.6.24-16-generic root=/dev/sda2 ro acpi=ht quiet splash
in /boot/grub/menu.lst
This is much a shot in the dark, but it might work :roll:

Re: Cute But Mute - Seriously Need Help

Posted: Mon Oct 27, 2008 9:59 am
by garda

Sorry about this very late reply. The last few weeks had been very busy. I just want to report that the workaround you offered doesn't solve the sound problem. Anyway, I tried installing a few other distros there on her computer and Mandriva 2007 was the only one on which sound worked normally right out of the box. I think it ALSA is the root of the problem since Mandriva 2007 automatically uses OSS for this soundcard.

However, I think she's pretty happy with the aforementioned distro right now so I guess I'll just save the hassle for later, should she decide to switch back to Mint. Thank you for the effort you've put into this, I appreciate it. :D